VCOM:VectorWorks:Filing:IFileIdentifier::DuplicateOnDisk

From Vectorworks Developer
Revision as of 15:01, 26 February 2014 by Maarten (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileIdentifier

Duplicates this file into another file on the disk. The file must exist in the OS.

Be aware, if the file does not exist, an empty file is created. The error output will be 0 (no error). This is on Windows, VW2014.

virtual VCOMError VCOM_CALLTYPE DuplicateOnDisk(
IFileIdentifier *pDestFileID,
bool bOverwrite) = 0;

Parameters

pDestFileID IFileIdentifier* The new file into which this should be duplicated.
bOverwrite bool true to override if the file already exist; false -- the function will fail if the file exist.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]