VCOM:VectorWorks:Extension:ILeaderLineProvider::SetLabelPt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:ILeaderLineProvider]]
Member of [[VCOM:VectorWorks:Extension:ILeaderLineProvider]]


...put some description here...
Sets position for the leader line label point.
 
The position change is triggered by the Align/Distribute Leader Lines command so this function implements how the object will use the new position.  
</desc>
</desc>


Line 26: Line 28:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
the object which provides leader line shoulder point.
</line>
</line>
<line>
<line>
pt
pt
const [[SDK:WorldPt]]&
const [[SDK:WorldPt]]&
no info.
new position.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 13:19, 5 September 2014

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:ILeaderLineProvider

Sets position for the leader line label point.

The position change is triggered by the Align/Distribute Leader Lines command so this function implements how the object will use the new position.

virtual VCOMErrorVCOM_CALLTYPE SetLabelPt(
MCObjectHandle hObject,
const WorldPt& pt) = 0;

Parameters

hObject MCObjectHandle the object which provides leader line shoulder point.
pt const SDK:WorldPt& new position.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.