VCOM:VectorWorks:Extension:ILeaderLineProvider::GetLeaderLinePt

From Vectorworks Developer
Revision as of 13:08, 5 September 2014 by Bstanchev (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:ILeaderLineProvider

Gets the position of the leader line shoulder point.

virtual VCOMErrorVCOM_CALLTYPE GetLeaderLinePt(
MCObjectHandle hObject,
WorldPt& outPt) = 0;

Parameters

hObject MCObjectHandle the object which provides leader line shoulder point.
outPt SDK:WorldPt& the position.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.