VCOM:VectorWorks:Extension:ILeaderLineProvider::GetLeaderLinePt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:ILeaderLineProvider]]
Member of [[VCOM:VectorWorks:Extension:ILeaderLineProvider]]


...put some description here...
Gets the position of the leader line shoulder point.
</desc>
</desc>


Line 26: Line 26:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
the object which provides leader line shoulder point.
</line>
</line>
<line>
<line>
outPt
outPt
[[SDK:WorldPt]]&
[[SDK:WorldPt]]&
no info.
the position.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 13:08, 5 September 2014

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:ILeaderLineProvider

Gets the position of the leader line shoulder point.

virtual VCOMErrorVCOM_CALLTYPE GetLeaderLinePt(
MCObjectHandle hObject,
WorldPt& outPt) = 0;

Parameters

hObject MCObjectHandle the object which provides leader line shoulder point.
outPt SDK:WorldPt& the position.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.