VCOM:VectorWorks:Extension:IDocumentShadowSupport: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 13:18, 19 September 2013

Description

namespace VectorWorks::Extension

..put some descriptoin in here...

Interface

...put the class definition, including the UUID, here...

Members

GetShadowOffset
SetShadowOffset
GetShadowOffsetUnit
SetShadowOffsetUnit
GetShadowAngle
SetShadowAngle
GetShadowOpacity
SetShadowOpacity
GetShadowOpacityByClass
SetShadowOpacityByClass
GetShadowFillStyle
SetShadowFillStyle
GetShadowSolidColorRef
SetShadowSolidColorRef
GetShadowFillStyleName
SetShadowFillStyleName
ApplyShadowSettings
LoadDefaults

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IDocumentShadowSupport interface:

typedef VCOMPtr<IDocumentShadowSupport>  IDocumentShadowSupportPtr;

Version

Available from: Vectorworks 2014

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]