VCOM:VectorWorks:Extension:IDTMTIN::GetVisibleContours: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Extension:IDTMTIN]]
Member of [[VCOM:VectorWorks:Extension:IDTMTIN]]


...put some description here...
Gets visible contours.
The returned information for every contour is:
contour 2D polygon, contour index in the model, contour elevation in document coordinates, if it is a major contour.
Depending on the Site model's settings gets the contour polygon or the smoothed contour polygon.
</desc>
</desc>


Line 25: Line 28:
outArrContours
outArrContours
TVWArray_TINContour&
TVWArray_TINContour&
no info.
resulting array with informations for each contours.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 08:48, 17 October 2013

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

Gets visible contours. The returned information for every contour is: contour 2D polygon, contour index in the model, contour elevation in document coordinates, if it is a major contour. Depending on the Site model's settings gets the contour polygon or the smoothed contour polygon.

virtual VCOMErrorVCOM_CALLTYPE GetVisibleContours(
TVWArray_TINContour& outArrContours) = 0;

Parameters

outArrContours TVWArray_TINContour& resulting array with informations for each contours.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.