VCOM:VectorWorks:Extension:IDTMTIN::GetBoundedVolumeInfo

From Vectorworks Developer
Revision as of 18:53, 18 September 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

...put some description here...

virtual VCOMErrorVCOM_CALLTYPE GetBoundedVolumeInfo(
IPolyDef* inBoundPoly2D,
double& outVolumeExisting,
double& outVolumeProposed) = 0;

Parameters

inBoundPoly2D IPolyDef* no info.
outVolumeExisting double& no info.
outVolumeProposed double& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.