VCOM:VectorWorks:Extension:IDTMTIN::GetBoundedVolumeInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Extension:IDTMTIN]]
Member of [[VCOM:VectorWorks:Extension:IDTMTIN]]


...put some description here...
// Calculates the volume informations from the region of the Site model under the bounding poly.
</desc>
</desc>


Line 25: Line 25:
inBoundPoly2D
inBoundPoly2D
IPolyDef*
IPolyDef*
no info.
the bounding poly.
</line>
</line>
<line>
<line>
outVolumeExisting
outVolumeExisting
double&
double&
no info.
resulting existing volume.
</line>
</line>
<line>
<line>
outVolumeProposed
outVolumeProposed
double&
double&
no info.
resulting proposed volume.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 08:33, 17 October 2013

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

// Calculates the volume informations from the region of the Site model under the bounding poly.

virtual VCOMErrorVCOM_CALLTYPE GetBoundedVolumeInfo(
IPolyDef* inBoundPoly2D,
double& outVolumeExisting,
double& outVolumeProposed) = 0;

Parameters

inBoundPoly2D IPolyDef* the bounding poly.
outVolumeExisting double& resulting existing volume.
outVolumeProposed double& resulting proposed volume.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.