VCOM:VectorWorks:Extension:IDTMTIN::GetBoundedVolumeInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 18:53, 18 September 2013

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

...put some description here...

virtual VCOMErrorVCOM_CALLTYPE GetBoundedVolumeInfo(
IPolyDef* inBoundPoly2D,
double& outVolumeExisting,
double& outVolumeProposed) = 0;

Parameters

inBoundPoly2D IPolyDef* no info.
outVolumeExisting double& no info.
outVolumeProposed double& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.