VCOM:VectorWorks:Extension:IDBVariant::GetBinary: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:IDBVariant]]
Member of [[VCOM:VectorWorks:Extension:IDBVariant]]


...put some description here...
Returns the binary value. The buffer for value should be big enough.
</desc>
</desc>


Line 16: Line 16:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual voidVCOM_CALLTYPE GetBinary(void* value, size_t& size) = 0;
virtual void VCOM_CALLTYPE GetBinary(void* value, size_t& size) = 0;
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 26:
value
value
void*
void*
no info.
Output parameter for the result.
</line>
</line>
<line>
<line>
size
size
size_t&
size_t&
no info.
Input/output parameter. As input parameter this is the buffer size. As output parameter is the result size.
</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>
Uses standard [[VCOM:VCOMError|VCOM Error Reporting]].
Return value meaning:
<lineList ident=1>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
</line>
<line>
kVCOMError_Failed
Routine failed.
</line>
</lineList>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 06:38, 11 December 2015

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBVariant

Returns the binary value. The buffer for value should be big enough.

virtual void VCOM_CALLTYPE GetBinary(
void* value,
size_t& size) = 0;

Parameters

value void* Output parameter for the result.
size size_t& Input/output parameter. As input parameter this is the buffer size. As output parameter is the result size.