VCOM:VectorWorks:Extension:IDBDatabase::SetTransactionMode

From Vectorworks Developer
Revision as of 11:16, 2 November 2015 by Sasha (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBDatabase

Sets the commit mode of the driver. The driver uses manual-commit mode or auto-commit mode. If you want to use transactions you need to set the commit mode to manual and to use Commit and Rollback functions.

virtual VCOMError VCOM_CALLTYPE SetTransactionMode(
ECommitMode commitMode) = 0;

Parameters

commitMode ECommitMode Commit mode. Possible values are eCommitMode_Default, eCommitMode_Auto, eCommitMode_Manual.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.