VCOM:VectorWorks:Extension:IDBDatabase::SetTransactionMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]


...put some description here...
Sets the commit mode of the driver. The driver uses manual-commit mode or auto-commit mode. If you want to use transactions you need to set the commit mode to '''manual''' and to use [[VCOM:VectorWorks:Extension:IDBDatabase::Commit|Commit]] and [[VCOM:VectorWorks:Extension:IDBDatabase::Rollback|Rollback]] functions.
</desc>
</desc>


Line 16: Line 16:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE SetTransactionMode(ECommitMode commitMode) = 0;
virtual VCOMError VCOM_CALLTYPE SetTransactionMode(ECommitMode commitMode) = 0;
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 26:
commitMode
commitMode
ECommitMode
ECommitMode
no info.
Commit mode. Possible values are eCommitMode_Default, eCommitMode_Auto, eCommitMode_Manual.
</line>
</line>
</lineList>
</lineList>
Line 45: Line 45:
Routine failed.
Routine failed.
</line>
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</lineList>
</lineList>
</return>
</return>

Latest revision as of 11:16, 2 November 2015

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBDatabase

Sets the commit mode of the driver. The driver uses manual-commit mode or auto-commit mode. If you want to use transactions you need to set the commit mode to manual and to use Commit and Rollback functions.

virtual VCOMError VCOM_CALLTYPE SetTransactionMode(
ECommitMode commitMode) = 0;

Parameters

commitMode ECommitMode Commit mode. Possible values are eCommitMode_Default, eCommitMode_Auto, eCommitMode_Manual.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.