VCOM:VectorWorks:Extension:IDBDatabase::ListTables: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]


...put some description here...
Returns a list of table names in the data source.
</desc>
</desc>


Line 16: Line 16:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE ListTables(bool includeViews, bool includeSystemTables, TXStringArray& outArrTables) = 0;
virtual VCOMError VCOM_CALLTYPE ListTables(bool includeViews, bool includeSystemTables, TXStringArray& outArrTables) = 0;
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 26:
includeViews
includeViews
bool
bool
no info.
Include views as tables in the result list.
</line>
</line>
<line>
<line>
includeSystemTables
includeSystemTables
bool
bool
no info.
Include system tables in the result list.
</line>
</line>
<line>
<line>
outArrTables
outArrTables
TXStringArray&
TXStringArray&
no info.
Result list.
</line>
</line>
</lineList>
</lineList>
Line 49: Line 49:
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 55: Line 55:
Routine failed.
Routine failed.
</line>
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</lineList>
</lineList>
</return>
</return>

Latest revision as of 11:31, 2 November 2015

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBDatabase

Returns a list of table names in the data source.

virtual VCOMError VCOM_CALLTYPE ListTables(
bool includeViews,
bool includeSystemTables,
TXStringArray& outArrTables) = 0;

Parameters

includeViews bool Include views as tables in the result list.
includeSystemTables bool Include system tables in the result list.
outArrTables TXStringArray& Result list.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.