VCOM:VectorWorks:Extension:IDBDatabase::IsInTransactionMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]


...put some description here...
Checks if the database is in transaction mode. By default most of the drivers are in auto commit mode. If you want to use transactions you have to use the [[VCOM:VectorWorks:Extension:IDBDatabase::SetTransactionMode|SetTransactionMode]] function.
</desc>
</desc>


Line 16: Line 16:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual boolVCOM_CALLTYPE IsInTransactionMode() = 0;
virtual bool VCOM_CALLTYPE IsInTransactionMode() = 0;
</funcDef>
</funcDef>
</def>
</def>
Line 28: Line 28:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
Uses standard [[VCOM:VCOMError|VCOM Error Reporting]].
Returns '''true''' if the connection is in transaction mode.
 
Return value meaning:
<lineList ident=1>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
</line>
<line>
kVCOMError_Failed
Routine failed.
</line>
</lineList>
</return>
</return>



Latest revision as of 11:09, 2 November 2015

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBDatabase

Checks if the database is in transaction mode. By default most of the drivers are in auto commit mode. If you want to use transactions you have to use the SetTransactionMode function.

virtual bool VCOM_CALLTYPE IsInTransactionMode( ) = 0;

Parameters

Return Value

Returns true if the connection is in transaction mode.