VCOM:VectorWorks:Extension:IDBDatabase::GetNumRowsN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]


...put some description here...
Returns count of rows in the table.
</desc>
</desc>


Line 16: Line 16:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE GetNumRowsN(const TXString& inTableName, int driverNoToDoTheJob, size_t& outCnt) = 0;
virtual VCOMError VCOM_CALLTYPE GetNumRowsN(const TXString& inTableName, int driverNoToDoTheJob, size_t& outCnt) = 0;
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 26:
inTableName
inTableName
const [[SDK:TXString]]&
const [[SDK:TXString]]&
no info.
Table name.
</line>
</line>
<line>
<line>
driverNoToDoTheJob
driverNoToDoTheJob
int
int
no info.
Driver number to execute the query..
</line>
</line>
<line>
<line>
outCnt
outCnt
size_t&
size_t&
no info.
Out parameter - the count of rows in the table.
</line>
</line>
</lineList>
</lineList>
Line 49: Line 49:
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 55: Line 55:
Routine failed.
Routine failed.
</line>
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</lineList>
</lineList>
</return>
</return>

Latest revision as of 12:02, 2 November 2015

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBDatabase

Returns count of rows in the table.

virtual VCOMError VCOM_CALLTYPE GetNumRowsN(
const TXString& inTableName,
int driverNoToDoTheJob,
size_t& outCnt) = 0;

Parameters

inTableName const SDK:TXString& Table name.
driverNoToDoTheJob int Driver number to execute the query..
outCnt size_t& Out parameter - the count of rows in the table.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:


kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.