VCOM:VectorWorks:Extension:IDBDatabase::DoTableExists: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]


...put some description here...
Checks if the table exist.
</desc>
</desc>


Line 16: Line 16:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual boolVCOM_CALLTYPE DoTableExists(const TXString& table) = 0;
virtual bool VCOM_CALLTYPE DoTableExists(const TXString& table) = 0;
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 26:
table
table
const [[SDK:TXString]]&
const [[SDK:TXString]]&
no info.
Table name.
</line>
</line>
</lineList>
</lineList>
Line 39: Line 39:
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 10:54, 2 November 2015

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBDatabase

Checks if the table exist.

virtual bool VCOM_CALLTYPE DoTableExists(
const TXString& table) = 0;

Parameters

table const SDK:TXString& Table name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.