VCOM:VectorWorks:Extension:IDBDatabase::ConnectWithBrowserN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]


This function works only on Windows. On other platforms returns "not implemented". It uses the OS ODBC API function SQLDriverConnect and it opens the "Select Data Source" dialog.
This function works '''only''' on Windows. On other platforms returns "not implemented". It uses the OS ODBC API function SQLDriverConnect and it opens the "Select Data Source" dialog.
</desc>
</desc>



Latest revision as of 12:24, 2 November 2015

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBDatabase

This function works only on Windows. On other platforms returns "not implemented". It uses the OS ODBC API function SQLDriverConnect and it opens the "Select Data Source" dialog.

virtual VCOMError VCOM_CALLTYPE ConnectWithBrowserN(
TXString& outConnectionString) = 0;

Parameters

outConnectionString SDK:TXString& Completed connection string.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

<line> kVCOMError_NoError Routine succeeded. <line>

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.