VCOM:VectorWorks:Extension:IDBDatabase::ConnectWithBrowser: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
mNo edit summary
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]


This function works '''only''' on Windows. On other platforms returns "not implemented". It uses the OS ODBC API function SQLDriverConnect and it opens the "Select Data Source" dialog, shown below.
This function works '''only''' on Windows. On other platforms returns "not implemented". It uses the OS ODBC API function SQLDriverConnect and it opens the "Select Data Source" dialog.
 
[[File:Https://drive.google.com/open?id=0B LnY1IxRyyabElUanZlSUo0eUE|thumbnail|Select Data Source]]
 
</desc>
</desc>



Revision as of 08:44, 2 November 2015

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBDatabase

This function works only on Windows. On other platforms returns "not implemented". It uses the OS ODBC API function SQLDriverConnect and it opens the "Select Data Source" dialog.

virtual VCOMErrorVCOM_CALLTYPE ConnectWithBrowser(
IDBConnectionString** outConnectionString) = 0;

Parameters

outConnectionString IDBConnectionString** Completed connection string.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.
kVCOMError_NotImplemented The function works only on Windows and on the current platform is not supported by the OS.