VCOM:VectorWorks:Extension:IDBDatabase::ConnectWithBrowser: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
(4 intermediate revisions by 2 users not shown)
Line 10: Line 10:
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]
Member of [[VCOM:VectorWorks:Extension:IDBDatabase]]


...put some description here...
<font color="red">NOT RECOMENDED FOR USE</font>. Use [[VCOM:VectorWorks:Extension:IDBDatabase::ConnectWithBrowserN|ConnectWithBrowserN]] instead of this function.
 
This function works '''only''' on Windows. On other platforms returns "not implemented". It uses the OS ODBC API function SQLDriverConnect and it opens the "Select Data Source" dialog.
</desc>
</desc>


Line 16: Line 18:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE ConnectWithBrowser(IDBConnectionString** outConnectionString) = 0;
virtual VCOMError VCOM_CALLTYPE ConnectWithBrowser(IDBConnectionString** outConnectionString) = 0;
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 28:
outConnectionString
outConnectionString
IDBConnectionString**
IDBConnectionString**
no info.
Completed connection string.
</line>
</line>
</lineList>
</lineList>
Line 37: Line 39:
Return value meaning:
Return value meaning:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
</line>
</line>
<line>
kVCOMError_NotImplemented
The function works only on Windows and on the current platform is not supported by the OS.
</line>
</lineList>
</lineList>
</return>
</return>

Latest revision as of 11:24, 2 November 2015

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBDatabase

NOT RECOMENDED FOR USE. Use ConnectWithBrowserN instead of this function.

This function works only on Windows. On other platforms returns "not implemented". It uses the OS ODBC API function SQLDriverConnect and it opens the "Select Data Source" dialog.

virtual VCOMError VCOM_CALLTYPE ConnectWithBrowser(
IDBConnectionString** outConnectionString) = 0;

Parameters

outConnectionString IDBConnectionString** Completed connection string.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.
kVCOMError_NotImplemented The function works only on Windows and on the current platform is not supported by the OS.