VCOM:VectorWorks:Extension:IDBDatabase::ConnectDriver

From Vectorworks Developer
Revision as of 12:24, 2 November 2015 by Sasha (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDBDatabase

NOT RECOMENDED FOR USE Use ConnectDriverN instead of this function.

This function connects to a data source.

virtual VCOMErrorVCOM_CALLTYPE ConnectDriver(
IDBConnectionString* inOutConnectionString) = 0;

Parameters

inOutConnectionString IDBConnectionString* Pointer to the in/out IDBConnectionString, which represents the driver settings.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.