VCOM:VectorWorks:Animation:IMovieWriter

From Vectorworks Developer
Revision as of 17:50, 22 September 2014 by Aghosh (talk | contribs) (1 revision)
Jump to navigation Jump to search

Description

namespace VectorWorks::Animation

..put some descriptoin in here...

Interface

...put the class definition, including the UUID, here...

Members

ShowOptions
ShowOptions
GetMovieFormat
GetMovieFilename
CreateMovie
AdjustFramesPerSecond
GetFramesPerSecond
AdjustFramesPerKeyFrame
GetFramesPerKeyFrame
AdjustQuality
GetQuality
WriteRawImage
WriteCompressedImage
Finalize

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IMovieWriter interface:

typedef VCOMPtr<IMovieWriter>  IMovieWriterPtr;

Version

Available from: Vectorworks 2015

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]