User talk:Maarten

From Vectorworks Developer
Revision as of 07:04, 10 September 2014 by Maarten (talk | contribs) (Created page with "{{LocationMain|category=LocationSDKSpecial|specific=}} <div class="rightmenu"> __TOC__ </div> == What's that == This article will explain how to create the surface objects t...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

What's that

This article will explain how to create the surface objects that are the intersection of the two referenced surface objects.

Creating

To create a surface intersection between two surface objects, use :

	gSDK->Kludge( kIntersectSurfaceKludge, &surfaceInformation, nil );
  • kIntersectSurfaceKludge is a const CBSignedShort with 5571 as value.
  • doubleParams is a struct with 3 MCObjectHandles parameters (object1, object2 and the result of the intersection between the two objects).

Example

MCObjectHandle IntersectSurface(MCObjectHandle obj1, MCObjectHandle obj2)
{
	const CBSignedShort kIntersectSurfaceKludge = 5571;
	struct IntersectSurfaceInformation
	{
		MCObjectHandle h1;
		MCObjectHandle h2;
		MCObjectHandle result;
	};

	IntersectSurfaceInformation surfaceInformation;
	surfaceInformation.h1 = listObj1[i];
	surfaceInformation.h2 = listObj2[j];
	gSDK->Kludge(kIntersectSurfaceKludge, &surfaceInformation, nil);
	
	return surfaceInformation.result;
}

See also

VCOM:VectorWorks:ISDK::Kludge