User talk:Maarten: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationSDKSpecial|specific=}} <div class="rightmenu"> __TOC__ </div> == What's that == This article will explain how to create the surface objects t...")
 
No edit summary
 
(One intermediate revision by the same user not shown)
Line 1: Line 1:
{{LocationMain|category=LocationSDKSpecial|specific=}}
Test
<div class="rightmenu">
__TOC__
</div>
 
== What's that ==
 
This article will explain how to create the surface objects that are the intersection of the two referenced surface objects.
 
== Creating ==
To create a surface intersection between two surface objects, use :
<code lang="cpp">
gSDK->Kludge( kIntersectSurfaceKludge, &surfaceInformation, nil );
</code>
* ''kIntersectSurfaceKludge'' is a const CBSignedShort with 5571 as value.
* ''doubleParams'' is a struct with 3 MCObjectHandles parameters (object1, object2 and the result of the intersection between the two objects).
 
== Example ==
 
 
<code lang="cpp">
MCObjectHandle IntersectSurface(MCObjectHandle obj1, MCObjectHandle obj2)
{
const CBSignedShort kIntersectSurfaceKludge = 5571;
struct IntersectSurfaceInformation
{
MCObjectHandle h1;
MCObjectHandle h2;
MCObjectHandle result;
};
 
IntersectSurfaceInformation surfaceInformation;
surfaceInformation.h1 = listObj1[i];
surfaceInformation.h2 = listObj2[j];
gSDK->Kludge(kIntersectSurfaceKludge, &surfaceInformation, nil);
return surfaceInformation.result;
}
</code>
 
== See also ==
[[VCOM:VectorWorks:ISDK::Kludge]]
 
[[Category:SDK]]

Latest revision as of 11:38, 13 April 2023

Test