User:Orso.b.schmid: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(add text concat)
(expand string implicit conversion)
Line 13: Line 13:


|- style="vertical-align: top;"
|- style="vertical-align: top;"
|  
| '''Case sensitivity'''
; Assignment operator:
| '''Not case sensitive:'''
| <code>:=</code>
* <code>AlrtDialog('test'); { OK }</code>
| <code>=</code>
* <code>alrtDialog('test'); { OK }</code>
* <code>alrtdialog('test'); { OK }</code>
* <code>ALRTDIALOG('test'); { OK }</code>
| '''Case sensitive:'''
* <code>vs.AlrtDialog('test') # OK </code>
* <code>vs.alrtDialog('test') # error</code>
* <code>vs.alrtdialog('test') # error</code>
* <code>vs.ALRTDIALOG('test') # error</code>
 
Error Message: AttributeError: 'module' object has no attribute 'vs.ALRTDIALOG'


|- style="vertical-align: top;"
|- style="vertical-align: top;"
|  
| '''Empty brakes for functions'''
; Empty brakes for functions: don't forget in python the empty brakets for routines without parameters, this rises errors that are so tricky to find.
: don't forget in python the empty brakets for routines without parameters, this rises errors that are so tricky to find.
| If a routine has no parameters, it can be expressed without brakets:
| If a routine has no parameters, it can be expressed without brakets:
* <code>FSActLayer;</code>
* <code>FSActLayer;</code>
Line 29: Line 38:


|- style="vertical-align: top;"
|- style="vertical-align: top;"
|  
| '''Empty handles'''
; Empty handle: do pay attention also to the variable scope (see below).
: do pay attention also to the variable scope (see below).
|  
|  
* <code>h <> NIL</code>
* <code>h <> NIL</code>
Line 38: Line 47:


|- style="vertical-align: top;"
|- style="vertical-align: top;"
| '''Variable scope'''
: perhaps the largest source of error for the vectorscripter transitioning to python
|  
|  
; Colors:
'''Global wins over local:'''
|
* Color Index:
*: <code>SetPenFore(h, RGBToColorIndex(65535, 0, 0));</code>
*: <code>PenFore(RGBToColorIndex(65535, 0, 0));</code>
* RGB:
*: <code>SetPenFore(h, 65535, 0, 0);</code>
|
* Color Index:
*: <code>vs.SetPenFore(h, vs.RGBToColorIndex(65535, 0, 0)) </code>
* RGB in Tuple:
*: <code>vs.SetPenFore(h, (65535, 0, 0)) </code>
* Hex in Tuple:
*: <code>vs.SetPenFore(h, (0xFFFF, 0, 0))</code>
 
Warning: don't forget the brakets:
* <code>vs.PenFore((65535, 0, 0)) </code> correct
* <code>vs.PenFore(65535, 0, 0) </code> fails
 
|- style="vertical-align: top;"
|
; Variable scope: perhaps the largest source of error for the vectorscripter transitioning to python
|
Global wins over local:
* Variables must be declared
* Variables must be declared
* Subroutines "see" their own variables and those of any parent function/procedure where they are contained.
* Subroutines "see" their own variables and those of any parent function/procedure where they are contained.
Line 95: Line 83:
</code>
</code>
|  
|  
Local wins over global:
'''Local wins over global:'''
* Variables must NOT be declared
* Variables must NOT be declared
* Subroutines create automatically a local instance of any used variable.
* Subroutines create automatically a local instance of any used variable.
Line 140: Line 128:


|- style="vertical-align: top;"
|- style="vertical-align: top;"
|  
| '''FOR statements'''
; FOR statements:
| '''Runs including last value:'''
| Runs including last value
<code lang="pas">
<code lang="pas">
PROCEDURE Test;
{ runs 3 times! 1, 2 and 3 }
VAR
FOR i := 1 TO 3 DO
    i : INTEGER;
    AlrtDialog(Concat(i));
BEGIN
    { runs 3 times! 1, 2 and 3 }
    FOR i := 1 TO 3 DO
        AlrtDialog(Concat(i));
END;
Run(Test);
</code>
</code>
| Runs excluding last value
| '''Runs excluding last value:'''
<code lang="py">
<code lang="py">
# runs 2 times! 1 and 2
# runs 2 times! 1 and 2
Line 162: Line 143:


|- style="vertical-align: top;"
|- style="vertical-align: top;"
| '''Colors'''
|
* Color Index:
*: <code>SetPenFore(h, RGBToColorIndex(65535, 0, 0));</code>
*: <code>PenFore(RGBToColorIndex(65535, 0, 0));</code>
* RGB:
*: <code>SetPenFore(h, 65535, 0, 0);</code>
|  
|  
; Concatenate text:
* Color Index:
|  
*: <code>vs.SetPenFore(h, vs.RGBToColorIndex(65535, 0, 0)) </code>
* <code>Concat(text1, ' ', text2)</code>
* RGB in Tuple:
* AlrtDialog(Concat(10, ' fingers'));
*: <code>vs.SetPenFore(h, (65535, 0, 0)) </code>
| Outside vs.Concat conversion to string might be needed
* Hex in Tuple:
* <code> text1 + ' ' + text2</code>
*: <code>vs.SetPenFore(h, (0xFFFF, 0, 0))</code>
* vs.AlrtDialog(vs.Concat(10, ' fingers'));
 
* vs.AlrtDialog(10 + ' fingers'); # error
Warning: don't forget the brakets:
* vs.AlrtDialog(str(10) + ' fingers'); # OK
* <code>vs.PenFore((65535, 0, 0)) </code> correct
* <code>vs.PenFore(65535, 0, 0) </code> fails
Error Message: - none! be careful! -
 
|- style="vertical-align: top;"
| '''Concatenate text'''
| '''Supports implicit conversion:'''
: Both [[VS:Concat| Concat]] and [[VS:Message| Message]] support multiple variable types and convert them into string.
* <code>Concat(10, ' fingers'); { OK }</code>
* <code>Message(10, ' fingers'); { OK }</code>
* <code>AlrtDialog(Concat(10, ' fingers')); { OK }</code>
|  '''Doesn't support implicit conversion:'''
: For example an integer won't automatically be converted into string. Wrap it in [[VS:Concat| vs.Concat]] or [[VS:Message| vs.Message]], alternatively perform the needed conversion.
* <code>10 + ' fingers' # error</code>
* <code>vs.AlrtDialog(vs.Concat(10, ' fingers')) # OK</code>
* <code>vs.AlrtDialog(str(10) + ' fingers') # OK</code>
* <code>vs.AlrtDialog(10 + ' fingers') # error </code>
 
Error Message: TypeError: unsupported operand type(s) for +: 'int' and 'str'
 
|- style="vertical-align: top;"
| '''Encryption'''
| Whatever .vs or .px file is linked through your includes, will be encrypted upon running the encrypt command. More infos [[VS:Include_Files_and_Encryption| here]].
| Create list of your included files in an xml file. Please read [https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Number=197639&Searchpage=1&Main=39809&Words=python&Search=true#Post197639 Vlado on Techboard]


|- style="vertical-align: top;"
|- style="vertical-align: top;"
|  
| '''Python version'''
; Python version:
|  
|  
| <code>import sys
| <code>import sys
Line 183: Line 193:


|- style="vertical-align: top;"
|- style="vertical-align: top;"
|  
| '''"import vs"'''
; "import vs" yes or no?
|  
|  
| <code>import vs</code> # do I need this?
| <code>import vs</code> # do I need this?


|- style="vertical-align: top;"
|- style="vertical-align: top;"
|  
| '''Caching'''
; Caching: some caching prevents your script to reflect changes:
: some caching prevents your script to reflect changes:
|  
|  
| varPersistentPythonEngine = 412 { Boolean }
| varPersistentPythonEngine = 412 { Boolean }
In the SDK starting from VW 2014 we can read:
In the SDK starting from VW 2014 we can read:
''When True the Python engine is the same for the execution of all scripts, this solves some issues with Py_Initialize and Py_Finalize. For example, when debugging externally python leaves threas that cause crash if Py_Initialize and Py_Finalize is used for each script call. So, this allows the engine to be preserved between calls, however Vectorworks will delete all custom modules and objects defined in the engine prior each execution.''
''When True the Python engine is the same for the execution of all scripts, this solves some issues with Py_Initialize and Py_Finalize. For example, when debugging externally python leaves threas that cause crash if Py_Initialize and Py_Finalize is used for each script call. So, this allows the engine to be preserved between calls, however Vectorworks will delete all custom modules and objects defined in the engine prior each execution.''
|- style="vertical-align: top;"
|
; Encryption:
| Whatever .vs or .px file is linked through your includes, will be encrypted upon running the encrypt command. More infos [[VS:Include_Files_and_Encryption| here]].
| Create list of your included files in an xml file. Please read [https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Number=197639&Searchpage=1&Main=39809&Words=python&Search=true#Post197639 Vlado on Techboard]
|}
|}



Revision as of 09:10, 19 May 2015

Ciao,

I am Orso, an Italian Vectorscripter since many years. Some of you might know me from Vectorlab or the comments on the present Developer wiki. I feel very comfortable with Vectorscript (from now on: VS) but will now switch over to Python for even more power. I will try to share here comments, problems -and solutions- from the point of view of a non-programmer. --Orso.b.schmid (talk) 08:13, 17 May 2015 (EDT)

If you add comments, please use the full wiki formatting, easily available clicking on Advanced while on edit mode and don't forget to sign up your comment using --~~~~!

VS <> Py FAQ

Description Vectorscript Python
Case sensitivity Not case sensitive:
  • AlrtDialog('test'); { OK }
  • alrtDialog('test'); { OK }
  • alrtdialog('test'); { OK }
  • ALRTDIALOG('test'); { OK }
Case sensitive:
  • vs.AlrtDialog('test') # OK
  • vs.alrtDialog('test') # error
  • vs.alrtdialog('test') # error
  • vs.ALRTDIALOG('test') # error
Error Message: AttributeError: 'module' object has no attribute 'vs.ALRTDIALOG'
Empty brakes for functions
don't forget in python the empty brakets for routines without parameters, this rises errors that are so tricky to find.
If a routine has no parameters, it can be expressed without brakets:
  • FSActLayer;
  • MySubroutine;
If a routine has no parameters, it must be nevertheless expressed with brakets:
  • vs.FSActLayer()
  • MySubroutine()
Empty handles
do pay attention also to the variable scope (see below).
  • h <> NIL
  • h != None
  • h != vs.Handle() # not inited instance of a handle, how cryptic
Variable scope
perhaps the largest source of error for the vectorscripter transitioning to python

Global wins over local:

  • Variables must be declared
  • Subroutines "see" their own variables and those of any parent function/procedure where they are contained.
{ GLOBAL ACCESS }
{ parent of subroutine "Increment" }
PROCEDURE Main;
    VAR
        { good praxis: label globals with "g" }
        gIndex, gNum : INTEGER; 
    
    { subroutine }
    PROCEDURE Increment;
        BEGIN
            { gNum is not defined in this subroutine 
            the parser goes up to the parent container 
            until it finds a declaration for the var gNum.
            In this case in Main }
            gNum := gNum +1;
            SysBeep;
        END;
        
BEGIN
    gNum := 10; { init }
    FOR gIndex := 1 TO 10 DO
        Increment; { increments the variable gNum }
        
    AlrtDialog(Concat(gNum));
{ returns 20 }
END;
Run(Main);

Local wins over global:

  • Variables must NOT be declared
  • Subroutines create automatically a local instance of any used variable.
# LOCAL ACCESS
# subroutine
def Increment():
    # gNum is not defined in this subroutine
    # the parser creates a local instance of the var gNum!
    gNum +=1
    vs.SysBeep
 
gNum = 10 # init
for gIndex in range(1, 10):
    Increment 
    # increments the variable gNum
    # but only inside Increment!
    
vs.AlrtDialog(str(gNum))
# returns 10! The global var didn't set
# GLOBAL ACCESS
# subroutine
def Increment():
    # gNum is not defined in this subroutine
    # tell the parser that you want to edit gNum global!
    global gNum
    gNum +=1
    vs.SysBeep()
 
gNum = 10 # init
# please observe that the range is NOT 1, 10!
for gIndex in range(0, 10):
    Increment()
    # increments the variable gNum
    # but only inside Increment!
    
vs.AlrtDialog(str(gNum))
# returns 20
FOR statements Runs including last value:
{ runs 3 times! 1, 2 and 3 }
FOR i := 1 TO 3 DO
    AlrtDialog(Concat(i));
Runs excluding last value:
# runs 2 times! 1 and 2
for i in range(1, 3):
    vs.AlrtDialog(str(i))
Colors
  • Color Index:
    SetPenFore(h, RGBToColorIndex(65535, 0, 0));
    PenFore(RGBToColorIndex(65535, 0, 0));
  • RGB:
    SetPenFore(h, 65535, 0, 0);
  • Color Index:
    vs.SetPenFore(h, vs.RGBToColorIndex(65535, 0, 0))
  • RGB in Tuple:
    vs.SetPenFore(h, (65535, 0, 0))
  • Hex in Tuple:
    vs.SetPenFore(h, (0xFFFF, 0, 0))

Warning: don't forget the brakets:

  • vs.PenFore((65535, 0, 0)) correct
  • vs.PenFore(65535, 0, 0) fails
Error Message: - none! be careful! -
Concatenate text Supports implicit conversion:
Both Concat and Message support multiple variable types and convert them into string.
  • Concat(10, ' fingers'); { OK }
  • Message(10, ' fingers'); { OK }
  • AlrtDialog(Concat(10, ' fingers')); { OK }
Doesn't support implicit conversion:
For example an integer won't automatically be converted into string. Wrap it in vs.Concat or vs.Message, alternatively perform the needed conversion.
  • 10 + ' fingers' # error
  • vs.AlrtDialog(vs.Concat(10, ' fingers')) # OK
  • vs.AlrtDialog(str(10) + ' fingers') # OK
  • vs.AlrtDialog(10 + ' fingers') # error
Error Message: TypeError: unsupported operand type(s) for +: 'int' and 'str'
Encryption Whatever .vs or .px file is linked through your includes, will be encrypted upon running the encrypt command. More infos here. Create list of your included files in an xml file. Please read Vlado on Techboard
Python version import sys

ver = sys.version_info
vs.Message(repr(ver))

"import vs" import vs # do I need this?
Caching
some caching prevents your script to reflect changes:
varPersistentPythonEngine = 412 { Boolean }

In the SDK starting from VW 2014 we can read: When True the Python engine is the same for the execution of all scripts, this solves some issues with Py_Initialize and Py_Finalize. For example, when debugging externally python leaves threas that cause crash if Py_Initialize and Py_Finalize is used for each script call. So, this allows the engine to be preserved between calls, however Vectorworks will delete all custom modules and objects defined in the engine prior each execution.

Lists

Lists are powerful in Python, below some fascinating lists manipulations. They remind me of Applescript:

months = "Jan Feb Mar Apr May Jun Jul"
months = months.split() # no splitter defined and it will use the empty space --> ['Jan', 'Feb', 'Mar', 'Apr', 'May', 'Jun', 'Jul']
months[2] # --> 'Mar' note that the index is 0-based
months2 = "Jan, Feb, Mar, Apr, May, Jun, Jul"
months2.split(', ') # --> ['Jan', 'Feb', 'Mar', 'Apr', 'May', 'Jun', 'Jul'] use comma and empty space as splitter 
months.append('Jul') # --> ['Jan', 'Feb', 'Mar', 'Apr', 'May', 'Jun', 'Jul'] append adds an item to a list 
months.pop() #- -> 'Jul' pop fetches the last item of a list
', sunny '.join(months) # --> ', sunny Jan, sunny Feb, sunny Mar, sunny Apr, sunny May, sunny Jun, sunny Sep'
'-'.join(months[1:3]) # --> 'Feb-Mar'
del months[2] # --> ['Jan', 'Feb', 'Apr', 'May', 'Jun', 'Jul']
months = {1: 'Jan', 2: 'Feb', 3: 'Mar'} # --> {1: 'Jan', 2: 'Feb', 3: 'Mar'}