User:Orso.b.schmid: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(variable scope)
(add text concat)
Line 137: Line 137:
vs.AlrtDialog(str(gNum))
vs.AlrtDialog(str(gNum))
# returns 20
# returns 20
</code>
|- style="vertical-align: top;"
|
; FOR statements:
| Runs including last value
<code lang="pas">
PROCEDURE Test;
VAR
    i : INTEGER;
BEGIN
    { runs 3 times! 1, 2 and 3 }
    FOR i := 1 TO 3 DO
        AlrtDialog(Concat(i));
END;
Run(Test);
</code>
| Runs excluding last value
<code lang="py">
# runs 2 times! 1 and 2
for i in range(1, 3):
    vs.AlrtDialog(str(i))
</code>
</code>


Line 144: Line 166:
|  
|  
* <code>Concat(text1, ' ', text2)</code>
* <code>Concat(text1, ' ', text2)</code>
|  
* AlrtDialog(Concat(10, ' fingers'));
| Outside vs.Concat conversion to string might be needed
* <code> text1 + ' ' + text2</code>
* <code> text1 + ' ' + text2</code>
* vs.AlrtDialog(vs.Concat(10, ' fingers'));
* vs.AlrtDialog(10 + ' fingers'); # error
* vs.AlrtDialog(str(10) + ' fingers'); # OK


|- style="vertical-align: top;"
|- style="vertical-align: top;"

Revision as of 07:25, 19 May 2015

Ciao,

I am Orso, an Italian Vectorscripter since many years. Some of you might know me from Vectorlab or the comments on the present Developer wiki. I feel very comfortable with Vectorscript (from now on: VS) but will now switch over to Python for even more power. I will try to share here comments, problems -and solutions- from the point of view of a non-programmer. --Orso.b.schmid (talk) 08:13, 17 May 2015 (EDT)

If you add comments, please use the full wiki formatting, easily available clicking on Advanced while on edit mode and don't forget to sign up your comment using --~~~~!

VS <> Py FAQ

Description Vectorscript Python
Assignment operator
:= =
Empty brakes for functions
don't forget in python the empty brakets for routines without parameters, this rises errors that are so tricky to find.
If a routine has no parameters, it can be expressed without brakets:
  • FSActLayer;
  • MySubroutine;
If a routine has no parameters, it must be nevertheless expressed with brakets:
  • vs.FSActLayer()
  • MySubroutine()
Empty handle
do pay attention also to the variable scope (see below).
  • h <> NIL
  • h != None
  • h != vs.Handle() # not inited instance of a handle, how cryptic
Colors
  • Color Index:
    SetPenFore(h, RGBToColorIndex(65535, 0, 0));
    PenFore(RGBToColorIndex(65535, 0, 0));
  • RGB:
    SetPenFore(h, 65535, 0, 0);
  • Color Index:
    vs.SetPenFore(h, vs.RGBToColorIndex(65535, 0, 0))
  • RGB in Tuple:
    vs.SetPenFore(h, (65535, 0, 0))
  • Hex in Tuple:
    vs.SetPenFore(h, (0xFFFF, 0, 0))

Warning: don't forget the brakets:

  • vs.PenFore((65535, 0, 0)) correct
  • vs.PenFore(65535, 0, 0) fails
Variable scope
perhaps the largest source of error for the vectorscripter transitioning to python

Global wins over local:

  • Variables must be declared
  • Subroutines "see" their own variables and those of any parent function/procedure where they are contained.
{ GLOBAL ACCESS }
{ parent of subroutine "Increment" }
PROCEDURE Main;
    VAR
        { good praxis: label globals with "g" }
        gIndex, gNum : INTEGER; 
    
    { subroutine }
    PROCEDURE Increment;
        BEGIN
            { gNum is not defined in this subroutine 
            the parser goes up to the parent container 
            until it finds a declaration for the var gNum.
            In this case in Main }
            gNum := gNum +1;
            SysBeep;
        END;
        
BEGIN
    gNum := 10; { init }
    FOR gIndex := 1 TO 10 DO
        Increment; { increments the variable gNum }
        
    AlrtDialog(Concat(gNum));
{ returns 20 }
END;
Run(Main);

Local wins over global:

  • Variables must NOT be declared
  • Subroutines create automatically a local instance of any used variable.
# LOCAL ACCESS
# subroutine
def Increment():
    # gNum is not defined in this subroutine
    # the parser creates a local instance of the var gNum!
    gNum +=1
    vs.SysBeep
 
gNum = 10 # init
for gIndex in range(1, 10):
    Increment 
    # increments the variable gNum
    # but only inside Increment!
    
vs.AlrtDialog(str(gNum))
# returns 10! The global var didn't set
# GLOBAL ACCESS
# subroutine
def Increment():
    # gNum is not defined in this subroutine
    # tell the parser that you want to edit gNum global!
    global gNum
    gNum +=1
    vs.SysBeep()
 
gNum = 10 # init
# please observe that the range is NOT 1, 10!
for gIndex in range(0, 10):
    Increment()
    # increments the variable gNum
    # but only inside Increment!
    
vs.AlrtDialog(str(gNum))
# returns 20
FOR statements
Runs including last value
PROCEDURE Test;
VAR
    i : INTEGER;
BEGIN
    { runs 3 times! 1, 2 and 3 }
    FOR i := 1 TO 3 DO
        AlrtDialog(Concat(i));
END;
Run(Test);
Runs excluding last value
# runs 2 times! 1 and 2
for i in range(1, 3):
    vs.AlrtDialog(str(i))
Concatenate text
  • Concat(text1, ' ', text2)
  • AlrtDialog(Concat(10, ' fingers'));
Outside vs.Concat conversion to string might be needed
  • text1 + ' ' + text2
  • vs.AlrtDialog(vs.Concat(10, ' fingers'));
  • vs.AlrtDialog(10 + ' fingers'); # error
  • vs.AlrtDialog(str(10) + ' fingers'); # OK
Python version
import sys

ver = sys.version_info
vs.Message(repr(ver))

"import vs" yes or no?
import vs # do I need this?
Caching
some caching prevents your script to reflect changes:
varPersistentPythonEngine = 412 { Boolean }

In the SDK starting from VW 2014 we can read: When True the Python engine is the same for the execution of all scripts, this solves some issues with Py_Initialize and Py_Finalize. For example, when debugging externally python leaves threas that cause crash if Py_Initialize and Py_Finalize is used for each script call. So, this allows the engine to be preserved between calls, however Vectorworks will delete all custom modules and objects defined in the engine prior each execution.

Encryption
Whatever .vs or .px file is linked through your includes, will be encrypted upon running the encrypt command. More infos here. Create list of your included files in an xml file. Please read Vlado on Techboard

Lists

Lists are powerful in Python, below some fascinating lists manipulations. They remind me of Applescript:

months = "Jan Feb Mar Apr May Jun Jul"
months = months.split() # no splitter defined and it will use the empty space --> ['Jan', 'Feb', 'Mar', 'Apr', 'May', 'Jun', 'Jul']
months[2] # --> 'Mar' note that the index is 0-based
months2 = "Jan, Feb, Mar, Apr, May, Jun, Jul"
months2.split(', ') # --> ['Jan', 'Feb', 'Mar', 'Apr', 'May', 'Jun', 'Jul'] use comma and empty space as splitter 
months.append('Jul') # --> ['Jan', 'Feb', 'Mar', 'Apr', 'May', 'Jun', 'Jul'] append adds an item to a list 
months.pop() #- -> 'Jul' pop fetches the last item of a list
', sunny '.join(months) # --> ', sunny Jan, sunny Feb, sunny Mar, sunny Apr, sunny May, sunny Jun, sunny Sep'
'-'.join(months[1:3]) # --> 'Feb-Mar'
del months[2] # --> ['Jan', 'Feb', 'Apr', 'May', 'Jun', 'Jul']
months = {1: 'Jan', 2: 'Feb', 3: 'Mar'} # --> {1: 'Jan', 2: 'Feb', 3: 'Mar'}