Template:NURBSObject: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "==== VectorScript ==== <code lang="pas"> PROCEDURE Example; VAR h :HANDLE; BEGIN h := FSActLayer; h := ConvertToNURBS(h, FALSE); h := CreateOffsetNurbsObjectHandle(h, 1); END;...")
 
(→‎VectorScript: fix syntax)
 
Line 10: Line 10:
END;
END;
RUN(Example);
RUN(Example);
</code>
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">

Latest revision as of 16:58, 29 February 2020

VectorScript

PROCEDURE Example;
VAR
h :HANDLE;
BEGIN
h := FSActLayer;
h := ConvertToNURBS(h, FALSE);
h := CreateOffsetNurbsObjectHandle(h, 1);
END;
RUN(Example);

Python

def Example():
	h = vs.FSActLayer()
	h = vs.ConvertToNURBS(h, False)
	h = vs.CreateOffsetNurbsObjectHandle(h, 1)
Example()