Template:AlertDialogsAndMessages: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "<code lang="pas"> PROCEDURE Example; BEGIN AlrtDialog('AlrtDialog'); AlertInform('AlertInform', 'advice', FALSE); AlertCritical('AlertCritical', 'advice'); Message(YNDialog('Y...")
 
No edit summary
 
Line 1: Line 1:
==== VectorScript ====
<code lang="pas">
<code lang="pas">
PROCEDURE Example;
PROCEDURE Example;

Latest revision as of 19:48, 17 July 2014

VectorScript

PROCEDURE Example;
BEGIN
AlrtDialog('AlrtDialog');
AlertInform('AlertInform', 'advice', FALSE);
AlertCritical('AlertCritical', 'advice');
Message(YNDialog('YNDialog'));
Message(AlertQuestion('question', 'advice', 1, 'ok', 'cancel', 'a', 'b'));
END;
RUN(Example);

Python

def Example():
	vs.AlrtDialog('AlrtDialog')
	vs.AlertInform('AlertInform', 'advice', False)
	vs.AlertCritical('AlertCritical', 'advice')	
	vs.Message(vs.YNDialog('YNDialog'))
	vs.Message(vs.AlertQuestion('question', 'advice', 1, 'ok', 'cancel', 'a', 'b'))
Example()