Template:AddSurface

From Vectorworks Developer
Revision as of 22:02, 20 January 2022 by Root (talk | contribs)
Jump to navigation Jump to search

VectorScript

PROCEDURE AddSurfaceExample;
VAR
h1, h2, h3 :HANDLE;
BEGIN
DSelectAll;
CallTool(-203);
h1 := FSActLayer;
DSelectAll;
CallTool(-203);
h2 := FSActLayer;
h3 := AddSurface(h1, h2);
IF h3 <> nil THEN SetFPat(h3, 5);
END;
RUN(AddSurfaceExample);

Python

# this will not be called prior Vectorworks 2022 SP3
# as the calback functions will not be executed prior to that version
def Example():
	vs.DSelectAll()

	def reultCallback1():
		h1 = vs.FSActLayer()
		vs.DSelectAll()
		
		def reultCallback2():
			h2 = vs.FSActLayer()
			h3 = vs.AddSurface(h1, h2)
			if h3 != None :  
				vs.SetFPat(h3, 5)
		
		
		vs.CallTool(-203, reultCallback2)
			
	vs.CallTool(-203, reultCallback1)

Example()