Talk:VS:IFC ExportNoUI

From Vectorworks Developer
Revision as of 13:46, 5 January 2023 by Ptr (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

Description

Exports IFC file, without showing Export IFC Project dialog

PROCEDURE IFC_ExportNoUI(
strFullFilePath :DYNARRAY of CHAR);
def vs.IFC_ExportNoUI(strFullFilePath):
    return BOOLEAN

Parameters

strFullFilePath DYNARRAY of CHAR

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_ExportNoUI('FullFilePath');
END;

RUN(Test);

Python

ok = vs.IFC_ExportNoUI('FullFilePath')

Version

Availability: from Vectorworks 2014