Talk:VS:IFC ExportNoUI: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "__TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> Exports IFC file, showing Export IFC Projec...")
 
No edit summary
 
Line 4: Line 4:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Exports IFC file, showing Export IFC Project dialog</desc>
Exports IFC file, without showing Export IFC Project dialog
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE IFC_ExportWithUI(bExpSingleObj:BOOLEAN);
PROCEDURE IFC_ExportNoUI(strFullFilePath:DYNARRAY of CHAR);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.IFC_ExportWithUI(bExpSingleObj):
def vs.IFC_ExportNoUI(strFullFilePath):
     return None
     return BOOLEAN
</funcDef>
</funcDef>
</def>
</def>
Line 21: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
bExpSingleObj
strFullFilePath
BOOLEAN
DYNARRAY of CHAR
Set to False.


</line>
</line>
Line 43: Line 43:
ok : BOOLEAN;
ok : BOOLEAN;
BEGIN
BEGIN
ok := IFC_ExportWithUI(FALSE);
ok := IFC_ExportNoUI('FullFilePath');
END;
END;


Line 50: Line 50:
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
ok = vs.IFC_ExportWithUI(FALSE)
ok = vs.IFC_ExportNoUI('FullFilePath')
</code>
</code>
</sample>
</sample>

Latest revision as of 13:46, 5 January 2023

Description

Exports IFC file, without showing Export IFC Project dialog

PROCEDURE IFC_ExportNoUI(
strFullFilePath :DYNARRAY of CHAR);
def vs.IFC_ExportNoUI(strFullFilePath):
    return BOOLEAN

Parameters

strFullFilePath DYNARRAY of CHAR

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_ExportNoUI('FullFilePath');
END;

RUN(Test);

Python

ok = vs.IFC_ExportNoUI('FullFilePath')

Version

Availability: from Vectorworks 2014