SDK:TexturePartSDK

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK:Textures

This enumeration is used to direct the texturing functions to a particular texture part on an object.

enum TexturePartSDK
{
  kTexturePart_Overall = 3,
		
  kTexturePart_ExtrudeSweep_Top = 4,
  kTexturePart_ExtrudeSweep_Bottom = 5,
  kTexturePart_ExtrudeSweep_Sides = 6,

  kTexturePart_Wall_Left = 7,
  kTexturePart_Wall_Right = 8,
  kTexturePart_Wall_StartCap = 9,
  kTexturePart_Wall_EndCap = 10,
  kTexturePart_Wall_Top = 11,
  kTexturePart_Wall_Bottom = 12,
  kTexturePart_Wall_Holes = 13,

  kTexturePart_Slab_Top = 14,
  kTexturePart_Slab_Bottom = 15,
  kTexturePart_Slab_Sides = 16,

  kTexturePart_Roof_Top = 17,
  kTexturePart_Roof_Bottom = 18,
  kTexturePart_Roof_Sides = 19,
  kTexturePart_Roof_Walls = 20,
  kTexturePart_Roof_Fascia = 21,
  kTexturePart_Roof_Attic = 22,
  kTexturePart_Roof_Soffit = 23
};

Version

Availability: from VectorWorks 2009

See Also

VCOM:VectorWorks:ISDK::SetDefaultTextureMapping | VCOM:VectorWorks:ISDK::GetTextureMappingInfo | VCOM:VectorWorks:ISDK::SetTextureMappingInfo | SDK:TexturePartSDK | SDK:TextureMappingInfoSDK

[[VCOM:VectorWorks:ISDK::SetDefaultTextureMapping]] | [[VCOM:VectorWorks:ISDK::GetTextureMappingInfo]] | [[VCOM:VectorWorks:ISDK::SetTextureMappingInfo]] | [[SDK:TexturePartSDK]] | [[SDK:TextureMappingInfoSDK]]