SDK:MCObjectHandle

From Vectorworks Developer
Revision as of 15:39, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

What is this?

This is a number (or 'void*') to an object inside VectorWorks.

This is the foundation element of the VectorWorks document architecture. Every object inside VectorWorks document has handle that is used to recognize this object from the others.

Document Handle

The active document itself has MCObjectHandle. ISDK::GetDrawingHeader will return you the active document handle.

Object Type

Every handle represents instance of an object with specified type. You can get object type by handle using ISDK::GetObjectType function.

For available types codes see Remarks of ISDK::GetObjectType

Document Architecture

Some object types are containings. Through that object's MCObjectHandle you can enumerate the child list.

See SDK:The VectorWorks Environment

Object hierarchy iteration
ISDK::FirstMemberObj Returns handle to the first child object of the specified one.
ISDK::LastMemberObj Returns handle to the last child object of the specified one.
ISDK::ParentObject Returns handle to the parent object of the specified one.
ISDK::PrevObject Returns handle of the previous sibling object of the specified one.
ISDK::NextObject Returns handle of the next sibling object of the specified one.
Hierarchy manipulation
ISDK::AddObjectToContainer Adds object instance into object container instance.
ISDK::DeleteObject Deletes the specified object from the hierarchy. The Handle is no longer valid.
ISDK::InsertObjectAfter Reposition the specified object into the hierarchy placing it after the specified one. The object is removed from it's old place in the hierarchy.
ISDK::InsertObjectBefore Reposition the specified object into the hierarchy placing it before the specified one. The object is removed from it's old place in the hierarchy.

Aux List

Every object in VectorWorks has Aux (Auxiliary) list of objects.

Every object can be put into another object's Aux list.

Object Aux list iteration
ISDK::FirstAuxObject Returns the previos sibling object in the Aux list of the specified one.
ISDK::NextAuxObject Returns the next sibling object in the Aux list of the specified one.
ISDK::AuxOwner Returns the object that contains the specfied one in it's Aux list.
Object Aux list manipulation
ISDK::AttachAuxObject Attaches an object to specified object's Aux list.
ISDK::DeleteAuxObject Removes and deletes the specified object.
ISDK::RemoveAuxObject Removes the specified object from the Aux list. Does not delete the object.
Object aux list tools
ISDK::FindAuxObject Searches for a particular object in the specified object's Aux list.

See Also

VCOM:VectorWorks:ISDK::GetObjectType