SDK:IWidgetsProvider

From Vectorworks Developer
Revision as of 14:17, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

Provides widget accessing capabilities for SDK:Parametric Custom Shape Pane support.

This interface is obtained using interface VCOM:VectorWorks:PluginSupport:IExtendedProps from function IExtendedProps::GetObjComponentTypeWidgets.

Interface

//----------------------------------------------------------
class IWidgetsProvider
// Widgets provider interface for parametric objects
{
public:
  virtual bool               IsUsed(bool bCheck) = 0;
  virtual TComponentTypeID   GetComponentTypeID() const = 0;
  virtual size_t             GetWidgetsCount() const = 0;
  virtual SWidgetDefinition& GetWidgetAt(size_t index) = 0;
  virtual SWidgetDefinition* GetWidgetByID(Sint32 widgetID) = 0;
};

Members

IsUsed For internal NNA use.
GetComponentTypeID Return the component that this instance defines widgets of. See SDK:Parametric Components.
GetWidgetsCount Return the number of widgets defined in this instance.
GetWidgetAt Return the widget at the specified index.
GetWidgetByID Return the widget with the specified ID.

Remarks

The structure SDK:SWidgetDefinition is used to define a widget.

Version

Available from: VectorWorks 2009

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider | VCOM:VectorWorks:PluginSupport:IExtendedProps | SDK:SWidgetDefinition

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider]] | [[VCOM:VectorWorks:PluginSupport:IExtendedProps]] | [[SDK:SWidgetDefinition]]