SDK:Debugging SDK Plugins

From Vectorworks Developer
Revision as of 16:50, 15 November 2017 by Root (talk | contribs) (Created page with "{{LocationMain|category=LocationSDKSpecial|specific=}} == The Problem == After the Unicode conversion (Vectorworks 2018), there are some issues (crashing) with the debugging...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

The Problem

After the Unicode conversion (Vectorworks 2018), there are some issues (crashing) with the debugging SDK plugins with Vectorworks.

This is Windows ONLY problem!

The problem is the fact that the SDK uses STL for the TXString representation.

On Windows, the STL is compiled differently between Debug and Release configurations. So, when a plugin is compiled in Debug configuration, it cannot run with the Release Vectorworks. In fact, it will cause Vectorworks to crash!

The Solution

The solution is to change the Debug configuration so it would build like-release, but still support debugging so the plugin code can be stepped through and variables monitored.

Again, this is Windows ONLY problem with VisualStudio