SDK: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
Line 63: Line 63:
== Version Information ==
== Version Information ==


*[[SDK:Vectorworks 2017 Development|Vectorworks 2017]]
*[[SDK:Vectorworks 2016 Development|Vectorworks 2016]]
*[[SDK:Vectorworks 2016 Development|Vectorworks 2016]]
*[[SDK:Vectorworks 2015 Development|Vectorworks 2015]]
*[[SDK:Vectorworks 2015 Development|Vectorworks 2015]]

Revision as of 13:43, 21 September 2016

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

The SDK

Vectorworks (http://www.vectorworks.net) provides an open architecture that allows developers to supplement or replace existing Vectorworks functionality. From the user’s perspective, these new tools, menu commands, and objects are indistinguishable from those built into Vectorworks. As such, they are first class solutions for the user.

The SDK provides OS independent functionality for accessing the application routines. Also, it provides functions for creating OS independent User Interface for your plug-ins.

The SDK for beginners

Basics

The Vectorworks SDK uses the C++ language to develop extension functionality. To develop SDK plug-ins for Vectorworks, you will need the following tools:

  • Vectorworks 2014:
    • MS Visual Studio 2012 for MS Windows XP and later.
    • A modified Xcode 4.5.2 for Mac OS X 10.6.0 and later.
  • Vectorworks 2013:
    • MS Visual Studio 2005 for MS Windows XP and later.
    • Xcode 3.2 for Mac OS X 10.6.0 and later.

Before you begin, you should review the Vectorworks environment.

The Vectorworks SDK provides some specific types. A developer should use the recommended types. Here is a short list of most commonly used types:

Working with the SDK

Plug-ins Modules

Vectorworks plug-in is a dynamic library on Windows and a specific type bundle on Mac.

On launch time Vectorworks enumerates the 'Plug-ins' folder next to the application for dynamic libraries (or bundles). Also, Vectorworks traverses shortcuts (aliases) placed in the folder hierarchy.

Each Plug-in module is a VCOM:VCOM (Vectorworks Component Object Model) provider library. This library provides one or many VCOM implementation of standard interfaces for the different extensions.

More information on the topic see here.

Layout Manager

SDK:Layout Manager

VWFC

SDK:VectorWorks Foundation Classes

Version Information