SDK: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (improve grammar)
(Update page to describe what development tools are required for VW 2013 and VW 2014)
Line 20: Line 20:
== Basics ==
== Basics ==


The Vectorworks SDK uses the C++ language to develop extension functionality. To compile SDK plug-ins you need VisualStudio 2005 for Windows, and Xcode 3.2 for Mac.
The Vectorworks SDK uses the C++ language to develop extension functionality. To develop SDK plug-ins for Vectorworks, you will need the following tools:
 
* Vectorworks 2014:
** MS Visual Studio 2012 for MS Windows XP and later.
** A [[how_to_modify_xcode452_for_vectorworks2014_development|modified Xcode 4.5.2]] for Mac OS X 10.6.0 and later.
 
* Vectorworks 2013:
** MS Visual Studio 2005 for MS Windows XP and later.
** Xcode 3.2 for Mac OS X 10.6.0 and later.


Before you begin, you should review [[SDK:The Vectorworks Environment|the Vectorworks environment]].
Before you begin, you should review [[SDK:The Vectorworks Environment|the Vectorworks environment]].

Revision as of 15:50, 17 September 2013

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

The SDK

Vectorworks (http://www.vectorworks.net) provides an open architecture that allows developers to supplement or replace existing Vectorworks functionality. From the user’s perspective, these new tools, menu commands, and objects are indistinguishable from those built into Vectorworks. As such, they are first class solutions for the user.

The SDK provides OS independent functionality for accessing the application routines. Also, it provides functions for creating OS independent User Interface for your plug-ins.

The SDK for beginners

Here is a simple tutorial that can help beginners start developing SDK plug-ins for Vectorworks.

Basics

The Vectorworks SDK uses the C++ language to develop extension functionality. To develop SDK plug-ins for Vectorworks, you will need the following tools:

  • Vectorworks 2014:
    • MS Visual Studio 2012 for MS Windows XP and later.
    • A modified Xcode 4.5.2 for Mac OS X 10.6.0 and later.
  • Vectorworks 2013:
    • MS Visual Studio 2005 for MS Windows XP and later.
    • Xcode 3.2 for Mac OS X 10.6.0 and later.

Before you begin, you should review the Vectorworks environment.

The Vectorworks SDK provides some specific types. A developer should use the recommended types. Here is a short list of most commonly used types:

Plug-ins Modules

Vectorworks plug-in is a dynamic library on Windows and a specific type bundle on Mac.

On launch time Vectorworks enumerates the 'Plug-ins' folder next to the application for dynamic libraries (or bundles). Also, Vectorworks traverses shortcuts (aliases) placed in the folder hierarchy.

Each Plug-in module is a VCOM:VCOM (Vectorworks Component Object Model) provider library. This library provides one or many VCOM implementation of standard interfaces for the different extensions.

More information on the topic see here.

Layout Manager

SDK:Layout Manager

VWFC

SDK:VectorWorks Foundation Classes