SDK: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Update page to describe what development tools are required for VW 2013 and VW 2014)
No edit summary
Line 57: Line 57:


[[SDK:VectorWorks Foundation Classes]]
[[SDK:VectorWorks Foundation Classes]]
== Version Information ==
=== Vectorworls 2009 ===
*[[SDK:Vectorworks 2009 Development|Development]]
*[[SDK:Vectorworks 2009 New Functions|New Functions]]
=== Vectorworls 2010 ===
*[[SDK:Vectorworks 2010 Development|Development]]
*[[SDK:Vectorworks 2010 New Functions|New Functions]]
=== Vectorworls 2011 ===
*[[SDK:Vectorworks 2011 Development|Development]]
*[[SDK:Vectorworks 2011 New Functions|New Functions]]
=== Vectorworls 2012 ===
*[[SDK:Vectorworks 2012 Development|Development]]
*[[SDK:Vectorworks 2012 New Functions|New Functions]]
*[[SDK:Vectorworks 2012 Deprecated Functions|Deprecated Functions]]
=== Vectorworls 2013 ===
*[[SDK:Vectorworks 2013 Development|Development]]
*[[SDK:Vectorworks 2013 New Functions|New Functions]]
=== Vectorworls 2014 ===
*[[SDK:Vectorworks 2014]]


[[Category:SDK]]
[[Category:SDK]]

Revision as of 18:17, 18 September 2013

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

The SDK

Vectorworks (http://www.vectorworks.net) provides an open architecture that allows developers to supplement or replace existing Vectorworks functionality. From the user’s perspective, these new tools, menu commands, and objects are indistinguishable from those built into Vectorworks. As such, they are first class solutions for the user.

The SDK provides OS independent functionality for accessing the application routines. Also, it provides functions for creating OS independent User Interface for your plug-ins.

The SDK for beginners

Here is a simple tutorial that can help beginners start developing SDK plug-ins for Vectorworks.

Basics

The Vectorworks SDK uses the C++ language to develop extension functionality. To develop SDK plug-ins for Vectorworks, you will need the following tools:

  • Vectorworks 2014:
    • MS Visual Studio 2012 for MS Windows XP and later.
    • A modified Xcode 4.5.2 for Mac OS X 10.6.0 and later.
  • Vectorworks 2013:
    • MS Visual Studio 2005 for MS Windows XP and later.
    • Xcode 3.2 for Mac OS X 10.6.0 and later.

Before you begin, you should review the Vectorworks environment.

The Vectorworks SDK provides some specific types. A developer should use the recommended types. Here is a short list of most commonly used types:

Plug-ins Modules

Vectorworks plug-in is a dynamic library on Windows and a specific type bundle on Mac.

On launch time Vectorworks enumerates the 'Plug-ins' folder next to the application for dynamic libraries (or bundles). Also, Vectorworks traverses shortcuts (aliases) placed in the folder hierarchy.

Each Plug-in module is a VCOM:VCOM (Vectorworks Component Object Model) provider library. This library provides one or many VCOM implementation of standard interfaces for the different extensions.

More information on the topic see here.

Layout Manager

SDK:Layout Manager

VWFC

SDK:VectorWorks Foundation Classes

Version Information

Vectorworls 2009

Vectorworls 2010

Vectorworls 2011

Vectorworls 2012

Vectorworls 2013

Vectorworls 2014