Help:Adding VectorScript Function Reference

From Vectorworks Developer
Revision as of 14:15, 13 August 2013 by Root (talk | contribs) (Created page with "<div class="rightmenu"> __TOC__ </div> == Naming == The actual type of the reference page (is it VectorScript or SDK or VCOM) is determined by the category in which the page ...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

Naming

The actual type of the reference page (is it VectorScript or SDK or VCOM) is determined by the category in which the page exist.

The category is represented in the name before the semi-colon in the name.

For example "VS:Something" is a page "Something" in category "VS".

IMPORTANT Be careful when naming pages. The name is very important!

See Help:Contents#Page Name

General Function Page

Here is information of how to format general function reference page.

More information on the pages and the tags here Help:Adding Function Reference.

Here is template for VectorScript function reference pages:

__TOC__
<vwDoc>

-----------------------------------------------------------------------------------------------------------
<desc>
... some description ...
</desc>

-----------------------------------------------------------------------------------------------------------
<def>
<funcDef lang="vs">
... function definition ...
</funcDef>
</def>

-----------------------------------------------------------------------------------------------------------
<params>
<lineList ident=1>
<line>
...parameter type...
...parameter name...
...parameter information...
</line>
</lineList>
</params>

-----------------------------------------------------------------------------------------------------------
<return>
</return>

-----------------------------------------------------------------------------------------------------------
<remark>
</remark>

-----------------------------------------------------------------------------------------------------------
<sample>
</sample>

-----------------------------------------------------------------------------------------------------------
<version>
</version>

-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>

</vwDoc>

[[Category:VS Function Reference|_function_name_]]

See Also