Help:Adding VectorScript Function Reference: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "<div class="rightmenu"> __TOC__ </div> == Naming == The actual type of the reference page (is it VectorScript or SDK or VCOM) is determined by the category in which the page ...")
 
No edit summary
 
Line 1: Line 1:
<div id="location-source">
.Help:Contents|Help
..Help:Contents|General Help
..Help:Adding Article|Adding Article
..Help:Adding Function Reference|Adding Function Reference
..Help:Adding General Function Reference|Adding General Function Reference
..Help:Adding VCOM Function Reference|Adding VCOM Function Reference
..Help:Adding VectorScript Function Reference|Adding VectorScript Function Reference
</div>
<div class="rightmenu">
<div class="rightmenu">
__TOC__
__TOC__

Latest revision as of 12:51, 14 August 2013

.Help:Contents|Help ..Help:Contents|General Help ..Help:Adding Article|Adding Article ..Help:Adding Function Reference|Adding Function Reference ..Help:Adding General Function Reference|Adding General Function Reference ..Help:Adding VCOM Function Reference|Adding VCOM Function Reference ..Help:Adding VectorScript Function Reference|Adding VectorScript Function Reference

Naming

The actual type of the reference page (is it VectorScript or SDK or VCOM) is determined by the category in which the page exist.

The category is represented in the name before the semi-colon in the name.

For example "VS:Something" is a page "Something" in category "VS".

IMPORTANT Be careful when naming pages. The name is very important!

See Help:Contents#Page Name

General Function Page

Here is information of how to format general function reference page.

More information on the pages and the tags here Help:Adding Function Reference.

Here is template for VectorScript function reference pages:

__TOC__
<vwDoc>

-----------------------------------------------------------------------------------------------------------
<desc>
... some description ...
</desc>

-----------------------------------------------------------------------------------------------------------
<def>
<funcDef lang="vs">
... function definition ...
</funcDef>
</def>

-----------------------------------------------------------------------------------------------------------
<params>
<lineList ident=1>
<line>
...parameter type...
...parameter name...
...parameter information...
</line>
</lineList>
</params>

-----------------------------------------------------------------------------------------------------------
<return>
</return>

-----------------------------------------------------------------------------------------------------------
<remark>
</remark>

-----------------------------------------------------------------------------------------------------------
<sample>
</sample>

-----------------------------------------------------------------------------------------------------------
<version>
</version>

-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>

</vwDoc>

[[Category:VS Function Reference|_function_name_]]

See Also