Energos: Use Record Formats to define energy analysis data: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 29: Line 29:
{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
|-
| Sort Index || Integer || Index used to order the elements
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Name || Text||  
| Name || Text|| || FieldText_Name
|-
|-
| Area || Number|| Area value in document units
| Area || Number|| Area value in document units || FieldDim_Area
|-
|-
| UValue || Number || U - value in document units
| UValue || Number || U - value in document units || FieldReal_UValue
|-
|-
| Orientation || Integer || Orientation values:<br/>
| Orientation || Integer || Orientation values:<br/>
Line 48: Line 48:
6 - West<br/>
6 - West<br/>
7 - NorthWest<br/>
7 - NorthWest<br/>
8 - Horizontal<br/>
8 - Horizontal || FieldInt_Orientation
|-
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
| Inclination || Integer || Orientation inclination degrees:<br/>
Line 62: Line 62:
9 = 150<br/>
9 = 150<br/>
10 = 165<br/>
10 = 165<br/>
11 = 180 - Horizontal<br/>
11 = 180 - Horizontal || FieldInt_OrientInclination
|-
|-
| Reduction Factor Shading || Number ||  
| Reduction Factor Shading || Number || || FieldReal_ReductionFactorShading
|-
|-
| Wall Type|| Integer || <br/>
| Wall Type|| Integer || <br/>
0 - Exterior Ambient<br/>
0 - Exterior Ambient<br/>
1 - Exterior Ground<br/>
1 - Exterior Ground<br/>
2 - Partition To Neighbour<br/>
2 - Partition To Neighbour || FieldInt_WallType
|}
|}


Line 80: Line 80:
{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
|-
| Sort Index || Integer || Index used to order the elements
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Name || Text||  
| Name || Text|| || FieldText_Name
|-
|-
| Area || Number|| Area value in document units
| Quantity || Integer ||   || FieldLong_Quantity
|-
| Quantity || Integer ||
|-
|-
| Location || Integer || Location values:<br/>
| Location || Integer || Location values:<br/>
Line 94: Line 92:
1 - Ambient<br/>
1 - Ambient<br/>
2 - Perimeter<br/>
2 - Perimeter<br/>
3 - Floor/Slab
3 - Floor/Slab || FieldLong_Location
|-
|-
| Length || Number || thermal bridge length in document units
| Length || Number || thermal bridge length in document units || FieldDim_Length
|-
|-
| PSI || Number ||  
| PSI || Number || || FieldReal_PSI
|}
|}
'''Note:''' strings are localizable via 'FormatDef_ThermalBridge.vwstrings' of the EnergyAnalysis.vwr
'''Note:''' strings are localizable via 'FormatDef_ThermalBridge.vwstrings' of the EnergyAnalysis.vwr
Line 114: Line 112:
{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
|-
| Sort Index || Integer || Index used to order the elements
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Name || Text ||  
| Name || Text || || FieldText_Name
|-
|-
| Area || Number || Area value in document units
| Area || Number || Area value in document units || FieldDim_Area
|-
|-
| UValue || Number || U - value in document units
| UValue || Number || U - value in document units || FieldReal_UValue
|-
|-
| Orientation || Integer || Orientation values:<br/>
| Orientation || Integer || Orientation values:<br/>
Line 133: Line 131:
6 - West<br/>
6 - West<br/>
7 - NorthWest<br/>
7 - NorthWest<br/>
8 - Horizontal
8 - Horizontal || FieldInt_Orientation
|-
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
| Inclination || Integer || Orientation inclination degrees:<br/>
Line 147: Line 145:
9 = 150<br/>
9 = 150<br/>
10 = 165<br/>
10 = 165<br/>
11 = 180 - Horizontal<br/>
11 = 180 - Horizontal<br/> || FieldInt_OrientInclination
|-
|-
| Width || Number || Width in document units
| Width || Number || Width in document units || FieldDim_Width
|-
|-
| Glazing Area || Number || Glazing area in document units
| Glazing Area || Number || Glazing area in document units || FieldDim_GlazingArea
|-
|-
| Glazing Length || Number || Glazing length in document units
| Glazing Length || Number || Glazing length in document units || FieldDim_GlazingLength
|-
|-
| Frame Length || Number || Frame length in document units
| Frame Length || Number || Frame length in document units || FieldDim_FrameLength
|-
|-
| Light Transmission Glazing || Number ||  
| Light Transmission Glazing || Number || || FieldReal_LightTrasmGlazing
|-
|-
| General Shading || Number || Shading values:<br/>
| General Shading || Number || Shading values:<br/>
Line 164: Line 162:
-2 - Medium<br/>
-2 - Medium<br/>
-3 - High<br/>
-3 - High<br/>
X - Custom Value as Specified<br/>
X - Custom Value as Specified<br/> || FieldReal_ShadingGeneral
|-
|-
| Surrounding Shading || Number || Same values as general shading
| Surrounding Shading || Number || Same values as general shading || FieldReal_ShadingSurrounding
|-
|-
| Summer Shading || Number || Same values as general shading
| Summer Shading || Number || Same values as general shading || FieldReal_ShadingSummer
|-
|-
| Additional Shading || Number || Same values as general shading
| Additional Shading || Number || Same values as general shading || FieldReal_ShadingAdditional
|}
|}
'''Note:''' strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr
'''Note:''' strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr
Line 186: Line 184:
{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
|-
| Sort Index || Integer || Index used to order the elements
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Name || Text ||  
| Name || Text || || FieldText_Name
|-
|-
| Area || Number || Area value in document units
| Area || Number || Area value in document units || FieldDim_Area
|-
|-
| UValue || Number || U - value in document units
| UValue || Number || U - value in document units || FieldReal_UValue
|-
|-
| Orientation || Integer || Orientation values:<br/>
| Orientation || Integer || Orientation values:<br/>
Line 205: Line 203:
6 - West<br/>
6 - West<br/>
7 - NorthWest<br/>
7 - NorthWest<br/>
8 - Horizontal<br/>
8 - Horizontal<br/> || FieldInt_Orientation
|-
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
| Inclination || Integer || Orientation inclination degrees:<br/>
Line 219: Line 217:
9 = 150<br/>
9 = 150<br/>
10 = 165<br/>
10 = 165<br/>
11 = 180 - Horizontal<br/>
11 = 180 - Horizontal<br/> || FieldInt_OrientInclination
|-
|-
| Width || Number || Width in document units
| Width || Number || Width in document units || FieldDim_Width
|-
|-
| Glazing Area || Number || Glazing area in document units
| Glazing Area || Number || Glazing area in document units || FieldDim_GlazingArea
|-
|-
| Glazing Length || Number || Glazing length in document units
| Glazing Length || Number || Glazing length in document units || FieldDim_GlazingLength
|-
|-
| Frame Length || Number || Frame length in document units
| Frame Length || Number || Frame length in document units || FieldDim_FrameLength
|-
|-
| Light Transmission Glazing || Number ||  
| Light Transmission Glazing || Number || || FieldReal_LightTrasmGlazing
|-
|-
| General Shading || Number || Shading values:<br/>
| General Shading || Number || Shading values:<br/>
Line 236: Line 234:
-2 - Medium<br/>
-2 - Medium<br/>
-3 - High<br/>
-3 - High<br/>
X - Custom Value as Specified<br/>
X - Custom Value as Specified<br/> || FieldReal_ShadingGeneral
|-
|-
| Surrounding Shading || Number || Same values as general shading
| Surrounding Shading || Number || Same values as general shading || FieldReal_ShadingSurrounding
|-
|-
| Summer Shading || Number || Same values as general shading
| Summer Shading || Number || Same values as general shading || FieldReal_ShadingSummer
|-
|-
| Additional Shading || Number || Same values as general shading
| Additional Shading || Number || Same values as general shading || FieldReal_ShadingAdditional
|}
|}
'''Note:''' strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr
'''Note:''' strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr
Line 258: Line 256:
{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
|-
| Name || Text ||  
| Name || Text || || FieldText_Name
|-
|-
| Area || Number || Area value in document units
| Area || Number || Area value in document units || FieldDim_Area
|-
|-
| Volume || Number || Volume value in document units
| Volume || Number || Volume value in document units || FieldDim_Volume
|-
|-
| Orientation || Integer || Orientation values:<br/>
| Orientation || Integer || Orientation values:<br/>
Line 275: Line 273:
6 - West<br/>
6 - West<br/>
7 - NorthWest<br/>
7 - NorthWest<br/>
8 - Horizontal<br/>
8 - Horizontal<br/> || FieldInt_Orientation
|-
|-
| Width || Number || Width in document units
| Width || Number || Width in document units || FieldDim_Width
|-
|-
| Depth || Number || Depth in document units
| Depth || Number || Depth in document units || FieldDim_Depth
|-
|-
| Height || Number || Height in document units
| Height || Number || Height in document units || FieldDim_Height
|-
|-
| Lintel Height || Number || Height in document units
| Lintel Height || Number || Height in document units || FieldDim_LintelHeight
|-
|-
| Window Width || Number || Width in document units
| Window Width || Number || Width in document units || FieldDim_WindowWidth
|-
|-
| Light Transmission Glazing Percent || Number ||  ||
| Light Transmission Glazing Percent || Number ||  || || FieldReal_LightTransmissionGlazingPercent
|-
|-
| Lighting Full Load Hours || Number || h/a
| Lighting Full Load Hours || Number || h/a || FieldReal_LightingFullLoadHours
|-
|-
| Installer Light Power || Number || Document unit for W/m2
| Installer Light Power || Number || Document unit for W/m2 || FieldReal_InstalledLightPower
|-
|-
| Lighting Control || Integer || Lighting Control Values:<br/>
| Lighting Control || Integer || Lighting Control Values:<br/>
Line 297: Line 295:
1 - WithoutOffMode<br/>
1 - WithoutOffMode<br/>
2 - WithOffMode<br/>
2 - WithOffMode<br/>
3 - BusSystem<br/>
3 - BusSystem<br/> || FieldInt_LightingControl
|-
|-
| Motion Detector || Boolean ||  
| Motion Detector || Boolean || || FieldBool_MotionDetector
|-
|-
| Extract Air Room Type || Integer || Extract Air Room Type Value:<br/>
| Extract Air Room Type || Integer || Extract Air Room Type Value:<br/>
Line 306: Line 304:
2 - Shower<br/>
2 - Shower<br/>
3 - WC<br/>
3 - WC<br/>
4 - Other<br/>
4 - Other<br/> || FieldInt_ExtractAirRoomType
|-
|-
| Extract Air Requirement Volume || Number || Document volume/h
| Extract Air Requirement Volume || Number || Document volume/h || FieldDim_ExtractAirRequirement
|}
|}
'''Note:''' strings are localizable via 'FormatDef_Space.vwstrings' of the EnergyAnalysis.vwr
'''Note:''' strings are localizable via 'FormatDef_Space.vwstrings' of the EnergyAnalysis.vwr
Line 325: Line 323:
{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
|-
| Sort Index || Integer || Index used to order the elements
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Name || Text ||  
| Name || Text || || FieldText_Name
|-
|-
| Area || Number || Area value in document units
| Area || Number || Area value in document units || FieldDim_Area
|-
|-
| UValue || Number || U - value in document units
| UValue || Number || U - value in document units || FieldReal_UValue
|-
|-
| Orientation || Integer || Orientation values:<br/>
| Orientation || Integer || Orientation values:<br/>
Line 344: Line 342:
6 - West<br/>
6 - West<br/>
7 - NorthWest<br/>
7 - NorthWest<br/>
8 - Horizontal<br/>
8 - Horizontal<br/> || FieldInt_Orientation
|-
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
| Inclination || Integer || Orientation inclination degrees:<br/>
Line 358: Line 356:
9 = 150<br/>
9 = 150<br/>
10 = 165<br/>
10 = 165<br/>
11 = 180 - Horizontal<br/>
11 = 180 - Horizontal<br/> || FieldInt_OrientInclination
|-
|-
| RS Internal || Number ||
| RS Internal || Number || || FieldReal_RSInternal
|-
|-
| RS External || Number ||  
| RS External || Number || || FieldReal_RSExternal
|-
|-
| Exposed Perimeter To Open || Number ||
| Exposed Perimeter To Open || Number || || FieldReal_ExposedPerimToOpen
|}
|}
Note: strings are localizable via 'FormatDef_Slab.vwstrings' of the EnergyAnalysis.vwr
Note: strings are localizable via 'FormatDef_Slab.vwstrings' of the EnergyAnalysis.vwr


Wall -- Attach a record of this format to define the energy properties of a wall
Format name: Energos Wall
{| class="wikitable"
|-
| Field name || Unit || Description
|-
| Sort Index || Integer || Index used to order the elements
|-
| Name || Text ||
|-
| Area || Number || Area value in document units
|-
| UValue || Number || U - value in document units
|-
| Orientation || Integer || Orientation values:<br/>
0 - North<br/>
1 - NorthEast<br/>
2 - East<br/>
3 - SouthEast<br/>
4 - South<br/>
5 - SouthWest<br/>
6 - West<br/>
7 - NorthWest<br/>
8 - Horizontal<br/>
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
0 = 0 - Horizontal<br/>
1 = 15<br/>
2 = 30<br/>
3 = 45<br/>
4 = 60<br/>
5 = 90 - Vertical<br/>
6 = 105<br/>
7 = 120<br/>
8 = 135<br/>
9 = 150<br/>
10 = 165<br/>
11 = 180 - Horizontal<br/>
|-
| Reduction Factor Shading || Number ||
|-
| Wall Type || Integer || Wall types:<br/>
0 = Exterior Ambient<br/>
1 = Exterior Ground<br/>
2 = Partition to Neighbour<br/>
|}
'''Note:''' strings are localizable via 'FormatDef_Wall.vwstrings' of the EnergyAnalysis.vwr


=== Roof ===
=== Roof ===
Line 432: Line 375:
{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
| Sort Index || Integer || Index used to order the elements
|-
|-
| Name || Text ||  
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Area || Number || Area value in document units
| Name || Text || || FieldText_Name
|-
|-
| UValue || Number || U - value in document units
| Area || Number || Area value in document units || FieldDim_Area
|-
|-
| Orientation || Integer ||
| UValue || Number || U - value in document units || FieldReal_UValue
|-
|-
| Orientation || Integer || values:<br/>
| Orientation || Integer || values:<br/>
Line 453: Line 394:
6 - West<br/>
6 - West<br/>
7 - NorthWest<br/>
7 - NorthWest<br/>
8 - Horizontal<br/>
8 - Horizontal<br/> || FieldInt_Orientation
|-
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
| Inclination || Integer || Orientation inclination degrees:<br/>
Line 467: Line 408:
9 = 150<br/>
9 = 150<br/>
10 = 165<br/>
10 = 165<br/>
11 = 180 - Horizontal
11 = 180 - Horizontal || FieldInt_OrientInclination
|-
|-
| Reduction Factor Shading || Number ||  
| Reduction Factor Shading || Number || || FieldReal_ReductionFactorShading
|}
|}



Revision as of 16:03, 23 March 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

By Vladislav Stanev

Records can be attached to any object to define energy analysis data to be used. Depending on the record the object is identified and used as the corresponding energy analysis element.

Note that these records/formats don't define the full set of properties. They are designed for simplicity to allow any Vectorworks object to be setup to participate in the energy analysis.

if you are integrating custom parametric objects with the energy analysis feature see:

Here is the definition of the formats that are recognized by the feature (all noted units are units defined by the energy analysis units settings):

Formats

Note: that all the format names and fields are localized. This means that in localized versions of Vectorworks, they will be in the corresponding language. Note the information of how to read the resource containing the localized strings, or look at the scripts below.

Wall

Attach a record of this format to define the energy properties of a wall

Format name: Energos Wall

Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text FieldText_Name
Area Number Area value in document units FieldDim_Area
UValue Number U - value in document units FieldReal_UValue
Orientation Integer Orientation values:

0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal || FieldInt_Orientation

Inclination Integer Orientation inclination degrees:

0 = 0 - Horizontal
1 = 15
2 = 30
3 = 45
4 = 60
5 = 90 - Vertical
6 = 105
7 = 120
8 = 135
9 = 150
10 = 165
11 = 180 - Horizontal || FieldInt_OrientInclination

Reduction Factor Shading Number FieldReal_ReductionFactorShading
Wall Type Integer

0 - Exterior Ambient
1 - Exterior Ground
2 - Partition To Neighbour || FieldInt_WallType

Note: strings are localizable via 'FormatDef_Wall.vwstrings' of the EnergyAnalysis.vwr

Thermal Bridge

Attach a record of this format to define the energy properties of a thermal-bridge

Format name: Energos Thermal Bridge

Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text FieldText_Name
Quantity Integer FieldLong_Quantity
Location Integer Location values:

0 - None
1 - Ambient
2 - Perimeter
3 - Floor/Slab || FieldLong_Location

Length Number thermal bridge length in document units FieldDim_Length
PSI Number FieldReal_PSI

Note: strings are localizable via 'FormatDef_ThermalBridge.vwstrings' of the EnergyAnalysis.vwr



Window

Attach a record of this format to define the energy properties of a window

Format name: Energos Window

Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text FieldText_Name
Area Number Area value in document units FieldDim_Area
UValue Number U - value in document units FieldReal_UValue
Orientation Integer Orientation values:

0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal || FieldInt_Orientation

Inclination Integer Orientation inclination degrees:

0 = 0 - Horizontal
1 = 15
2 = 30
3 = 45
4 = 60
5 = 90 - Vertical
6 = 105
7 = 120
8 = 135
9 = 150
10 = 165
11 = 180 - Horizontal
|| FieldInt_OrientInclination

Width Number Width in document units FieldDim_Width
Glazing Area Number Glazing area in document units FieldDim_GlazingArea
Glazing Length Number Glazing length in document units FieldDim_GlazingLength
Frame Length Number Frame length in document units FieldDim_FrameLength
Light Transmission Glazing Number FieldReal_LightTrasmGlazing
General Shading Number Shading values:

0 - None
-1 - Low
-2 - Medium
-3 - High
X - Custom Value as Specified
|| FieldReal_ShadingGeneral

Surrounding Shading Number Same values as general shading FieldReal_ShadingSurrounding
Summer Shading Number Same values as general shading FieldReal_ShadingSummer
Additional Shading Number Same values as general shading FieldReal_ShadingAdditional

Note: strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr



Door

Attach a record of this format to define the energy properties of a door

Format name: Energos Door

Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text FieldText_Name
Area Number Area value in document units FieldDim_Area
UValue Number U - value in document units FieldReal_UValue
Orientation Integer Orientation values:

0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal
|| FieldInt_Orientation

Inclination Integer Orientation inclination degrees:

0 = 0 - Horizontal
1 = 15
2 = 30
3 = 45
4 = 60
5 = 90 - Vertical
6 = 105
7 = 120
8 = 135
9 = 150
10 = 165
11 = 180 - Horizontal
|| FieldInt_OrientInclination

Width Number Width in document units FieldDim_Width
Glazing Area Number Glazing area in document units FieldDim_GlazingArea
Glazing Length Number Glazing length in document units FieldDim_GlazingLength
Frame Length Number Frame length in document units FieldDim_FrameLength
Light Transmission Glazing Number FieldReal_LightTrasmGlazing
General Shading Number Shading values:

0 - None
-1 - Low
-2 - Medium
-3 - High
X - Custom Value as Specified
|| FieldReal_ShadingGeneral

Surrounding Shading Number Same values as general shading FieldReal_ShadingSurrounding
Summer Shading Number Same values as general shading FieldReal_ShadingSummer
Additional Shading Number Same values as general shading FieldReal_ShadingAdditional

Note: strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr



Space

Attach a record of this format to define the energy properties of a space

Format name: Energos Space

Field name Unit Description .vwstring key
Name Text FieldText_Name
Area Number Area value in document units FieldDim_Area
Volume Number Volume value in document units FieldDim_Volume
Orientation Integer Orientation values:

0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal
|| FieldInt_Orientation

Width Number Width in document units FieldDim_Width
Depth Number Depth in document units FieldDim_Depth
Height Number Height in document units FieldDim_Height
Lintel Height Number Height in document units FieldDim_LintelHeight
Window Width Number Width in document units FieldDim_WindowWidth
Light Transmission Glazing Percent Number FieldReal_LightTransmissionGlazingPercent
Lighting Full Load Hours Number h/a FieldReal_LightingFullLoadHours
Installer Light Power Number Document unit for W/m2 FieldReal_InstalledLightPower
Lighting Control Integer Lighting Control Values:

0 - Manual
1 - WithoutOffMode
2 - WithOffMode
3 - BusSystem
|| FieldInt_LightingControl

Motion Detector Boolean FieldBool_MotionDetector
Extract Air Room Type Integer Extract Air Room Type Value:

0 - Kitchen
1 - Bathroom
2 - Shower
3 - WC
4 - Other
|| FieldInt_ExtractAirRoomType

Extract Air Requirement Volume Number Document volume/h FieldDim_ExtractAirRequirement

Note: strings are localizable via 'FormatDef_Space.vwstrings' of the EnergyAnalysis.vwr




Slab

Attach a record of this format to define the energy properties of a slab

Format name: Energos Slab

Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text FieldText_Name
Area Number Area value in document units FieldDim_Area
UValue Number U - value in document units FieldReal_UValue
Orientation Integer Orientation values:

0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal
|| FieldInt_Orientation

Inclination Integer Orientation inclination degrees:

0 = 0 - Horizontal
1 = 15
2 = 30
3 = 45
4 = 60
5 = 90 - Vertical
6 = 105
7 = 120
8 = 135
9 = 150
10 = 165
11 = 180 - Horizontal
|| FieldInt_OrientInclination

RS Internal Number FieldReal_RSInternal
RS External Number FieldReal_RSExternal
Exposed Perimeter To Open Number FieldReal_ExposedPerimToOpen

Note: strings are localizable via 'FormatDef_Slab.vwstrings' of the EnergyAnalysis.vwr


Roof

Attach a record of this format to define the energy properties of a roof

Format name: Energos Roof

Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text FieldText_Name
Area Number Area value in document units FieldDim_Area
UValue Number U - value in document units FieldReal_UValue
Orientation Integer values:

0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal
|| FieldInt_Orientation

Inclination Integer Orientation inclination degrees:

0 = 0 - Horizontal
1 = 15
2 = 30
3 = 45
4 = 60
5 = 90 - Vertical
6 = 105
7 = 120
8 = 135
9 = 150
10 = 165
11 = 180 - Horizontal || FieldInt_OrientInclination

Reduction Factor Shading Number FieldReal_ReductionFactorShading

Note: strings are localizable via 'FormatDef_Roof.vwstrings' of the EnergyAnalysis.vwr


Example Scripts - Python Script

You can use the following scripts to create the formats:

Wall

# Energos Thermal Bridge
vwr = 'EnergyAnalysis/Strings/FormatDef_Wall.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_SortIndex"              ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldText_Name"                  ), '', 4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldDim_Area"                   ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldReal_UValue"                ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_Orientation"            ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_OrientInclination"      ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldReal_ReductionFactorShading"), '0', 3, 0 ) #real	
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_WallType"               ), '0', 1, 0 ) #int

Thermal Bridge

# Energos Thermal Bridge
vwr = 'EnergyAnalysis/Strings/FormatDef_ThermalBridge.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'    ), '', 4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldLong_Quantity'), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldLong_Location'), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Length'   ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_PSI'     ), '0', 3, 0 ) #real


Window

# Energos Window
vwr = 'EnergyAnalysis/Strings/FormatDef_WinDoor.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatNameWindow' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'          ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'              ), '',  4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'               ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'            ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'        ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination'  ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Width'              ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingArea'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingLength'      ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_FrameLength'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightTrasmGlazing' ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingGeneral'    ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSurrounding'), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSummer'     ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingAdditional' ), '0', 3, 0 ) #real


Door

# Energos Door
vwr = 'EnergyAnalysis/Strings/FormatDef_WinDoor.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatNameDoor' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'          ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'              ), '',  4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'               ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'            ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'        ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination'  ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Width'              ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingArea'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingLength'      ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_FrameLength'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightTrasmGlazing' ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingGeneral'    ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSurrounding'), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSummer'     ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingAdditional' ), '0', 3, 0 ) #real


Space

# Energos Space
vwr = 'EnergyAnalysis/Strings/FormatDef_Space.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'                           ), '',  4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'                            ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Volume'                          ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'                     ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Width'                           ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Depth'                           ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Height'                          ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_LintelHeight'                    ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_WindowWidth'                     ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightTransmissionGlazingPercent'), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightingFullLoadHours'          ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_InstalledLightPower'            ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_LightingControl'                 ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldBool_MotionDetector'                 ), '0', 2, 0 ) #bool
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_ExtractAirRoomType'              ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_ExtractAirRequirement'           ), '0', 3, 0 ) #real

Slab

# Energos Slab
vwr = 'EnergyAnalysis/Strings/FormatDef_Slab.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'          ), '0', 1, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'              ), '',  4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'               ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'            ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'        ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination'  ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_RSInternal'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_RSExternal'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ExposedPerimToOpen'), '0', 3, 0 ) #real


Roof

# Energos Roof
vwr = 'EnergyAnalysis/Strings/FormatDef_Roof.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'              ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'                  ), '',  4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'                   ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'                ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'            ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination'      ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ReductionFactorShading'), '0', 3, 0 ) #real