Category:VS Function Reference:Criteria

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

List of VectorScript functions in Criteria category:

Note
All Criteria do not support variables stored in structures (tested under VW 11.5 through 12.5). The following example shows the failure and a possible workaround:
{ try on a drawing with some lines in class 'none' }
PROCEDURE xxxxx;
	TYPE
		whatever = STRUCTURE
			foo : STRING;
		END;
	VAR
		test : whatever;
		classVal, tryTrick	: STRING;
BEGIN
	classVal := 'None';
	test.foo := 'None';
	tryTrick := test.foo; { redirect the value }
	
	AlrtDialog(concat('Total LINES in class None using classVal: ', count((C= classVal) & (T=LINE)))); { all lines in class None }
	AlrtDialog(concat('Total LINES in class None using test.foo: ', count((C= test.foo) & (T=LINE)))); { doesn't work }
	AlrtDialog(concat('Total LINES in class None using tryTrick: ', count((C= tryTrick) & (T=LINE)))); { works }
END;

Run(xxxxx);

VS:Function Reference

Pages in category "VS Function Reference:Criteria"

The following 115 pages are in this category, out of 115 total.