VS:GetLayerElevationN

From Vectorworks Developer
Revision as of 22:02, 11 September 2024 by Root (talk | contribs) (1 revision imported)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the elevation and thickness of the specified layer in document units.

PROCEDURE GetLayerElevationN(
h :HANDLE;
VAR baseElev :REAL;
VAR thickness :REAL);
def vs.GetLayerElevationN(h):
    return (baseElev, thickness)

Parameters

h HANDLE Handle to the layer.
baseElev REAL Base elevation of the layer in document units.
thickness REAL Thickness of the layer in document units.

Example

PROCEDURE Example;
VAR
	h :HANDLE; 
	baseElev, thickness :REAL;
BEGIN
	h := FLayer;
	WHILE h <> NIL DO BEGIN
		GetLayerElevationN(h, baseElev, thickness);
		thickness := thickness / (25.4 / GetPrefReal(152));
		AlrtDialog(Concat('layer name: ', GetLName(h), ', baseElev: ', baseElev, ', thickness: ', thickness));
		h := NextLayer(h);
	END;
END;
RUN(Example);

Version

Availability: from Vectorworks 2025

See Also

VS Functions:

VS:SetLayerElevationN

VS Functions: [[VS:SetLayerElevationN]]