VS:AddStoryLevelN

From Vectorworks Developer
Revision as of 22:02, 11 September 2024 by Root (talk | contribs) (1 revision imported)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds a new Story Layer to the Story pointed to by 'storyHandle'. There must not be another story level in this story that matches 'levelType' or 'elevation', or the function will fail. If the layer 'layerName' already exists, it will be associated with the new Story Level.

FUNCTION AddStoryLevelN(
storyHandle :HANDLE;
levelType :STRING;
elevation :REAL;
layerName :STRING) : BOOLEAN;
def vs.AddStoryLevelN(storyHandle, levelType, elevation, layerName):
    return BOOLEAN

Parameters

storyHandle HANDLE The handle of the story that the new level should be added to.
levelType STRING The level type of the new Story Level. This cannot be blank.
elevation REAL The elevation of the new Story Level in the story. The elevation is in document units.
layerName STRING The name of the layer to associate with the new Story Level. This is optional.

Return Value

Whether the new Story Level was created and added.

Example

VAR

storyHandle : HANDLE
success:BOOLEAN

BEGIN

storyHandle := CreateStory('Floor 1', '-1');
success := AddStoryLevelN(storyHandle, 'Finish Floor', 0, 'Floor');

Version

Availability: from Vectorworks 2025

See Also

VS Functions:

VS:CreateStory | VS:AddLevelFromTemplate | VS:RemoveStoryLevel | VS:SetLevelElevationN | VS:GetLevelElevationN

VS Functions:

[[VS:CreateStory]] | [[VS:AddLevelFromTemplate]] | [[VS:RemoveStoryLevel]] | [[VS:SetLevelElevationN]]

| [[VS:GetLevelElevationN]]