VCOM:VectorWorks:ISDK::Project3DModelPtToScreen: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
mNo edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:ISDK]]
Member of [[VCOM:VectorWorks:ISDK]]


Projects the given 3D world point to the Screen plane, and returns a 2D point.
Projects the given 3D world point to the Screen plane, and returns a 2D point. It is a good idea to confirm if the return value is true, before using the converted 2D point.
</desc>
</desc>



Latest revision as of 19:55, 19 September 2013

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Projects the given 3D world point to the Screen plane, and returns a 2D point. It is a good idea to confirm if the return value is true, before using the converted 2D point.

virtual BooleanVCOM_CALLTYPE Project3DModelPtToScreen(
const WorldPt3& inwpt3Model,
WorldPt& outwptScreen) = 0;

Parameters

inwpt3Model const SDK:WorldPt3& no info.
outwptScreen SDK:WorldPt& no info.

Version

Availability: from Vectorworks 2014