VS:ReplaceText: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
VS>Unknown user
No edit summary
m (1 revision imported)
 
(No difference)

Latest revision as of 22:02, 11 September 2024

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure ReplaceText replace the oldText with the newText of the referenced text object.

PROCEDURE ReplaceText(
objectHd :HANDLE;
oldText :STRING;
newText :STRING;
replaceAll :BOOLEAN;
isCaseSens :BOOLEAN);
def vs.ReplaceText(objectHd, oldText, newText, replaceAll, isCaseSens):
    return None

Parameters

objectHd HANDLE Handle to text object.
oldText STRING Old text string value.
newText STRING New text string value.
replaceAll BOOLEAN Flag whether to replace all oldTexts or first found text.
isCaseSens BOOLEAN Flag whether to be case sensitive.

Example

ReplaceText(hText,'Old text', 'New', TRUE, FALSE);

Version

Availability: from Vectorworks 2025