Worksheet Functions: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(One intermediate revision by the same user not shown)
Line 68: Line 68:
|  || valign="top" | One of several possible results based on a series of tests. The first value which passes the test is chosen.
|  || valign="top" | One of several possible results based on a series of tests. The first value which passes the test is chosen.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=ifs(A4>30, 'yes', A4<=30, 'no') returns 'yes' if the number in the cell A4 is >30. Else, if it is <=30 'no' is returned
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=IFS(A4>30, 'yes', A4<=30, 'no') returns 'yes' if the number in the cell A4 is >30. Else, if it is <=30 'no' is returned
=IFS(A4>30, 'yes', A4<30, 'no', TRUE, 'exact') returns 'exact' if the number in the cell A4 is exactly 30, 'yes' when >30, and 'no' when <30


If the final LogicN is ELSE then the final ValueN will be applied to all items that do not match a Logic earlier in the list.
=IFS(COND1; VALUE1; COND2; VALUE2; ELSE; 'ELSE') this example uses ELSE as a string condition, which evaluates to TRUE as it is non-empty string</pre>
Reported by Antonio Landsberger 11-6-23
</pre>
|-
|-
| colspan="3" | <big>Exact(value1, value2)</big>
| colspan="3" | <big>Exact(value1, value2)</big>
Line 127: Line 126:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=if(('Existing Tree'.'Condition'='Not Set'), '-', 'Existing Tree'.'Condition') If no condition value was set for the existing tree object, the value in this cell is a dash; otherwise, the value in this cell is the condition value that was set for the tree object.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=if(('Existing Tree'.'Condition'='Not Set'), '-', 'Existing Tree'.'Condition') If no condition value was set for the existing tree object, the value in this cell is a dash; otherwise, the value in this cell is the condition value that was set for the tree object.


=if(('Existing Tree'.'Condition'='Not Set'); '-'; 'Existing Tree'.'Condition')
=if(('Existing Tree'.'Condition'='Not Set'), '-', 'Existing Tree'.'Condition')
</pre>
</pre>
|}
|}
Line 162: Line 161:
2 |        |  tech    | tech@vectorworks.net
2 |        |  tech    | tech@vectorworks.net
3 |  tech  |  PR      | PR@vectorworks.net
3 |  tech  |  PR      | PR@vectorworks.net
</pre>
 
When [use_pattern] is missing or "false", the "value" will be matched exactly when looking up.
When [use_pattern] is "true" then the "value" is expected to be a regular expression that will be used when looking up.
Here is more information of the syntax of the regular rexpressions: https://cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
And here is a web-tool that can help developing and testing regular expressions: https://regexr.com/</pre>
|-
|-
| colspan="3" | <big>XLookup(value, [use_pattern], not_found_value, array_lookup, array_result)</big>
| colspan="3" | <big>XLookup(value, [use_pattern], not_found_value, array_lookup, array_result)</big>
Line 196: Line 199:
2 |  1235  | tech@vectorworks.net
2 |  1235  | tech@vectorworks.net
3 |  1236  | PR@vectorworks.net
3 |  1236  | PR@vectorworks.net
</pre>
 
When [use_pattern] is missing or "false", the "value" will be matched exactly when looking up.
When [use_pattern] is "true" then the "value" is expected to be a regular expression that will be used when looking up.
Here is more information of the syntax of the regular rexpressions: https://cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
And here is a web-tool that can help developing and testing regular expressions: https://regexr.com/</pre>
|}
|}


Line 487: Line 494:
|-
|-
|  || valign="top" | Returns the class description of the object's class.
|  || valign="top" | Returns the class description of the object's class.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Classification', classification_index, param_index)</big>
|-
|  || valign="top" | Returns the specified classification data from the object
Available options for classification_index:
1 - Primary Classification;
2 - Secondary Classification;
3 - Tertiary Classification;
Available options for param_index:
1 - Is classified;
2 - Standard Name;
3 - Classification Code;
4 - Classification Description;
5 - Classification System;
6 - Standard Source;
7 - Standard Edition;
8 - Standard Edition Date;
9 - Standard Location;
10 - Standard Description;
|-
|-
|  ||  
|  ||  
Line 492: Line 522:
| colspan="3" | <big>ObjectData('component', <value> [, <component index>])</big>
| colspan="3" | <big>ObjectData('component', <value> [, <component index>])</big>
|-
|-
|  || valign="top" | Returns the specified <value> about a component by index, or the core component if <component index> is missing. See the example for more details.
|  || valign="top" | When called on an object, the function returns the specified <value> of the object's component with the specified <component index>, or the core component if <component index> is missing. When called on a component, the function will return the specified <value> for that component. If the optional <component index> is added, the function will return the component value only for components that match the given index.
 
The following values are supported: "name", "function", "class", "class desc", "class description", "thickness", "lambda", "u-value", "net area", "net volume".
 
See the example for more details.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Available optiosn for <value>:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Available options for <value>:
- Name
- Name
- Function
- Function
Line 507: Line 541:
Examples:
Examples:
# return component name
# return component name
ObjectData('component', 'Name') # core compoent
ObjectData('component', 'Name') # core component
ObjectData('component', 'Name', 2) # component with index = 2
ObjectData('component', 'Name', 2) # component with index = 2
# return component Function value
# return component Function value
ObjectData('component', 'Function') # core compoent
ObjectData('component', 'Function') # core component
ObjectData('component', 'Function', 2) # component with index = 2
ObjectData('component', 'Function', 2) # component with index = 2
# return component class
# return component class
ObjectData('component', 'Class') # core compoent
ObjectData('component', 'Class') # core component
ObjectData('component', 'Class', 2) # component with index = 2
ObjectData('component', 'Class', 2) # component with index = 2
# return component class description
# return component class description
ObjectData('component', 'Class Desc') # core compoent
ObjectData('component', 'Class Desc') # core component
ObjectData('component', 'Class Desc', 2) # component with index = 2
ObjectData('component', 'Class Desc', 2) # component with index = 2
ObjectData('component', 'Class Description') # core compoent
ObjectData('component', 'Class Description') # core component
ObjectData('component', 'Class Description', 2) # component with index = 2
ObjectData('component', 'Class Description', 2) # component with index = 2
# return component thickness
# return component thickness
ObjectData('component', 'Thickness') # core compoent
ObjectData('component', 'Thickness') # core component
ObjectData('component', 'Thickness', 2) # component with index = 2
ObjectData('component', 'Thickness', 2) # component with index = 2
# return component lambda value
# return component lambda value
ObjectData('component', 'Lambda') # core compoent
ObjectData('component', 'Lambda') # core component
ObjectData('component', 'Lambda', 2) # component with index = 2
ObjectData('component', 'Lambda', 2) # component with index = 2
# return component U-value
# return component U-value
ObjectData('component', 'U-Value') # core compoent
ObjectData('component', 'U-Value') # core component
ObjectData('component', 'U-Value', 2) # component with index = 2
ObjectData('component', 'U-Value', 2) # component with index = 2
# return component net area
# return component net area
ObjectData('component', 'Net Area') # core compoent
ObjectData('component', 'Net Area') # core component
ObjectData('component', 'Net Area', 2) # component with index = 2
ObjectData('component', 'Net Area', 2) # component with index = 2
# return component net volume
# return component net volume
ObjectData('component', 'Net Volume') # core compoent
ObjectData('component', 'Net Volume') # core component
ObjectData('component', 'Net Volume', 2) # component with index = 2
ObjectData('component', 'Net Volume', 2) # component with index = 2
Line 588: Line 622:
|-
|-
|  || valign="top" | Returns the layer description of the object's layer.
|  || valign="top" | Returns the layer description of the object's layer.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('load info', paramSelector, [loadIndex])</big>
|-
|  || valign="top" | Get load info from a load object. ParamSelector can be - 'Position', 'Load ID', 'Load Name', 'Distributed Weight' and 'Total Weight'. If no loadIndex is specified the first load is used.
|-
|-
|  ||  
|  ||  
Line 659: Line 699:
When used with the COUNT function, the SEL (selection status) criterion counts objects that are actually non-selectable, such as the individual items within a group. The VSEL (visible selection status) criterion counts only the visibly selected items, which is the same counting method used for the Object Info palette. For example, if you select and count a group that has 11 items in it, the SEL criterion returns a value of 12 (the group, plus the 11 items). The VSEL criterion returns a value of 1 (the group only).
When used with the COUNT function, the SEL (selection status) criterion counts objects that are actually non-selectable, such as the individual items within a group. The VSEL (visible selection status) criterion counts only the visibly selected items, which is the same counting method used for the Object Info palette. For example, if you select and count a group that has 11 items in it, the SEL criterion returns a value of 12 (the group, plus the 11 items). The VSEL criterion returns a value of 1 (the group only).
</pre>
</pre>
|-
| colspan="3" | <big>Count('subparts', [subpart_name])</big>
|-
|  || valign="top" | Returns the number of subparts in a plug-in object. If subpart_name is provided, then only subparts with the given subpart name will be counted. If the given subpart name doesn't match the localized name of a subpart, then it will be treated as a universal name.
|-
|  ||
|-
|-
| colspan="3" | <big>Angle()</big>
| colspan="3" | <big>Angle()</big>
Line 896: Line 942:
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=Layer returns the layer of each object in the database
=Layer returns the layer name of each object in the database


Spreadsheet cell:
Spreadsheet cell:
Line 907: Line 953:
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=Class returns the class of each object in the database
=Class returns the class name of each object in the database


Spreadsheet cell:
Spreadsheet cell:
Line 937: Line 983:
| colspan="3" | <big>Story()</big>
| colspan="3" | <big>Story()</big>
|-
|-
|  || valign="top" | Returns the object's story.
|  || valign="top" | Returns the object's story name.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
Line 948: Line 994:
| colspan="3" | <big>ObjectTileFill()</big>
| colspan="3" | <big>ObjectTileFill()</big>
|-
|-
|  || valign="top" | Returns the object's tile fill.
|  || valign="top" | Returns the object's tile fill name.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=TileFill returns the tile fill for each object in the database
=TileFill returns the tile fill name for each object in the database


Spreadsheet cell:
Spreadsheet cell:
=TileFill(sel=true) returns the tile fill of the selected objects in the drawing
=TileFill(sel=true) returns the tile fill name of the selected objects in the drawing
</pre>
</pre>
|-
|-
| colspan="3" | <big>ObjectHatchFill()</big>
| colspan="3" | <big>ObjectHatchFill()</big>
|-
|-
|  || valign="top" | Returns the object's hatch fill.
|  || valign="top" | Returns the object's hatch fill name.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=HatchFill returns the hatch fill for each object in the database
=HatchFill returns the hatch fill name for each object in the database


Spreadsheet cell:
Spreadsheet cell:
=HatchFill(sel=true) returns the hatch fill of the selected objects in the drawing
=HatchFill(sel=true) returns the hatch fill name of the selected objects in the drawing
</pre>
</pre>
|-
|-
| colspan="3" | <big>ObjectGradientFill()</big>
| colspan="3" | <big>ObjectGradientFill()</big>
|-
|-
|  || valign="top" | Returns the object's gradient fill.
|  || valign="top" | Returns the object's gradient fill name.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=GradientFill returns the gradient fill for each object in the database
=GradientFill returns the gradient fill name for each object in the database


Spreadsheet cell:
Spreadsheet cell:
=GradientFill(sel=true) returns the gradient fill of the selected objects in the drawing
=GradientFill(sel=true) returns the gradient fill name of the selected objects in the drawing
</pre>
</pre>
|-
|-
Line 984: Line 1,030:
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=ObjectTexture returns the texture of each object in the database
=ObjectTexture returns the texture name of each object in the database


Spreadsheet cell:
Spreadsheet cell:
=ObjectTexture(sel=true) returns the texture of the selected objects in the drawing
=ObjectTexture(sel=true) returns the texture name of the selected objects in the drawing
</pre>
</pre>
|-
|-
Line 995: Line 1,041:
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=SketchStyle returns the sketch style for each object in the database
=SketchStyle returns the sketch style name for each object in the database


Spreadsheet cell:
Spreadsheet cell:
=SketchStyle(sel=true) returns the sketch style of the selected objects in the drawing
=SketchStyle(sel=true) returns the sketch style name of the selected objects in the drawing
</pre>
</pre>
|-
|-
| colspan="3" | <big>ObjectLineType()</big>
| colspan="3" | <big>ObjectLineType()</big>
|-
|-
|  || valign="top" | Returns the object's line type.
|  || valign="top" | Returns the object's line type name.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=LineType returns the line type for each object in the database
=LineType returns the line type name for each object in the database


Spreadsheet cell:
Spreadsheet cell:
=LineType(sel=true) returns the line type of the selected objects in the drawing
=LineType(sel=true) returns the line type name of the selected objects in the drawing
</pre>
</pre>
|-
|-
| colspan="3" | <big>ObjectImageFill()</big>
| colspan="3" | <big>ObjectImageFill()</big>
|-
|-
|  || valign="top" | Returns the object's image fill.
|  || valign="top" | Returns the object's image fill name.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=ImageFill returns the image fill for each object in the database
=ImageFill returns the image fill name for each object in the database


Spreadsheet cell:
Spreadsheet cell:
=ImageFill(sel=true) returns the image fill of the selected objects in the drawing
=ImageFill(sel=true) returns the image fill name of the selected objects in the drawing
</pre>
</pre>
|-
|-
Line 1,164: Line 1,210:
=IsFilled(T=WALL) returns the attribute fill state of the wall object if the criteria resolves to one object, otherwise returns the total number of walls in the drawing that are filled
=IsFilled(T=WALL) returns the attribute fill state of the wall object if the criteria resolves to one object, otherwise returns the total number of walls in the drawing that are filled


</pre>
|-
| colspan="3" | <big>ViewportStyleName()</big>
|-
|  || valign="top" | Returns the name of the viewport style used by the object.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=ViewportStyleName returns the viewport style name for each viewport object in the database
Spreadsheet cell:
=ViewportStyleName(n='viewport-1') returns the viewport style name for the object named “viewport-1”
</pre>
</pre>
|}
|}
Line 1,694: Line 1,751:
|-
|-
|  || valign="top" | Get parameter value or attached record field from the adapter's plug socket.
|  || valign="top" | Get parameter value or attached record field from the adapter's plug socket.
|-
|  ||
|}
== Specialized for Cable ==
{| border=0
| colspan="3" | <big>ObjectData('cable break', '<DataSelector>', [<Break Index>)]</big>
|-
| style="width: 10pt;" |  || valign="top" | Get cable break data. Data selectors - 'Name'. If the function is called on a cable break subpart there is no need to specify the break index. If the function is called on a cable object you have to specify the break index.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>ObjectData('cable section', '<DataSelector>', [<Section Index>)]</big>
|-
|  || valign="top" | Get cable section data. Data selectors - 'Name', 'Parts Ordered'. 'Parts Ordered' is read only. If the function is called on a cable section subpart there is no need to specify the section index. If the function is called on a cable object you have to specify the section index.
|-
|  ||
|-
| colspan="3" | <big>Length('cable section', '<DataSelector>', [<Section Index>)]</big>
|-
|  || valign="top" | Get cable section length. Data selectors - 'Length', 'Start Slack', 'End Slack', 'Swag', 'Total Vertical Drop'. 'Length' and 'Total Vertical Drop' are read only. If the function is called on a cable section subpart there is no need to specify the section index. If the function is called on a cable object you have to specify the section index.
|-
|-
|  ||  
|  ||  
Line 1,719: Line 1,798:
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('eval circuit route', ['<RecordName>]', '[<FieldName>]')</big>
| colspan="3" | <big>ObjectData('eval circuit drop points', ['<RecordName>'], ['<FieldName>'], ['ignoreEnds'])</big>
|-
|-
|  || valign="top" | Get path IDs, parameter values or attached record fields from the circuit's used cable paths. The drawing needs to be analyzed.
|  || valign="top" | List any intermediate drop point ID’s, parameter values or attached record fields through which a circuit passes. Add ignoreEnds to not list the drop points, located at the begging or at the end of the route. The drawing needs to be analyzed.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('eval circuit source adapter', '<RecordName>', '<FieldName>')</big>
| colspan="3" | <big>ObjectData('eval circuit route', ['<RecordName>'], ['<FieldName>'])</big>
|-
|  || valign="top" | Get path IDs, parameter values or attached record fields from the circuit's used cable paths. The drawing needs to be analyzed.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('eval circuit source adapter', '<RecordName>', '<FieldName>')</big>
|-
|-
|  || valign="top" | Get parameter value or attached record field from the circuit's source adapter.
|  || valign="top" | Get parameter value or attached record field from the circuit's source adapter.
Line 1,744: Line 1,829:
|}
|}


== Specialized for Curtain Wall ==
== Specialized for Countertop ==


{| border=0
{| border=0
| colspan="3" | <big>CurtWallFrameLength(classname)</big>
| colspan="3" | <big>Weight()</big>
|-
| style="width: 10pt;" |  || valign="top" | Returns the net weight of the Countertop or any Countertop subpart. To have a weight, a subpart must have a material with a set density.
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns the length of curtain wall frames in class 'classname'.
| style="width: 10pt;" |  ||  
|-
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| colspan="3" | <big>Weight('gross')</big>
=CurtWallFrameLength('') returns the combined length of the curtain wall frames for each curtain wall in the database
 
Spreadsheet cell:
=CurtWallFrameLength(t=wall, '') returns the combined length of the curtain wall frames for all curtain walls in the drawing
</pre>
|-
|-
| colspan="3" | <big>CurtWallPnlAreaGross(classname)</big>
| || valign="top" | Returns the gross weight of the Countertop or any Countertop subpart. To have a weight, a subpart must have a material with a set density.
|-
|-
|  || valign="top" | Returns the gross area of the curtain wall panels in class 'classname'.
|  ||  
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| colspan="3" | <big>Weight('net')</big>
=CurtWallPnlAreaGross('') returns the combined gross area of the curtain wall panels for each curtain wall in the database
 
Spreadsheet cell:
=CurtWallPnlAreaGross(t=wall, '') returns the combined gross area of the curtain wall panels for all curtain walls in the drawing
</pre>
|-
|-
| colspan="3" | <big>CurtWallPnlAreaNet(classname)</big>
| || valign="top" | Returns the gross weight of the Countertop or any Countertop subpart. To have a weight, a subpart must have a material with a set density.
|-
|-
|  || valign="top" | Returns the net area of the curtain walls panels in class 'classname'.
|  ||  
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| colspan="3" | <big>ObjectData('backsplash profile')</big>
=CurtWallPnlAreaNet ('Class-1') returns the combined net area of the curtain wall panels assigned to the class “Class-1” for each curtain wall in the database
 
Spreadsheet cell:
=CurtWallPnlAreaNet(t=wall, 'Class-1') returns the combined net area of the curtain wall panels assigned to the class “Class-1” for all curtain walls in the drawing
</pre>
|}
 
== Specialized for Device ==
 
{| border=0
| colspan="3" | <big>ObjectData('eval equipment item', '<RecordName>', '<FieldName>')</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Get parameter value or attached record field from the device's corresponding equipment item.
|  || valign="top" | Returns the name of the backsplash profile. Applicable to the countertop object and backsplash subpart.
|-
|-
| style="width: 10pt;" |  ||  
|  ||  
|}
 
== Specialized for Door ==
 
{| border=0
| colspan="3" | <big>Angle('energos')</big>
|-
|-
| style="width: 10pt;" | || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
| colspan="3" | <big>ObjectData('edge profile')</big>
|-
|-
| style="width: 10pt;" |  ||  
|  || valign="top" | Returns the name of the edge/trim profile. Applicable to the countertop object and profile and trim subparts.
|}
 
== Specialized for Door CW ==
 
{| border=0
| colspan="3" | <big>Angle('energos')</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|  ||  
|-
|-
| style="width: 10pt;" |  ||
| colspan="3" | <big>ObjectData('joint type')</big>
|}
 
== Specialized for Hardscape ==
 
{| border=0
| colspan="3" | <big>Depth()</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | Returns the joint type of waterfall edge subparts.
|-
|-
| style="width: 10pt;" |  ||  
|  ||  
|-
|-
| colspan="3" | <big>ProjectedArea()</big>
| colspan="3" | <big>ObjectData('style name')</big>
|-
|-
|  || valign="top" | Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | Returns the name of the plug-in style used by the countertop object.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('component name')</big>
| colspan="3" | <big>Thickness()</big>
|-
|-
|  || valign="top" | Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
|  || valign="top" | Returns the thickness of the countertop surface, trim, backsplashes or waterfall edges. For the countertop object, this function will return the thickness of the countertop surface.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Area()</big>
| colspan="3" | <big>Width('bounding box')</big>
|-
|-
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | Returns the width of the bounding box of the countertop object or countertop surface.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>SurfaceArea()</big>
| colspan="3" | <big>Height()</big>
|-
|-
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | Returns the Z-height of trim and backsplashes.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Volume()</big>
| colspan="3" | <big>Height('bounding box')</big>
|-
|-
|  || valign="top" | Calculate the volume of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | Returns the height of the bounding box of the countertop object or countertop surface.
|-
|-
|  ||  
|  ||  
|}
== Specialized for Hedgerow ==
{| border=0
| colspan="3" | <big>ObjectData('percentage')</big>
|-
|-
| style="width: 10pt;" | || valign="top" | Return the percentage value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
| colspan="3" | <big>Count('cutouts')</big>
|-
|-
| style="width: 10pt;" | ||
| || valign="top" | Returns the number of cutouts in the countertop object or countertop surface. Both 2D and 3D cutouts are included.
|-
|-
| colspan="3" | <big>ObjectData('Plant Record', <field>)</big>
| ||  
|-
|-
|  || valign="top" | Provides access to the Plant Record data of the Landscape Area Plant subparts for edit if the style allows.
| colspan="3" | <big>Area()</big>
|-
|  || valign="top" | Returns the area of the outer faces of waterfall edges.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('rate')</big>
| colspan="3" | <big>Area('bounding box')</big>
|-
|-
|  || valign="top" | Return the rate value value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|  || valign="top" | Returns the area of the bounding box of the countertop object or countertop surface.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('rate unit')</big>
| colspan="3" | <big>Area('cutouts')</big>
|-
|-
|  || valign="top" | Return the rate unit string of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|  || valign="top" | Returns the total area of cutouts in the countertop. All 2D and 3D cutouts are taken into account. The function is only applicable to the countertop object and the countertop surface subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('rate with unit')</big>
| colspan="3" | <big>Area('gross')</big>
|-
|-
|  || valign="top" | Return the rate value and unit of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|  || valign="top" | Returns the gross area of the countertop. No cutouts are taken into account. The function is only applicable to the countertop object and the countertop surface subpart.
|-
|-
|  ||  
|  ||  
|}
== Specialized for Landscape Area ==
{| border=0
| colspan="3" | <big>Depth()</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
| colspan="3" | <big>Area('net')</big>
|-
|  || valign="top" | Returns the net area of the countertop. All 2D and 3D cutouts are taken into account. The function is only applicable to the countertop object and the countertop surface subpart.
|-
|-
| style="width: 10pt;" |  ||  
|  ||  
|-
|-
| colspan="3" | <big>ProjectedArea()</big>
| colspan="3" | <big>Perim()</big>
|-
|-
|  || valign="top" | Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | Returns the perimeter of the countertop object or countertop surface. The countertop overhangs will be included in the perimeter.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('component name')</big>
| colspan="3" | <big>Length()</big>
|-
|-
|  || valign="top" | Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
|  || valign="top" | Returns the length of edge profiles, trim, backsplashes or waterfall edges. The length is measured along the outer edge of the subart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('divider')</big>
| colspan="3" | <big>Volume()</big>
|-
|-
|  || valign="top" | Return the divider string or empty of this divider from a Landscape Area. This must be used on a database row listing the dividers/plants of Landscape Areas.
|  || valign="top" | Returns the net volume of the Countertop or any Countertop subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Landscape Area', <field>)</big>
| colspan="3" | <big>Volume('gross')</big>
|-
|-
|  || valign="top" | Provides access to the Landscape Area data field for edit if the style allows.
|  || valign="top" | Returns the gross volume of the Countertop or any Countertop subpart. Cutouts and edge profiles are ignored.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('percentage')</big>
| colspan="3" | <big>Volume('net')</big>
|-
|-
|  || valign="top" | Return the percentage value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|  || valign="top" | Returns the net volume of the Countertop or any Countertop subpart.
|-
|-
|  ||  
|  ||  
|}
== Specialized for Curb ==
{| border=0
| colspan="3" | <big>FootPrintArea()</big>
|-
| style="width: 10pt;" |  || valign="top" | Calculate the footprint area of the Curb object and its subparts.
|-
| style="width: 10pt;" |  ||
|-
|-
| colspan="3" | <big>ObjectData('Plant Record', <field>)</big>
| colspan="3" | <big>SpecialArea()</big>
|-
|-
|  || valign="top" | Provides access to the Plant Record data of the Landscape Area Plant subparts for edit if the style allows.
|  || valign="top" | Calculate the Extrude profile area for Curb Extrude subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('rate')</big>
| colspan="3" | <big>ObjectData('name')</big>
|-
|-
|  || valign="top" | Return the rate value value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|  || valign="top" | Return the name of the subpart symbol for Curbs.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('rate unit')</big>
| colspan="3" | <big>Width()</big>
|-
|-
|  || valign="top" | Return the rate unit string of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|  || valign="top" | Returns the width of the bounding box for Curb and its subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('rate with unit')</big>
| colspan="3" | <big>Height()</big>
|-
|-
|  || valign="top" | Return the rate value and unit of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|  || valign="top" | Returns the height of the bounding box for Curb and its subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Area()</big>
| colspan="3" | <big>Length()</big>
|-
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|  ||
|-
|-
| colspan="3" | <big>SurfaceArea()</big>
|  || valign="top" | Returns the length of the Curb insertion line
|-
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|-
|  ||  
|  ||  
Line 1,962: Line 2,006:
| colspan="3" | <big>Volume()</big>
| colspan="3" | <big>Volume()</big>
|-
|-
|  || valign="top" | Calculate the volume of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | Calculate the volume of the Curb, Landscape Area, Hardscape, or Site Model and their components.
|-
|-
|  ||  
|  ||  
|}
|}


== Specialized for Lighting Device ==
== Specialized for Curtain Wall ==


{| border=0
{| border=0
| colspan="3" | <big>Weight(criteria)</big>
| colspan="3" | <big>CurtWallFrameLength(classname)</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns the total weight of the Lighting Device and all it's accessories.
| style="width: 10pt;" |  || valign="top" | Returns the length of curtain wall frames in class 'classname'.
|-
|-
| style="width: 10pt;" |  ||  
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=CurtWallFrameLength('') returns the combined length of the curtain wall frames for each curtain wall in the database
 
Spreadsheet cell:
=CurtWallFrameLength(t=wall, '') returns the combined length of the curtain wall frames for all curtain walls in the drawing
</pre>
|-
|-
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
| colspan="3" | <big>CurtWallPnlAreaGross(classname)</big>
|-
|-
|  || valign="top" | Provides access to the Instrument Type of Lighting Device accessories. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
|  || valign="top" | Returns the gross area of the curtain wall panels in class 'classname'.
|-
|-
|  ||  
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=CurtWallPnlAreaGross('') returns the combined gross area of the curtain wall panels for each curtain wall in the database
 
Spreadsheet cell:
=CurtWallPnlAreaGross(t=wall, '') returns the combined gross area of the curtain wall panels for all curtain walls in the drawing
</pre>
|-
|-
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
| colspan="3" | <big>CurtWallPnlAreaNet(classname)</big>
|-
|-
|  || valign="top" | Provides access to a data of the Lighting Device accessory. Use  the first parameter to specify the universal parameter name. Use no parameters additional for all cells and accessories or use additional parameters to specify cells or accessories.
|  || valign="top" | Returns the net area of the curtain walls panels in class 'classname'.
|-
|-
|  ||  
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|-
=CurtWallPnlAreaNet ('Class-1') returns the combined net area of the curtain wall panels assigned to the class “Class-1” for each curtain wall in the database
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
 
|-
Spreadsheet cell:
|  || valign="top" | Provides access to the symbol names of Lighting Device accessories. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
=CurtWallPnlAreaNet(t=wall, 'Class-1') returns the combined net area of the curtain wall panels assigned to the class “Class-1” for all curtain walls in the drawing
</pre>
|}
 
== Specialized for Device ==
 
{| border=0
| colspan="3" | <big>ObjectData('eval equipment item', '<RecordName>', '<FieldName>')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get parameter value or attached record field from the device's corresponding equipment item.
|-
|-
|  ||  
| style="width: 10pt;" |  ||  
|}
 
== Specialized for Distributor Object ==
 
{| border=0
| colspan="3" | <big>ObjectData('eval schematic device', '<RecordName>', '<FieldName>')</big>
|-
|-
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
| style="width: 10pt;" | || valign="top" | Get parameter value or attached record field from the objects's schematic device.
|-
|-
|  || valign="top" | Provides access to a parameter of the Lighting Devices and ignores accessories. Use parameters to specify the universal parameter name.
| style="width: 10pt;" |  ||
|}
 
== Specialized for Door ==
 
{| border=0
| colspan="3" | <big>Angle('energos')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|-
|-
|  ||  
| style="width: 10pt;" |  ||  
|-
|-
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
| colspan="3" | <big>Volume(criteria, 'door jamb')</big>
|-
|-
|  || valign="top" | Provides access to the channel of Lighting Devices. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
|  || valign="top" | Returns the volume the jamb.
|-
|-
|  ||  
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('door jamb')    Returns the volume the jamb.
 
Spreadsheet cell:
=VOLUME(SEL, 'door jamb')    Returns the volume the jamb.
</pre>
|-
|-
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
| colspan="3" | <big>Volume(criteria, 'door sashes')</big>
|-
|-
|  || valign="top" | Provides access to the color of Lighting Devices. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
|  || valign="top" | Returns the total volume all sashes (including sidelight and transom sashes).
|-
|-
|  ||  
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('door sashes')    Returns the total volume all sashes (including sidelight and transom sashes).
 
Spreadsheet cell:
=VOLUME(SEL, 'door sashes')    Returns the total volume all sashes (including sidelight and transom sashes).
</pre>
|-
|-
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
| colspan="3" | <big>Volume(criteria, 'glazing all')</big>
|-
|-
|  || valign="top" | Provides access to a parameter of Lighting Devices. Use parameters to specify the universal parameter name, cell number and accessory number.
|  || valign="top" | Returns the total volume of all glazing.
|-
|-
|  ||  
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|}
=VOLUME('glazing all')    Returns the total volume of all glazing.


== Specialized for Plant ==
Spreadsheet cell:
=VOLUME(SEL, 'glazing all')    Returns the total volume of all glazing.
</pre>
|-
| colspan="3" | <big>Volume(criteria, 'glazing for leaves')</big>
|-
|  || valign="top" | Returns the volume of glazing for all leaves (including vision panels).
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('glazing for leaves')    Returns the volume of glazing for all leaves (including vision panels).


{| border=0
Spreadsheet cell:
| colspan="3" | <big>PlantImage(index)</big>
=VOLUME(SEL, 'glazing for leaves')    Returns the volume of glazing for all leaves (including vision panels).
</pre>
|-
| colspan="3" | <big>Volume(criteria, 'glazing for sidelights')</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns an image of the object at the specified index.
|  || valign="top" | Returns the volume of glazing for all sidelights.
|-
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=PlantImage(2) displays the image specified for Image Detail in the More Data pane of the plant symbol definition
=VOLUME('glazing for sidelights')     Returns the volume of glazing for all sidelights.


Spreadsheet cell:
Spreadsheet cell:
=PlantImage((‘Plant’.’plant ID’=’TaxfR’), 4) displays the image specified for Custom Image in the More Data pane of the plant symbol definition with a plant ID of TaxfR
=VOLUME(SEL, 'glazing for sidelights')   Returns the volume of glazing for all sidelights.
</pre>
</pre>
|}
|-
| colspan="3" | <big>Volume(criteria, 'glazing for transom')</big>
|-
|  || valign="top" | Returns the volume of glazing for the transom.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('glazing for transom')    Returns the volume of glazing for the transom.


== Specialized for Railing/Fence ==
Spreadsheet cell:
=VOLUME(SEL, 'glazing for transom')    Returns the volume of glazing for the transom.
</pre>
|-
| colspan="3" | <big>Volume(criteria, 'leaf panels')</big>
|-
|  || valign="top" | Returns the total volume of the leaf panels.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('leaf panels')    Returns the total volume of the leaf panels.


{| border=0
Spreadsheet cell:
| colspan="3" | <big>Width()</big>
=VOLUME(SEL, 'leaf panels')    Returns the total volume of the leaf panels.
</pre>
|-
| colspan="3" | <big>Volume(criteria, 'leaf stiles and rails')</big>
|-
|  || valign="top" | Returns the total volume of the leaf rails, and stiles.
|-
|-
| style="width: 10pt;" |  || valign="top" | Width([optional parameter])
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('leaf stiles and rails')     Returns the total volume of the leaf rails and stiles.


This function is applicable to the following subparts: Wall Bracket, Face Mount, Frame and Panel.
Spreadsheet cell:
=VOLUME(SEL, 'leaf stiles and rails')    Returns the total volume of the leaf rails and stiles.
</pre>
|}


OPTIONAL PARAMETER:
== Specialized for Door CW ==
'subpart=...': If provided, only the given subpart is included.


QUANTITY DESCRIPTION:
{| border=0
For Wall Bracket: Horizontal dimension of the Top Rails Wall Bracket.
| colspan="3" | <big>Angle('energos')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|-
| style="width: 10pt;" |  ||
|}


For Face Mount: Horizontal dimension of the Face Mount Post.
== Specialized for Fence ==


For Frame: Width of the rectangular frame.
{| border=0
 
| colspan="3" | <big>Depth('Gravel Board')</big>
For Panel: Width of the panel in elevation.
|-
| style="width: 10pt;" |  || valign="top" | The function is applicable to Fence object and Gravel Board subpart.
Returns the depth of the gravel board, if active.
|-
|-
| style="width: 10pt;" |  ||  
| style="width: 10pt;" |  ||  
|-
|-
| colspan="3" | <big>Width('profile')</big>
| colspan="3" | <big>Depth('Horizontal Boards')</big>
|-
|  || valign="top" | The function is applicable to Fence object and Infill subpart.
Returns the profile thickness. If the fence has different Infill Type, returns N/A.
|-
|  ||
|-
| colspan="3" | <big>Depth('Panels')</big>
|-
|  || valign="top" | The function is applicable to Fence object and Infill subpart.
Returns the profile depth. If the fence has different Infill Type, returns N/A.
|-
|  ||
|-
| colspan="3" | <big>Depth('Rail', <Index>)</big>
|-
|-
|  || valign="top" | Width('profile', [optional parameter])
|  || valign="top" | The function is applicable to:


This function is applicable to the following subparts: Top Rail, Post, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame.
Fence object: returns the depth of the selected rail.


OPTIONAL PARAMETER:
Rail subpart: returns the depth of the rail. If the rail doesn't correspond to the selected index, returns N/A.
'subpart=...': If provided, only the given subpart is included.
|-
|  ||
|-
| colspan="3" | <big>Depth('Rails')</big>
|-
|  || valign="top" | The function is applicable to rail subparts: returns the depth of the rail.
|-
|  ||
|-
| colspan="3" | <big>Depth('Vertical Boards')</big>
|-
|  || valign="top" | The function is applicable to Fence object and Infill subpart.
Returns the profile width. If the fence has different Infill Type, returns N/A.
|-
|  ||
|-
| colspan="3" | <big>FootPrintArea('Corner Footers')</big>
|-
|  || valign="top" | The function is applicable to:


QUANTITY DESCRIPTION:
Fence object: returns the total footprint area of all footers.
For Top Rail: Width of the Railings TopRail cross section profile. For round or octagonal shape of profile, width equals height. For custom profile (symbol), the bounding box is used to calculate this value.


For Post: Width of the Posts cross section profile.
Footer subpart: returns the footprint area of the footer. If the footer is not corner, returns N/A.
 
For Crossbar Top and Crossbar Bottom: Width of the profile of the crossbar.
 
For Bar Vertical and Bar Horizontal: Width of the vertical bars profile.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Height()</big>
| colspan="3" | <big>FootPrintArea('Footers')</big>
|-
|-
|  || valign="top" | Height([optional parameter])
|  || valign="top" | The function is applicable to:


This function is applicable to the Railing object and the following subparts: Top Rail, Wall Bracket, Post, Face Mount, Frame, Panel.
Fence object: returns the total footprint area of all footers.


OPTIONAL PARAMETER:
Footer subpart: returns the footprint area of the footer.
'subpart=...': If provided, only the given subpart is included.
|-
|  ||
|-
| colspan="3" | <big>FootPrintArea('Gate Footers')</big>
|-
|  || valign="top" | The function is applicable to:


QUANTITY DESCRIPTION:
Fence object: returns the total footprint area of all footers.
For Railing object: The height of the railing, measured as the vertical distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the highest subpart of the Railing (Top Rail if available, Frame, Panel or Crossbar Top).
This value is written into the IFC-field Pset_RailingCommon.Height.


For Top Rail: Height of the TopRail, measured as the distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the Railings Top Rail.
Footer subpart: returns the footprint area of the footer. If the footer is not gate, returns N/A.
|-
|  ||
|-
| colspan="3" | <big>FootPrintArea('Running Footers')</big>
|-
|  || valign="top" | The function is applicable to:


For Wall Bracket: Vertical dimension of the Top Rails Wall Bracket.
Fence object: returns the total footprint area of all footers.


For Post: Height of the Post.
Footer subpart: returns the footprint area of the footer. If the footer is not running, returns N/A.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Footer Type')</big>
|-
|  || valign="top" | The function is applicable to Footer subpart only.


For Face Mount: Vertical dimension of the Face Mount Post.
Returns the type of the footer. It can be 'Corner Footer', 'Running Footer' or 'Gate Footer'.
 
For Frame: Height of the rectangular frame.
 
For Panel: Height of the panel in elevation.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Height('profile')</big>
| colspan="3" | <big>ObjectData('Infill Type')</big>
|-
|-
|  || valign="top" | Height('profile', [optional parameter])
|  || valign="top" | The function is applicable to Infill subpart only.
 
This function is applicable to the following subparts: Top Rail, Post, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Top Rail: Height of the Railings TopRail cross section profile. For round or octagonal shape of profile, width equals height. For custom profile (symbol), the bounding box is used to calculate this value.


For Post: Height of the Posts cross section profile.
Returns the type of the infill. It can be 'Preconstructed Panel', 'Vertical Board' or 'Horizontal Board'.
 
For Crossbar Top and Crossbar Bottom: Height of the profile of the crossbar.
 
For Bar Vertical and Bar Horizontal: Height of the vertical bars profile.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Count('angle')</big>
| colspan="3" | <big>ObjectData('Name')</big>
|-
|-
|  || valign="top" | Count('angle', [optional parameter])
|  || valign="top" | The function is applicable to all Fence subparts: Post, Gate, Infill, and Rail.


This function is applicable to the Railing object and the Top Rail.
Returns the name of the used symbol definition.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Post Type')</big>
|-
|  || valign="top" | The function is applicable to Post subpart only.


OPTIONAL PARAMETER:
Returns the type of the post. It can be 'Corner Post', 'Running Post' or 'Gate Post'.
'subpart=...': If provided, only the given subpart is included.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Rail Index')</big>
|-
|  || valign="top" | The function is applicable to Rail subpart only.


QUANTITY DESCRIPTION:
Returns the index of the rail type, starting from index 1.
For Railing: Number of vertices that change the path without the beginning and end. Or IOW: the number of angles in the path..
|-
 
|  ||
For Top Rail: Number of angles in the Top Rail subpart.
|-
| colspan="3" | <big>Width('Horizontal Boards')</big>
|-
| || valign="top" | The function is applicable to Fence object and Infill subpart.
Returns the profile width. If the fence has different Infill Type, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Angle()</big>
| colspan="3" | <big>Width('Vertical Boards')</big>
|-
|-
|  || valign="top" | Angle([optional parameter])
|  || valign="top" | The function is applicable to Fence object and Infill subpart.
 
Returns the profile thickness. If the fence has different Infill Type, returns N/A.
This function is applicable to the following subparts: Bar Vertical and Bar Horizontal.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Bar Vertical: Angle of the vertical bars. Vertical is 0°.
 
For Bar Horizontal: Angle of the horizontal bar. horizontal is 0°.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Area()</big>
| colspan="3" | <big>Height('Corner Footers')</big>
|-
|-
|  || valign="top" | Area([optional parameter])
|  || valign="top" | The function is applicable to:
 
This function is applicable to the Railing object and the Panel subpart.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.


QUANTITY DESCRIPTION:
Fence object: returns the sum of all corner footers.
For Railing: Area of the Railing object measured by Railing Length multiplied by Railing Height. Length is the distance between the outer edges of the first and last post or between the infills, whichever results in the higher value. Extended handrails are excluded. This Length differs from buildingSMART standard which is stored in the Railing objects record field RailingLengthIFC. The height of the railing is measured as the vertical distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the highest subpart of the Railing (Top Rail if available, Frame, Panel or Crossbar Top).


For Panel: Area of the panel (Width x Height).
Footer subpart: returns the height of the footer, which is equal to the (depth below grade + drainage layer) of the related footer type. If the footer type is not corner, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Perimeter()</big>
| colspan="3" | <big>Height('Corner Posts')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is identical to Length('Corner Posts').
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('')</big>
| colspan="3" | <big>Height('Fabric')</big>
|-
|-
|  || valign="top" | Length([optional parameter])
|  || valign="top" | The function is applicable to:


This function is applicable to the Railing object and the following subparts: Top Rail, Crossbar Top, Crossbar Bottom, Bar Vertical, Bar Horizontal, Frame.
Fence object: returns the height of the fabric subpart ( if there are more than 1, returns the height of the first ).


OPTIONAL PARAMETER:
Rail subpart: returns height only if the rail is of type fabric.
'subpart=...': If provided, only the given subpart is included.
|-
|  ||
|-
| colspan="3" | <big>Height('Footers')</big>
|-
|  || valign="top" | The function is applicable to:


QUANTITY DESCRIPTION:
Fence object: returns the sum of all footers.
For Railing object: It is the distance between the outer edges of the first and last post or between the infills, whichever results in the higher value. Extended handrails are excluded. This Length differs from buildingSMART standard which is stored in the Railing objects record field RailingLengthIFC and written into Qto_RailingBaseQuantities.Length and BaseQuantities.Length.


For Top Rail: Length of the 3D path object of the top rail including extensions of the Top Rail at beginning or end of the Railing object.
Footer subpart: returns the height of the footer, which is equal to the (depth below grade + drainage layer) of the related footer type.
 
|-
For Crossbar Top and Bottom: Length of the crossbar.
|  ||
|-
| colspan="3" | <big>Height('Gate Footers')</big>
|-
|  || valign="top" | The function is applicable to:


For Bar Vertical and Horizontal: Length of the bar.
Fence object: returns the sum of all gate footers.


For Frame: It is the same value as for Width when applied to a Frame.
Footer subpart: returns the height of the footer, which is equal to the (depth below grade + drainage layer) of the related footer. If the footer type is not gate, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('max')</big>
| colspan="3" | <big>Height('Gate Posts')</big>
|-
|-
|  || valign="top" | Maximum occuring distance between the axes of all instances of a subparts.
|  || valign="top" | The function is identical to Length('Gate Posts').
Eligible subparts are Wall Bracket, Post and Face Mount.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Wall Bracket: Returns the maximum distance between the axes of all Wall Brackets occuring anywhere in the Railing object.
 
For Post: Maximum occuring distance between the axes of all posts.
 
For Face Mount: Maximum Distance between the axes of all Face Mounts.  
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>SurfaceArea()</big>
| colspan="3" | <big>Height('Gates')</big>
|-
|  || valign="top" | The function is applicable to Gate subpart only. Returns the height of the gate.
|-
|  ||
|-
|-
|  || valign="top" | SurfaceArea([optional parameter])
| colspan="3" | <big>Height('Gravel Board')</big>
 
|-
This function is applicable to the following subparts: Top Rail, Wall Bracket, Post, Face Mount, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame, Panel.
|  || valign="top" | The function is applicable to Fence object and Gravel Board subpart.
 
Returns the height of the gravel board, if active.
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Top Rail: Outer surface of the top rail on all sides including the two caps at beginning and end.
 
For Wall Bracket: Complete outer surface of the Top Rails Wall Bracket.
 
For Post: Complete Outer Surface of the Post including the sides which face the stair or wall or handrail.
 
For Face Mount: Complete Outer Surface of the Face Mount Post including the caps surfaces which are mounted against a wall, post, stair or other object.
 
For Crossbar Top and Bottom: Complete Surface of all sides of the crossbar.
 
Bar Vertical and Horizontal: Complete Surface of all sides of the bar.
 
For Frame: Complete Surface of the rectangular frame.
 
For Panel: Complete surface area of all sides of the panel.
|-
|-
|  ||  
|  ||  
|}
== Specialized for Roof ==
{| border=0
| colspan="3" | <big>ObjectData('Component Name')</big>
|-
|-
| style="width: 10pt;" | || valign="top" | Returns the name of the wall, slab or roof component.
| colspan="3" | <big>Height('Panels')</big>
|-
|-
| style="width: 10pt;" |  ||
|  || valign="top" | The function is applicable to Fence object and Infill subpart.
|-
Returns the panel height. If the fence has different Infill type, returns N/A.
| colspan="3" | <big>ObjectData('Cost Index Code')</big>
|-
|  || valign="top" |  
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Cost Index System')</big>
| colspan="3" | <big>Height('Posts')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is identical to Length('Posts').
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Description')</big>
| colspan="3" | <big>Height('Rail', <Index>)</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the height of the <Index> rail.
 
Rail subpart: returns the height of the rail. If the rail doesn't correspond to the selected index, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Exterior')</big>
| colspan="3" | <big>Height('Rails')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Rail subpart: returns the height of the rail.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Fire Rating')</big>
| colspan="3" | <big>Height('Running Footers')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the sum of all running footers.
 
Footer subpart: returns the height of the footer, which is equal to the (depth below grade + drainage layer) of the related footer type. If the footer type is not running, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Function')</big>
| colspan="3" | <big>Height('Running Posts')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is identical to Length('Running Posts').
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Lambda')</big>
| colspan="3" | <big>Height('Top Line Above Grade')</big>
|-
|-
|  || valign="top" | Returns the Lambda value of the object.
|  || valign="top" | The function is applicable to the Fence object.
 
If the 'Infill Type' is 'Rails Only': returns the highest top elevation of all rails.
 
Otherwise: returns the 'Top Line Above Grade' field.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Manufacturer')</big>
| colspan="3" | <big>Count('Corner Footers')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the count of all corner footers.
 
Footer subpart: returns 1 for any corner footer. If the footer is not corner, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Mark')</big>
| colspan="3" | <big>Count('Corner Posts')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the total count of corner posts.
 
Post subpart: returns 1 for any corner post.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Model')</big>
| colspan="3" | <big>Count('Fabric')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the count of all rails that are treated as fabric.
 
Rail subpart: returns 1 if the rail is fabric.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('RValue')</big>
| colspan="3" | <big>Count('Footers')</big>
|-
|-
|  || valign="top" | Returns the R-Value of the object.
|  || valign="top" | The function is applicable to:
 
Fence object: returns the count of all footers.
 
Footer subpart: returns 1 for any type of footer.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('UValue')</big>
| colspan="3" | <big>Count('Gate Footers')</big>
|-
|-
|  || valign="top" | Returns the U-Value of the object.
|  || valign="top" | The function is applicable to:
 
Fence object: returns the count of all gate footers.
 
Footer subpart: returns 1 for any gate footer. If footer is not gate, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>RoofArea_Total()</big>
| colspan="3" | <big>Count('Gate Posts')</big>
|-
|-
|  || valign="top" | Returns the total area along the slope of a roof.
|  || valign="top" | The function is applicable to:
|-
 
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
Fence object: returns the total count of gate posts.
=RoofArea_Total returns the total area for each roof and roof face object in the database


Spreadsheet cell:
Post subpart: returns 1 for any gate post.
=RoofArea_Total(st=roofface) returns the combined total area of all roof face objects in the drawing</pre>
|-
|-
| colspan="3" | <big>RoofArea_Heated()</big>
| ||  
|-
|-
| || valign="top" | Returns the heated area along the slope of a roof.
| colspan="3" | <big>Count('Gates')</big>
The heated area is the area that does not include an overhang.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | The function is applicable to:
=RoofArea_Heated returns the heated area for each roof and roof face object in the database
 
Fence object: returns the number of gates in the fence object.


Spreadsheet cell:
Gate subpart: returns 1 for any gate.
=RoofArea_Heated (st=roofface) returns the combined heated area of all roof face objects in the drawing
</pre>
|-
|-
| colspan="3" | <big>RoofArea_TotalProj()</big>
| ||  
|-
|-
| || valign="top" | Returns the total area of a roof projected on the active layer plane.
| colspan="3" | <big>Count('Gravel Board')</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | The function is applicable to:
=RoofArea_TotalProj returns the total area for each roof and roof face object in the database, as projected to the layer plane
 
Fence object: returns number of gravel boards if the option is active.


Spreadsheet cell:
Gravel Board subpart: returns 1.
=RoofArea_Totalproj(t=roof) returns the combined total area of all roof objects in the drawing, as projected to the layer plane
|-
</pre>
|  ||
|-
|-
| colspan="3" | <big>RoofArea_HeatedProj()</big>
| colspan="3" | <big>Count('Horizontal Boards')</big>
|-
|-
|  || valign="top" | Returns the heated area of a roof projected on the active layer plane.
|  || valign="top" | The function is applicable to:
The heated area is the area that does not include an overhang.
 
|-
Fence object: returns the number of horizontal boards in the object.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=RoofArea_HeatedProj returns the heated area for each roof and roof face object in the database, as projected to the layer plane


Spreadsheet cell:
Infill subpart: returns 1 for any horizontal board infill. If the fence has different Infill Type, returns N/A.
=RoofArea_HeatedProj (t=roof) returns the combined heated area of all roof objects in the drawing, as projected to the layer plane
</pre>
|-
|-
| colspan="3" | <big>RoofStyleName()</big>
| ||  
|-
|-
| || valign="top" | Returns the name the roof style used by the object.
| colspan="3" | <big>Count('Panels')</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | The function is applicable to:
=RoofStyleName returns the roof style name for each roof object in the database


Spreadsheet cell:
Fence object: returns the number of panels in the object.
=RoofStyleName(n='roof-1') returns the roof style name for the object named “roof-1”
</pre>
|}


== Specialized for Site Model ==
Infill subpart: returns 1 for any panel infill. If the fence has different Infill Type, returns N/A.
 
{| border=0
| colspan="3" | <big>Depth()</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
|  ||  
|-
|-
| style="width: 10pt;" | ||
| colspan="3" | <big>Count('Posts')</big>
|-
|-
| colspan="3" | <big>ProjectedArea()</big>
|  || valign="top" | The function is applicable to:
|-
 
|  || valign="top" | Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
Fence object: returns the total count of posts.
 
Post subpart: returns 1 for any type of post.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('component name')</big>
| colspan="3" | <big>Count('Rail', <Index>)</big>
|-
|-
|  || valign="top" | Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
|  || valign="top" | The function is applicable to:
 
Fence object: returns 1 if <Index> is valid one or 0 if it is out of bounds.
 
Rail subpart: returns 1 if the rail corresponds to the selected index. Otherwise, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Area()</big>
| colspan="3" | <big>Count('Rails')</big>
|-
|-
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | The function is applicable to:
 
Fence object: returns the count of all rail settings.
 
Rail subpart: returns 1 for any rail.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>SurfaceArea()</big>
| colspan="3" | <big>Count('Running Footers')</big>
|-
|-
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | The function is applicable to:
 
Fence object: returns the count of all running footers.
 
Footer subpart: returns 1 for any running footer. If the footer is not running, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>SurfaceArea( 'existing' )</big>
| colspan="3" | <big>Count('Running Posts')</big>
|-
|  || valign="top" | The function is applicable to:
 
Fence object: returns the total count of running posts.
 
Post subpart: returns 1 for any running post.
|-
|  ||
|-
|-
| || valign="top" | Calculate the existing surface area of the Site Model and their components.
| colspan="3" | <big>Count('Vertical Boards')</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | The function is applicable to:
=SURFACEAREA('Existing')    Returns the existing Surface Area for Site Model object or component in the DB row.
 
Fence object: returns the number of vertical boards in the object.


Spreadsheet cell:
Infill subpart: returns 1 for any vertical board infill. If the fence has different Infill Type, returns N/A.
=SURFACEAREA(SEL; 'Existing')    Returns the existing Surface Area for the selected Site Model object.
</pre>
|-
|-
| colspan="3" | <big>SurfaceArea( 'proposed' )</big>
| ||  
|-
|-
| || valign="top" | Calculate the proposed surface area of the Site Model and their components.
| colspan="3" | <big>Length('2D')</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | The function is applicable to the Fence object.
=SURFACEAREA('Proposed')    Returns the proposed Surface Area for Site Model object or component in the DB row.


Spreadsheet cell:
Returns the 2D length of the offset object path.
=SURFACEAREA(SEL; 'Proposed')    Returns the proposed Surface Area for the selected Site Model object.
|-
</pre>
|  ||
|-
|-
| colspan="3" | <big>Volume()</big>
| colspan="3" | <big>Length('3D')</big>
|-
|-
|  || valign="top" | Calculate the volume of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | The function is applicable to the Fence object.
 
Returns the 3D length of the offset object path.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Volume('existing')</big>
| colspan="3" | <big>Length('Corner Posts')</big>
|-
|  || valign="top" | Calculate the existing volume of the Site Model and their components.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | The function is applicable to:
=VOLUME('existing')    Returns the existing volume for Site Model object or component in the DB row.
 
Fence object: returns the sum of all post length.


Spreadsheet cell:
Post subpart: returns the length of the post, counted from top to bottom of depth below grade. If the post is not corner, returns N/A.
=VOLUME(SEL, 'existing')    Returns the existing volume for the selected Site Model object.
</pre>
|-
|-
| colspan="3" | <big>Volume('proposed')</big>
| ||  
|-
|-
| || valign="top" | Calculate the proposed volume of the Site Model and their components.
| colspan="3" | <big>Length('Fabric')</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | The function is applicable to:
=VOLUME('proposed')    Returns the proposed volume for Site Model object or component in the DB row.


Spreadsheet cell:
Fence object: return the total length of all fabric rails with equal index. If there are multiple fabric rails, selects the first one.
=VOLUME(SEL, 'proposed')    Returns the proposed volume for the selected Site Model object.
</pre>
|}


== Specialized for Slab ==
Rail subpart: returns the length of the rail. If the rail isn't fabric, returns N/A.
 
|-
{| border=0
|  ||
| colspan="3" | <big>Weight('gross', [optional parameters])</big>
|-
| colspan="3" | <big>Length('Gate Posts')</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns the weight of a wall, wall component, slab or slab component. All openings are ignored.
|  || valign="top" | The function is applicable to:
 
'component name=...': If provided, only openings in the components with the given name will be counted.


'component material=...': If provided, only components with the given material will be included.
Fence object: returns the sum of all post length.


'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
Post subpart: returns the length of the post, counted from top to bottom of depth below grade. If the post is not gate, returns N/A.
|-
|-
| style="width: 10pt;" |  ||  
|  ||  
|-
|-
| colspan="3" | <big>Weight('net', [optional parameters])</big>
| colspan="3" | <big>Length('Gates')</big>
|-
|-
|  || valign="top" | Returns the weight of a wall, wall component, slab or slab component.
|  || valign="top" | The function is applicable to:
 
'component name=...': If provided, only openings in the components with the given name will be counted.


'component material=...': If provided, only components with the given material will be included.
Fence object: returns the sum of all gate lengths.


'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
Gate subpart: return the length along the fence line of this Gate.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Acoustic Rating')</big>
| colspan="3" | <big>Length('Gravel Board')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
returns the sum length of all gravel boards.
 
Gravel Board subpart: returns the length of the gravel board.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Combustible Construction')</big>
| colspan="3" | <big>Length('Horizontal Boards')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the sum of all horizontal board lengths.
 
Infill subpart: returns the length of the horizontal board. It is defined as the distance/arc length from the start post to the end (depending on the object path). If the fence has different Infill Type, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Compartmentation')</big>
| colspan="3" | <big>Length('Panels')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the sum of all panel lengths.
 
Infill subpart: returns the length of the panel. If the fence has different Infill Type, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Component Name')</big>
| colspan="3" | <big>Length('Posts')</big>
|-
|-
|  || valign="top" | Returns the name of the wall, slab or roof component.
|  || valign="top" | The function is applicable to:
 
Fence object: returns the sum of all post length.
 
Post subpart: returns the length of the post, counted from top to bottom of depth below grade.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Cost Index Code')</big>
| colspan="3" | <big>Length('Rail', <Index>)</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the total length of all rails with index <Index>.
 
Rail subpart: return the length of the rail. If the rail doesn't correspond to the selected index, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Cost Index System')</big>
| colspan="3" | <big>Length('Rails')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the total length of all rails.
 
Rail subpart: returns the length of the rail.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Description')</big>
| colspan="3" | <big>Length('Running Posts')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the sum of all post length.
 
Post subpart: returns the length of the post, counted from top to bottom of depth below grade. If the post is not running, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Exterior')</big>
| colspan="3" | <big>Length('Vertical Boards')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the sum of all vertical boards lengths.
 
Infill subpart: returns the length of the vertical board. It is defined from the bottom position of the board to top. If the fence has different Infill Type, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Fire Rating')</big>
| colspan="3" | <big>SurfaceArea('Fabric')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the total surface area of all fabric rails.
 
Rail subpart: returns the surface area of the rail if it is fabric. Otherwise, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Function')</big>
| colspan="3" | <big>SurfaceArea('Panels')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the sum of all panel surface areas.
 
Infill subpart: returns the panel surface area. If the fence has different Infill Type, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Lambda')</big>
| colspan="3" | <big>Volume()</big>
|-
|-
|  || valign="top" | Returns the Lambda value of the object.
|  || valign="top" | The function is applicable to the Fence object.
 
Returns the total volume of the fence object.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Load Bearing')</big>
| colspan="3" | <big>Volume('Corner Footers')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the total volume of all corner footers.
 
Footer subpart: returns the volume of the footer. If the footer is not corner, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Manufacturer')</big>
| colspan="3" | <big>Volume('Corner Posts')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the volume of all corner posts.
 
Post subpart: returns the volume of the corner post. If the post is not corner, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Mark')</big>
| colspan="3" | <big>Volume('Footers')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the total volume of all footers.
 
Footer subpart: returns the volume of the footer.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Model')</big>
| colspan="3" | <big>Volume('Gate Footers')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | The function is applicable to:
 
Fence object: returns the total volume of all gate footers.
 
Footer subpart: returns the volume of the footer. If the gate is not gate, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('RValue')</big>
| colspan="3" | <big>Volume('Gate Posts')</big>
|-
|-
|  || valign="top" | Returns the R-Value of the object.
|  || valign="top" | The function is applicable to:
 
Fence object: returns the volume of all gate posts.
 
Post subpart: returns the volume of the gate post. If the post is not gate, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('UValue')</big>
| colspan="3" | <big>Volume('Gates')</big>
|-
|-
|  || valign="top" | Returns the U-Value of the object.
|  || valign="top" | The function is applicable to:
 
Fence object: returns the total volume of all gates.
 
Gate subpart: returns the volume of the gate.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Width()</big>
| colspan="3" | <big>Volume('Gravel Board')</big>
|-
|-
|  || valign="top" | Returns the thickness of a wall, slab, roof or a roof face object or their components.
|  || valign="top" | The function is applicable to:
 
returns the total volume of all gravel boards.
 
Gravel Board subpart: returns the volume of the gravel board.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Count('modifiers', [optional parameters])</big>
| colspan="3" | <big>Volume('Horizontal Boards')</big>
|-
|-
|  || valign="top" | Returns the number of modifiers in a slab or wall. For walls, recesses and projections are counted. For slabs, additions, subtractions and drains are counted.
|  || valign="top" | The function is applicable to:


'modifier type=...': If provided, only modifiers with any of the given types are counted. Multiple types can be delimited by a semicolon.
Fence object: returns the total volume of the horizontal boards.


'exclude modifier type=...': If provided, modifiers with any of the given types will not be counted.
Infill subpart: returns the horizontal board volume. If the fence has different Infill Type, returns N/A.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Count('openings', [optional parameters])</big>
| colspan="3" | <big>Volume('Panels')</big>
|-
|-
|  || valign="top" | Returns the number of openings in a wall, wall component, slab or slab component.
|  || valign="top" | The function is applicable to:


'component name=...': If provided, only openings in the components with the given name will be counted.
Fence object: returns the total volume of the panels.


'component material=...': If provided, only openings in the components with the given material will be counted.
Infill subpart: returns the panel volume. If the fence has different Infill Type, returns N/A.
|-
|  ||
|-
| colspan="3" | <big>Volume('Posts')</big>
|-
|  || valign="top" | The function is applicable to:


'component=...': If provided, only openings in the given components will be counted. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
Fence object: returns the volume of all posts.


opening criteria: If provided, only openings that satisfy all given criteria will be counted. If the values don't have any units specified, millimeters, square millimeters or cubic millimeters will be assumed. For slabs, the following criteria are available: min opening area top, max opening area top, min opening area bottom, max opening area bottom, min opening volume, max opening volume, min opening perimeter top, max opening perimeter top, min opening perimeter bottom, max opening perimeter bottom. For walls, the following criteria are available: min opening area left, max opening area left, min opening area right, max opening area right, min opening area facing core, max opening area facing core, min opening area avert core, max opening area avert core, min opening area center, max opening area center, min opening area footprint, max opening area footprint, min opening length footprint left, max opening length footprint left, min opening length footprint right, max opening length footprint right, min opening length footprint facing core, max opening length footprint facing core, min opening length footprint avert core, max opening length footprint avert core, min opening length footprint center, max opening length footprint center, min opening volume, max opening volume.
Post subpart: returns the volume of the post.
|-
|  ||
|-
| colspan="3" | <big>Volume('Rail', <Index>)</big>
|-
|  || valign="top" | The function is applicable to:


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
Fence object: returns the total volume of all rails from the selected index.


'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
Rail subpart: returns the volume of the rail. If the rail doesn't correspond to the selected index, returns N/A.
 
|-
'height=...': Specifies the height relative to the layer plane at which the footprint area and length along footprint criteria are measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|  ||
|-
| colspan="3" | <big>Volume('Rails')</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Count('openings') returns the number of openings in the wall, wall component, slab or slab component.
|  || valign="top" | The function is applicable to:


=Count('openings', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters.
Fence object: returns the total volume of all rails.


=Count('openings', 'min opening area top=0.5 sq m', 'max opening area top=1 sq m') returns the number of openings with an area between 0.5 and 1 square meter on the top of the slab or slab component.
Rail subpart: returns the volume of the rail. Function is defined only if Depth and Height return nonzero result.
|-
|  ||
|-
| colspan="3" | <big>Volume('Running Footers')</big>
|-
|  || valign="top" | The function is applicable to:


=Count('openings', 'min opening area bottom=1 sq ft', 'max opening volume=10 cu in') returns the number of openings with an area of at least 1 square foot on the bottom of the slab or slab component and a volume of at most 10 cubic inches.
Fence object: returns the total volume of all running footers.


=Count('openings', 'opening type=Window') returns the number of openings created by "Window" plug-in objects.
Footer subpart: returns the volume of the footer. If the footer is not running, returns N/A.
|-
|  ||
|-
| colspan="3" | <big>Volume('Running Posts')</big>
|-
|  || valign="top" | The function is applicable to:


=Count('openings', 'opening type=Window;WinDoor 6.0') returns the number of openings created by "Window" and "WinDoor 6.0" plug-in objects.
Fence object: returns the volume of all running posts.


=Count('openings', 'component=core', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters in the wall core component.
Post subpart: returns the volume of the running post. If the post is not running, returns N/A.
 
The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.</pre>
|-
|-
| colspan="3" | <big>Angle('energos')</big>
| ||  
|-
|-
|  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
| colspan="3" | <big>Volume('Vertical Boards')</big>
|-
|  || valign="top" | The function is applicable to:
 
Fence object: returns the total volume of the vertical boards.
 
Infill subpart: returns the vertical board volume. If the fence has different Infill Type, returns N/A.
|-
|-
|  ||  
|  ||  
|}
== Specialized for Hardscape ==
{| border=0
| colspan="3" | <big>Depth()</big>
|-
|-
| colspan="3" | <big>SlabThickness()</big>
| style="width: 10pt;" | || valign="top" | Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
|-
|-
| || valign="top" | Returns the thickness of slab objects.
| style="width: 10pt;" | ||
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| colspan="3" | <big>ProjectedArea()</big>
=SlabThickness returns the thickness for each object in the database
 
Spreadsheet cell:
=SlabThickness(PON=slab) returns the combined thickness of all slab objects in the drawing
</pre>
|-
|-
| colspan="3" | <big>SlabStyleName()</big>
| || valign="top" | Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|-
|  || valign="top" | Returns the name of the slab style used by the slab.
|  ||  
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| colspan="3" | <big>ObjectData('component name')</big>
=SlabStyleName returns the name of the slab style for each slab object in the database
 
Spreadsheet cell:
=SlabStyleName(n='slab-1') returns the name of the slab style for the object named “slab-1”
</pre>
|-
|-
| colspan="3" | <big>Area()</big>
|  || valign="top" | Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
|-
|  || valign="top" | Returns the area of a wall, slab, roof or a roof face object or their components.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Perim('bottom', [optional parameters])</big>
| colspan="3" | <big>Area()</big>
|-
|-
|  || valign="top" | Returns the perimeter of the bottom surface of a slab or slab component.
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Perim('openings bottom', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea()</big>
|-
|-
|  || valign="top" | Returns the sum of the opening perimeters on the bottom surface of a slab or slab component.
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening perimeter=...' / 'max opening perimeter=...': If provided, only openings with a perimeter of at least min opening perimeter and at most max opening perimeter will be included. If the values don't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Perim('openings top', [optional parameters])</big>
| colspan="3" | <big>Volume()</big>
|-
|  || valign="top" | Calculate the volume of the Curb, Landscape Area, Hardscape, or Site Model and their components.
|-
|-
|  || valign="top" | Returns the sum of the opening perimeters on the top surface of a slab or slab component.
|  ||  
|}


'component name=...': If provided, only openings in the components with the given name will be included.
== Specialized for Hedgerow ==


'component material=...': If provided, only openings in the components with the given material will be included.
{| border=0
 
| colspan="3" | <big>ObjectData('percentage')</big>
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
 
| style="width: 10pt;" |  || valign="top" | Return the percentage value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
'min opening perimeter=...' / 'max opening perimeter=...': If provided, only openings with a perimeter of at least min opening perimeter and at most max opening perimeter will be included. If the values don't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
| style="width: 10pt;" |  ||  
|-
|-
| colspan="3" | <big>Perim('top', [optional parameters])</big>
| colspan="3" | <big>ObjectData('Plant Record', <field>)</big>
|-
|-
|  || valign="top" | Returns the perimeter of the top surface of a slab or slab component.
|  || valign="top" | Provides access to the Plant Record data of the Landscape Area Plant subparts for edit if the style allows.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>SurfaceArea('bottom gross', [optional parameters])</big>
| colspan="3" | <big>ObjectData('rate')</big>
|-
|  || valign="top" | Return the rate value value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|-
|-
|  || valign="top" | Returns the area of the bottom surface of a slab or slab component. All openings are ignored.
|  ||  
 
|-
'component name=...': If provided, only components with the given name will be included.
| colspan="3" | <big>ObjectData('rate unit')</big>
 
|-
'component material=...': If provided, only components with the given material will be included.
|  || valign="top" | Return the rate unit string of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('bottom gross') returns the gross area of the bottom face of the slab or slab component.
|  ||  
 
=SurfaceArea('bottom gross', 'component=top') returns the gross area of the bottom face of the top component of the slab.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('bottom net', [optional parameters])</big>
| colspan="3" | <big>ObjectData('rate with unit')</big>
|-
|-
|  || valign="top" | Returns the area of the bottom surface of a slab or slab component.
|  || valign="top" | Return the rate value and unit of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('bottom net') returns the area of the bottom face of the slab or slab component.
|  ||  
|}


=SurfaceArea('bottom net', 'min opening area=0.5 sq m') returns the area of the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters.
== Specialized for Landscape Area ==


=SurfaceArea('bottom net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
{| border=0
 
| colspan="3" | <big>Depth()</big>
=SurfaceArea('bottom net', 'component=top') returns the area of the bottom face of the top component of the slab.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('openings bottom', [optional parameters])</big>
| style="width: 10pt;" | || valign="top" | Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
|-
|-
| || valign="top" | Returns the area of the openings on the bottom surface of a slab or slab component.
| style="width: 10pt;" | ||
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings bottom') returns the total area of openings on the bottom face of the slab or slab component.
| colspan="3" | <big>ProjectedArea()</big>
 
=SurfaceArea('openings bottom', 'min opening area=0.5 sq m') returns the total area of openings on the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('openings bottom', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('openings bottom', 'component=top') returns the total area of openings on the bottom face of the top component of the slab.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('openings top', [optional parameters])</big>
| || valign="top" | Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|-
|  || valign="top" | Returns the area of the openings on the top surface of a slab or slab component.
|  ||  
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings top') returns the total area of openings on the top face of the slab or slab component.
| colspan="3" | <big>ObjectData('component name')</big>
 
=SurfaceArea('openings top', 'min opening area=0.5 sq m') returns the total area of openings on the top face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('openings top', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the top face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('openings top', 'component=bottom') returns the total area of openings on the top face of the bottom component of the slab.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('top gross', [optional parameters])</big>
| || valign="top" | Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
|-
|-
|  || valign="top" | Returns the area of the top surface of a slab or slab component. All openings are ignored.
|  ||  
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('top gross') returns the gross area of the top face of the slab or slab component.
| colspan="3" | <big>ObjectData('divider')</big>
 
=SurfaceArea('top gross', 'component=bottom') returns the gross area of the top face of the bottom component of the slab.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('top net', [optional parameters])</big>
| || valign="top" | Return the divider string or empty of this divider from a Landscape Area. This must be used on a database row listing the dividers/plants of Landscape Areas.
|-
|-
|  || valign="top" | Returns the area of the top surface of a slab or slab component.
|  ||  
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('top net') returns the area of the top face of the slab or slab component.
| colspan="3" | <big>ObjectData('Landscape Area', <field>)</big>
 
=SurfaceArea('top net', 'min opening area=0.5 sq m') returns the area of the top face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('top net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the top face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('top net', 'component=bottom') returns the area of the top face of the bottom component of the slab.</pre>
|-
|-
| colspan="3" | <big>Volume()</big>
| || valign="top" | Provides access to the Landscape Area data field for edit if the style allows.
|-
|-
|  || valign="top" | Returns the volume of a wall, slab, roof or a roof face object or their components.
|  ||  
|-
|-
| ||  
| colspan="3" | <big>ObjectData('percentage')</big>
|-
|-
| colspan="3" | <big>Volume('gross', [optional parameters])</big>
| || valign="top" | Return the percentage value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|-
|-
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component. All openings are ignored.
|  ||  
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('gross') returns the gross volume of the wall, wall component, slab or slab component.
| colspan="3" | <big>ObjectData('Plant Record', <field>)</big>
 
=Volume('gross', 'component=core') returns the gross volume of the core wall component.</pre>
|-
|-
| colspan="3" | <big>Volume('net', [optional parameters])</big>
| || valign="top" | Provides access to the Plant Record data of the Landscape Area Plant subparts for edit if the style allows.
|-
|-
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component.
|  ||  
 
|-
'component name=...': If provided, only components with the given name will be included.
| colspan="3" | <big>ObjectData('rate')</big>
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('net') returns the volume of the wall, wall component, slab or slab component.
|  || valign="top" | Return the rate value value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
 
=Volume('net', 'min opening volume=10 cu cm') returns the volume of the wall, wall component, slab or slab component, but only taking openings with at least 10 cubic centimeters of volume into account.
 
=Volume('net', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the volume of the wall, wall component, slab or slab component, but only taking openings with between 10 cubic centimeters and 1 cubic meter of volume into account.
 
=Volume('net', 'opening type=Window') returns the volume of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=Volume('net', 'opening type=Window;WinDoor 6.0') returns the volume of the wall or wall component, but only taking openings created by "Window" and "WinDoor 6.0" plug-in objects into account.
 
=Volume('net', 'component=core', 'min opening volume=10 cu cm') returns the volume of the core wall component, but only taking openings with a volume of at least 10 cubic centimeters into account.</pre>
|-
|-
| colspan="3" | <big>Volume('openings', [optional parameters])</big>
| ||  
|-
|-
| || valign="top" | Returns the volume of the openings in a wall, wall component, slab or slab component.
| colspan="3" | <big>ObjectData('rate unit')</big>
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('openings') returns the total volume of openings in the wall, wall component, slab or slab component.
|  || valign="top" | Return the rate unit string of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
 
|-
=Volume('openings', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters.
|  ||
 
|-
=Volume('openings', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the total volume of openings with a volume of at least 10 cubic centimeters and at most 1 cubic meter.
| colspan="3" | <big>ObjectData('rate with unit')</big>
 
|-
=Volume('openings', 'opening type=Window') returns the total volume of openings created by "Window" plug-in objects.
|  || valign="top" | Return the rate value and unit of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
 
|-
=Volume('openings', 'opening type=Window;WinDoor 6.0') returns the total volume of openings created by "Window" and "WinDoor 6.0" plug-in objects.
|  ||
 
|-
=Volume('openings', 'component=core', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters in the wall core component.</pre>
| colspan="3" | <big>Area()</big>
|}
|-
 
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
== Specialized for Socket ==
|-
 
|  ||
{| border=0
|-
| colspan="3" | <big>ObjectData('eval socket circuits', '<RecordName>', '<FieldName>')</big>
| colspan="3" | <big>SurfaceArea()</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Get parameter values or attached record fields from the socket's connected circuits.
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|-
| style="width: 10pt;" |  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('eval socket device', '<RecordName>', '<FieldName>')</big>
| colspan="3" | <big>Volume()</big>
|-
|-
|  || valign="top" | Get parameter value or attached record field from the socket's device.
|  || valign="top" | Calculate the volume of the Curb, Landscape Area, Hardscape, or Site Model and their components.
|-
|-
|  ||  
|  ||  
|}
|}


== Specialized for Space ==
== Specialized for Lighting Device ==


{| border=0
{| border=0
| colspan="3" | <big>GetSpaceNameForObj()</big>
| colspan="3" | <big>Weight(criteria)</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns the name of the space that surrounds the object.
| style="width: 10pt;" |  || valign="top" | Returns the total weight of the Lighting Device and all it's accessories.
|-
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| style="width: 10pt;" |  ||  
=GetSpaceNameForObj returns the space name for each object in the database
|-
 
| colspan="3" | <big>ObjectData('accessory inst types', <field>)</big>
Spreadsheet cell:
=GetSpaceNameForObj(n='chair-1') returns the space name for the object named “chair-1”
</pre>
|-
|-
| colspan="3" | <big>GetSpaceNumForObj()</big>
| || valign="top" | Provides access to the Instrument Type of Lighting Device accessories. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
|-
|-
|  || valign="top" | Returns the number of the space that surrounds the object.
|  ||  
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| colspan="3" | <big>ObjectData('accessory parameter', <field>)</big>
=GetSpaceNumForObj returns the space number for each object in the database
 
Spreadsheet cell:
=GetSpaceNumForObj(n='chair-1') returns the space number for the object named “chair-1”</pre>
|}
 
== Specialized for Structural Member ==
 
{| border=0
| colspan="3" | <big>ObjectData(criteria, 'cover bound bottom')</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns the bottom bound of the structural member cover.
|  || valign="top" | Provides access to a data of the Lighting Device accessory. Use  the first parameter to specify the universal parameter name. Use no parameters additional for all cells and accessories or use additional parameters to specify cells or accessories.
|-
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=OBJECTDATA('cover bound bottom')    Returns the bottom bound of the Structural Member cover.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'cover bound bottom')    Returns the bottom bound of the Structural Member cover.
</pre>
|-
|-
| colspan="3" | <big>ObjectData(criteria, 'cover bound top')</big>
| colspan="3" | <big>ObjectData('accessory symbols', <field>)</big>
|-
|-
|  || valign="top" | Returns the top bound of the Structural Member cover.
|  || valign="top" | Provides access to the symbol names of Lighting Device accessories. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=OBJECTDATA('cover bound top')    Returns the top bound of the Structural Member cover.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'cover bound top')    Returns the top bound of the Structural Member cover.
</pre>
|-
|-
| colspan="3" | <big>ObjectData(criteria, 'cover physical length')</big>
| colspan="3" | <big>ObjectData('cellsonly', <field>)</big>
|-
|-
|  || valign="top" | Returns the physical length of the structural member cover including its start and end conditions.
|  || valign="top" | Provides access to a parameter of the Lighting Devices and ignores accessories. Use parameters to specify the universal parameter name.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=OBJECTDATA('cover physical length')     Returns the physical length of the structural member cover including its start and end conditions.
|-
 
| colspan="3" | <big>ObjectData('channel', <field>)</big>
Spreadsheet cell:
|-
=OBJECTDATA(SEL; 'cover physical length')    Returns the physical length of the structural member cover including its start and end conditions.
|  || valign="top" | Provides access to the channel of Lighting Devices. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
</pre>
|-
|  ||
|-
|-
| colspan="3" | <big>ObjectData(criteria, 'member bound bottom')</big>
| colspan="3" | <big>ObjectData('colors', <field>)</big>
|-
|-
|  || valign="top" | Returns the bottom bound of the Structural Member.
|  || valign="top" | Provides access to the color of Lighting Devices. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=OBJECTDATA('member bound bottom')    Returns the bottom bound of the Structural Member.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'member bound bottom')    Returns the bottom bound of the Structural Member.
</pre>
|-
|-
| colspan="3" | <big>ObjectData(criteria, 'member bound top')</big>
| colspan="3" | <big>ObjectData('eval schematic device', '<RecordName>', '<FieldName>')</big>
|-
|-
|  || valign="top" | Returns the top bound of the Structural Member.
|  || valign="top" | Get parameter value or attached record field from the objects's schematic device.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=OBJECTDATA('member bound top')    Returns the top bound of the Structural Member.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'member bound top')    Returns the top bound of the Structural Member.
</pre>
|-
|-
| colspan="3" | <big>ObjectData(criteria, 'member physical length')</big>
| colspan="3" | <big>ObjectData('parameter', <field>)</big>
|-
|-
|  || valign="top" | Returns the physical length of the structural member including its start and end conditions.
|  || valign="top" | Provides access to a parameter of Lighting Devices. Use parameters to specify the universal parameter name, cell number and accessory number.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=OBJECTDATA('member physical length')    Returns the physical length of the structural member including its start and end conditions.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'member physical length')    Returns the physical length of the structural member including its start and end conditions.
</pre>
|}
|}


== Specialized for Wall ==
== Specialized for Marionette Object ==


{| border=0
{| border=0
| colspan="3" | <big>Weight('gross', [optional parameters])</big>
| colspan="3" | <big>ObjectData('parameter', '<OIP FieldName>')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get parameter values or attached record fields from Marionette objects.
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns the weight of a wall, wall component, slab or slab component. All openings are ignored.
| style="width: 10pt;" |  ||  
|}


'component name=...': If provided, only openings in the components with the given name will be counted.
== Specialized for Panel Connector ==


'component material=...': If provided, only components with the given material will be included.
{| border=0
 
| colspan="3" | <big>ObjectData('eval panel connector circuit', '<RecordName>', '<FieldName>')</big>
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
| style="width: 10pt;" |  || valign="top" | Get parameter value or attached record field from the circuit connected to the panel connector.
|-
|-
| style="width: 10pt;" |  ||  
| style="width: 10pt;" |  ||  
|-
|}
| colspan="3" | <big>Weight('net', [optional parameters])</big>
|-
|  || valign="top" | Returns the weight of a wall, wall component, slab or slab component.


'component name=...': If provided, only openings in the components with the given name will be counted.
== Specialized for Plant ==


'component material=...': If provided, only components with the given material will be included.
{| border=0
 
| colspan="3" | <big>Count('excav component')</big>
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
| style="width: 10pt;" |  || valign="top" | Returns the number of planting excavation components.
|-
|-
|  ||  
| style="width: 10pt;" |  ||  
|-
|-
| colspan="3" | <big>FootPrintArea('gross', [optional parameters])</big>
| colspan="3" | <big>Volume('excav component', <index>)</big>
|-
|-
|  || valign="top" | Returns the footprint area of a wall or wall component. All openings are ignored.
|  || valign="top" | Returns the volume of the <index> planting excavation component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>FootPrintArea('net', [optional parameters])</big>
| colspan="3" | <big>PlantImage(index)</big>
|-
|  || valign="top" | Returns an image of the object at the specified index.
|-
|-
|  || valign="top" | Returns the footprint area of a wall or wall component.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=PlantImage(2) displays the image specified for Image Detail in the More Data pane of the plant symbol definition


'component name=...': If provided, only components with the given name will be included.
Spreadsheet cell:
=PlantImage((‘Plant’.’plant ID’=’TaxfR’), 4) displays the image specified for Custom Image in the More Data pane of the plant symbol definition with a plant ID of TaxfR
</pre>
|}


'component material=...': If provided, only components with the given material will be included.
== Specialized for Railing ==


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
{| border=0
| colspan="3" | <big>Width()</big>
|-
| style="width: 10pt;" |  || valign="top" | This function is applicable to the following subparts: Frame, Panel, Bracket and Face Post.


'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
QUANTITY DESCRIPTION:
For Frame: Width of the rectangular frame.


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
For Panel: Width of the rectangular panel.


'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
For Bracket: width of bracket (actually represents the value of Handrail offset).


'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
For Face Post: width of face post (actually represents the value of Inset).
|-
|-
|  ||  
| style="width: 10pt;" |  ||  
|-
|-
| colspan="3" | <big>FootPrintArea('openings', [optional parameters])</big>
| colspan="3" | <big>Width('brackets')</big>
|-
|-
|  || valign="top" | Returns the area of the openings in the footprint of a wall or wall component.
|  || valign="top" | This function is applicable to the Railing object.


'component name=...': If provided, only openings in the components with the given name will be included.
QUANTITY DESCRIPTION:
 
Width of bracket subpart.
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Acoustic Rating')</big>
| colspan="3" | <big>Width('face posts')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Width of face post subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Combustible Construction')</big>
| colspan="3" | <big>Width('frame')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Sum of the width of all frame subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Compartmentation')</big>
| colspan="3" | <big>Width('panels')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Sum of the width of all panel subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Component Name')</big>
| colspan="3" | <big>Width('profile')</big>
|-
|-
|  || valign="top" | Returns the name of the wall, slab or roof component.
|  || valign="top" | This function is applicable to the following subparts: Handrail, Guardrail, Post, Frame, Bar Vertical, Bar Horizontal, Bracket and Face Post.
 
QUANTITY DESCRIPTION:
Width of subparts listed above.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Cost Index Code')</big>
| colspan="3" | <big>Height()</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object and the following subparts: Handrail, Guardrail, Frame, Panel, Bracket, Post and Face Post.
|-
 
|  ||
QUANTITY DESCRIPTION:
|-
For Railing object: Height of the Railing object (actually represents the maximum value of Guardrail Height or Handrail Height).
| colspan="3" | <big>ObjectData('Cost Index System')</big>
 
|-
For Frame: Height of the rectangular frame.
|  || valign="top" |
 
For Panel: Height of the rectangular panel.
 
For Handrail: Height of Handrail (actually represents the value of Handrail Height).
 
For Guardrail: Height of Guardrail (actually represents the value of Guardrail Height).
 
For Face Post: Height of Post.
 
For Post: Height of Post.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Description')</big>
| colspan="3" | <big>Height('brackets')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Height of the bracket subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Exterior')</big>
| colspan="3" | <big>Height('face posts')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Sum of the height of all face post subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Fire Rating')</big>
| colspan="3" | <big>Height('frame')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Sum of the height of all frame subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Function')</big>
| colspan="3" | <big>Height('guardrail')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Height of the Guardrail (actually represents the value of Guardrail Height).
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Lambda')</big>
| colspan="3" | <big>Height('handrail')</big>
|-
|-
|  || valign="top" | Returns the Lambda value of the object.
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Height of the Handrail (actually represents the value of Handrail Height).
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Load Bearing')</big>
| colspan="3" | <big>Height('panels')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Sum of the height of all panel subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Manufacturer')</big>
| colspan="3" | <big>Height('posts')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Sum of the height of all post subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Mark')</big>
| colspan="3" | <big>Height('profile')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the following subparts: Handrail, Guardrail, Frame, Bar Vertical, Bar Horizontal, Bracket, Post and Face Post.
 
QUANTITY DESCRIPTION:
Height of profile of the individual subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Model')</big>
| colspan="3" | <big>Count('corners')</big>
|-
|-
|  || valign="top" |  
|  || valign="top" | This function is applicable to the Railing object and the following subparts: Guardrail and Handrail.
 
QUANTITY DESCRIPTION:
For Railing object: Number of vertices that change the direction or height of the path without the beginning and end.
 
For Guardrail: Number of vertices that change the direction or height of the path without the beginning and end in the Guardrail subpart.
 
For Handrail: If there is no Guardrail, then number of vertices that change the direction or height of the path without the beginning and end in the Guardrail subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Path Type')</big>
| colspan="3" | <big>Angle()</big>
|-
|-
|  || valign="top" | Returns the path type of a wall. 0 is line, and 1 is arc.
|  || valign="top" | This function is applicable to the following subparts: Bar Vertical and Bar Horizontal.
 
QUANTITY DESCRIPTION:
For Bar Vertical: Angle of the vertical bars(if option Rotate bars to diagonals on then 45° if not 0°.).
 
For Bar Horizontal: Angle of the horizontal bars(if option Rotate bars to diagonals on then 45° if not 0°.).
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('RValue')</big>
| colspan="3" | <big>Angle('bar horizontal')</big>
|-
|-
|  || valign="top" | Returns the R-Value of the object.
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
For Railing object: Angle of the horizontal bars(if option Rotate bars to diagonals on then 45° if not 0°.).
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('UValue')</big>
| colspan="3" | <big>Angle('bar vertical')</big>
|-
|-
|  || valign="top" | Returns the U-Value of the object.
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
For Railing object: Angle of the vertical bars(if option Rotate bars to diagonals on then 45° if not 0°.).
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Width()</big>
| colspan="3" | <big>Area()</big>
|-
|-
|  || valign="top" | Returns the thickness of a wall, slab, roof or a roof face object or their components.
|  || valign="top" | This function is applicable to the Railing object and the following subparts: Frame, Panel, Bracket and Face Post.
 
QUANTITY DESCRIPTION:
For Railing object: Area of the entire Railing object.
 
For subpart: Area of the individual subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Height('average')</big>
| colspan="3" | <big>Area('brackets')</big>
|-
|-
|  || valign="top" | Returns the average height of a wall, including wall peaks and different starting and ending heights.
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Area of bracket subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Height('overall')</big>
| colspan="3" | <big>Area('face posts')</big>
|-
|-
|  || valign="top" | Returns the overall height of a wall.
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Area of face post subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Count('inserts', [optional parameters])</big>
| colspan="3" | <big>Area('frame')</big>
|-
|-
|  || valign="top" | Returns the number of inserts (symbols and parametric objects) in a wall.
|  || valign="top" | This function is applicable to the Railing object.


'insert type=...': If provided, only inserts with any of the given names will be counted. Multiple names can be delimited by a semicolon.
QUANTITY DESCRIPTION:
Sum of the area of all frame subparts.
|-
|  ||
|-
| colspan="3" | <big>Area('panels')</big>
|-
|  || valign="top" | This function is applicable to the Railing object.


'exclude insert type=...': If provided, inserts with any of the given types will not be counted.
QUANTITY DESCRIPTION:
Sum of the area of all panel subparts.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Count('inserts') returns the number of inserts in the wall object.
|  ||  
 
|-
=Count('inserts', 'insert type=Window') returns the number of "Window" plug-in object inserts.
| colspan="3" | <big>Perimeter()</big>
|-
|  || valign="top" | This function is applicable to the Frame subpart.


=Count('inserts', 'insert type=Window;WinDoor 6.0') returns the number of by "Window" and "WinDoor 6.0" plug-in object inserts.
QUANTITY DESCRIPTION:
 
Frame: Perimeter of the Frame.
The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.</pre>
|-
|  ||
|-
|-
| colspan="3" | <big>Count('modifiers', [optional parameters])</big>
| colspan="3" | <big>Perimeter('frame')</big>
|-
|-
|  || valign="top" | Returns the number of modifiers in a slab or wall. For walls, recesses and projections are counted. For slabs, additions, subtractions and drains are counted.
|  || valign="top" | This function is applicable to the Railing object.


'modifier type=...': If provided, only modifiers with any of the given types are counted. Multiple types can be delimited by a semicolon.
QUANTITY DESCRIPTION:
 
For Railing object: Perimeter of all Frames.
'exclude modifier type=...': If provided, modifiers with any of the given types will not be counted.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Count('openings', [optional parameters])</big>
| colspan="3" | <big>Length()</big>
|-
|-
|  || valign="top" | Returns the number of openings in a wall, wall component, slab or slab component.
|  || valign="top" | This function is applicable to the Railing object and the following subparts: Handrail, Guardrail, Frame, Bar Vertical, Bar Horizontal, Bracket and Face Post.
 
QUANTITY DESCRIPTION:
For Railing object: Length of the 3D object path.


'component name=...': If provided, only openings in the components with the given name will be counted.
For Handrail: Length of the 3D handrail.


'component material=...': If provided, only openings in the components with the given material will be counted.
For Guardrail: Length of the 3D guardrail.


'component=...': If provided, only openings in the given components will be counted. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
For Frame: With of frame.


opening criteria: If provided, only openings that satisfy all given criteria will be counted. If the values don't have any units specified, millimeters, square millimeters or cubic millimeters will be assumed. For slabs, the following criteria are available: min opening area top, max opening area top, min opening area bottom, max opening area bottom, min opening volume, max opening volume, min opening perimeter top, max opening perimeter top, min opening perimeter bottom, max opening perimeter bottom. For walls, the following criteria are available: min opening area left, max opening area left, min opening area right, max opening area right, min opening area facing core, max opening area facing core, min opening area avert core, max opening area avert core, min opening area center, max opening area center, min opening area footprint, max opening area footprint, min opening length footprint left, max opening length footprint left, min opening length footprint right, max opening length footprint right, min opening length footprint facing core, max opening length footprint facing core, min opening length footprint avert core, max opening length footprint avert core, min opening length footprint center, max opening length footprint center, min opening volume, max opening volume.
For Bar Vertical: Length of the bar vertical.


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
For Bar Horizontal: Length of the bar horizontal.


'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
For Bracket: Handrail Offset + Bracket Height.


'height=...': Specifies the height relative to the layer plane at which the footprint area and length along footprint criteria are measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
For Face Post: Width + height of face post.
|-
|  ||
|-
| colspan="3" | <big>Length('bar horizontal')</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Count('openings') returns the number of openings in the wall, wall component, slab or slab component.
|  || valign="top" | This function is applicable to the Railing object.


=Count('openings', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters.
QUANTITY DESCRIPTION:
Sum of the length of all bar horizontal subparts.
|-
|  ||
|-
| colspan="3" | <big>Length('bar vertical')</big>
|-
|  || valign="top" | This function is applicable to the Railing object.


=Count('openings', 'min opening area top=0.5 sq m', 'max opening area top=1 sq m') returns the number of openings with an area between 0.5 and 1 square meter on the top of the slab or slab component.
QUANTITY DESCRIPTION:
Sum of the length of all bar vertical subparts.
|-
|  ||
|-
| colspan="3" | <big>Length('brackets')</big>
|-
|  || valign="top" | This function is applicable to the Railing object.


=Count('openings', 'min opening area bottom=1 sq ft', 'max opening volume=10 cu in') returns the number of openings with an area of at least 1 square foot on the bottom of the slab or slab component and a volume of at most 10 cubic inches.
QUANTITY DESCRIPTION:
 
Length of the bracket subpart.
=Count('openings', 'opening type=Window') returns the number of openings created by "Window" plug-in objects.
|-
 
|  ||
=Count('openings', 'opening type=Window;WinDoor 6.0') returns the number of openings created by "Window" and "WinDoor 6.0" plug-in objects.
 
=Count('openings', 'component=core', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters in the wall core component.
 
The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.</pre>
|-
|-
| colspan="3" | <big>Angle('energos')</big>
| colspan="3" | <big>Length('face posts')</big>
|-
|-
|  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Length of the face post subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>WallArea_Net()</big>
| colspan="3" | <big>Length('frame')</big>
|-
|-
|  || valign="top" | Returns the average of the net area of the interior and exterior face of the wall. The net area is adjusted for holes in the wall.
|  || valign="top" | This function is applicable to the Railing object.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallArea_Net returns the average of the net area of the interior and exterior face of the wall, for each wall in the database; the net area is adjusted for holes in the wall


Spreadsheet cell:
QUANTITY DESCRIPTION:
=WallArea_Net(t=wall) returns the average of the net area of the interior and exterior face of the wall, combined for all walls in the drawing; the net area is adjusted for holes in the wall
Length of the frame subpart.
</pre>
|-
|-
| colspan="3" | <big>WallArea_Gross()</big>
| ||  
|-
|-
| || valign="top" | Returns the average of the gross area of the interior and exterior face of the wall. The gross area ignores holes in the wall.
| colspan="3" | <big>Length('guardrail')</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | This function is applicable to the Railing object.
=WallArea_Gross returns the average of the gross area of the interior and exterior face of the wall, for each wall in the database; the gross area ignores holes in the wall


Spreadsheet cell:
QUANTITY DESCRIPTION:
=WallArea_Gross(t=wall) returns the average of the gross area of the interior and exterior face of the wall, combined for all walls in the drawing; the gross area ignores holes in the wall
Sum of the length of all guardrail subparts.
</pre>
|-
|-
| colspan="3" | <big>WallAverageHeight()</big>
| ||  
|-
|-
| || valign="top" | Returns the average wall height of a wall, including wall peaks and different starting and ending heights.
| colspan="3" | <big>Length('handrail')</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | This function is applicable to the Railing object.
=WallAverageHeight returns the average height for each wall object in the database


Spreadsheet cell:
QUANTITY DESCRIPTION:
=WallAverageHeight((t=wall)&(sel=true)) returns the average height of all walls that are selected in the drawing
Sum of the length of all handrail subparts.
</pre>
|-
|-
| colspan="3" | <big>WallThickness()</big>
| ||  
|-
|-
| || valign="top" | Returns the thickness of the wall.
| colspan="3" | <big>Length('max support spacing')</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | This function is applicable to the Railing object.
=WallThickness returns the thickness for each wall object in the database


Spreadsheet cell:
QUANTITY DESCRIPTION:
=WallThickness(t=wall) returns the combined thickness of all walls in the drawing
Maximum distance between posts if there no posts then returns the maximum distance between brackets.
</pre>
|-
|-
| colspan="3" | <big>WallStyleName()</big>
| ||  
|-
|-
| || valign="top" | Returns the name of the wall style used by the wall.
| colspan="3" | <big>SurfaceArea()</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | This function is applicable to the following subparts: Handrail, Guardrail, Post, Frame, Panel, Bar Vertical, Bar Horizontal, Bracket and Face Post.
=WallStyleName returns the name of the wall style for each wall object in the database


Spreadsheet cell:
QUANTITY DESCRIPTION:
=WallStyleName(n='wall-1') returns the name of the wall style for the object named “wall-1”
Complete outer surface area of subpart.
</pre>
|-
|  ||
|-
|-
| colspan="3" | <big>Area()</big>
| colspan="3" | <big>SurfaceArea('bar horizontal')</big>
|-
|-
|  || valign="top" | Returns the area of a wall, slab, roof or a roof face object or their components.
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Sum of the surface area of all bar horizontal subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length()</big>
| colspan="3" | <big>SurfaceArea('bar vertical')</big>
|-
|-
|  || valign="top" | Returns the length of a wall or its components.
|  || valign="top" | This function is applicable to the Railing object.
 
QUANTITY DESCRIPTION:
Sum of the surface area of all bar vertical subparts.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('control line avert core', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea('brackets')</big>
|-
|-
|  || valign="top" | Returns the length of the control line of a wall component on the side that's oriented away from the core component. All openings, recesses, projections and peaks are ignored.
|  || valign="top" | This function is applicable to the Railing object.


'component name=...': If provided, only components with the given name will be included.
QUANTITY DESCRIPTION:
 
Surface area of bracket.
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('control line center', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea('face posts')</big>
|-
|-
|  || valign="top" | Returns the length of the central control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.
|  || valign="top" | This function is applicable to the Railing object.


'component name=...': If provided, only components with the given name will be included.
QUANTITY DESCRIPTION:
 
Sum of the surface area of all face post subparts.
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('control line facing core', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea('frame')</big>
|-
|-
|  || valign="top" | Returns the length of the control line of a wall component on the side that's oriented towards the core component. All openings, recesses, projections and peaks are ignored.
|  || valign="top" | This function is applicable to the Railing object.


'component name=...': If provided, only components with the given name will be included.
QUANTITY DESCRIPTION:
 
Sum of the surface area of all frame subparts.
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('control line left', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea('guardrail')</big>
|-
|-
|  || valign="top" | Returns the length of the left control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.
|  || valign="top" | This function is applicable to the Railing object.


'component name=...': If provided, only components with the given name will be included.
QUANTITY DESCRIPTION:
 
Sum of the surface area of all guardrail subparts.
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('control line right', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea('handrail')</big>
|-
|-
|  || valign="top" | Returns the length of the right control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.
|  || valign="top" | This function is applicable to the Railing object.


'component name=...': If provided, only components with the given name will be included.
QUANTITY DESCRIPTION:
 
Sum of the surface area of all handrail subparts.
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('avert core gross', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea('panels')</big>
|-
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented away from the core component. All openings are ignored.
|  || valign="top" | This function is applicable to the Railing object.


'component name=...': If provided, only components with the given name will be included.
QUANTITY DESCRIPTION:
 
Sum of the surface area of all panel subparts.
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('avert core net', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea('posts')</big>
|-
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented away from the core component.
|  || valign="top" | This function is applicable to the Railing object.


'component name=...': If provided, only components with the given name will be included.
QUANTITY DESCRIPTION:
Sum of the surface area of all post subparts.
|-
|  ||
|}


'component material=...': If provided, only components with the given material will be included.
== Specialized for Railing/Fence ==


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
{| border=0
| colspan="3" | <big>Width()</big>
|-
| style="width: 10pt;" |  || valign="top" | Width([optional parameter])


'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
This function is applicable to the following subparts: Wall Bracket, Face Mount, Frame and Panel.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Wall Bracket: Horizontal dimension of the Top Rails Wall Bracket.


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
For Face Mount: Horizontal dimension of the Face Mount Post.


'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
For Frame: Width of the rectangular frame.


'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
For Panel: Width of the panel in elevation.
|-
|-
|  ||  
| style="width: 10pt;" |  ||  
|-
|-
| colspan="3" | <big>Length('center gross', [optional parameters])</big>
| colspan="3" | <big>Width('profile')</big>
|-
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the center line. All openings are ignored.
|  || valign="top" | Width('profile', [optional parameter])
 
This function is applicable to the following subparts: Top Rail, Post, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.


'component name=...': If provided, only components with the given name will be included.
QUANTITY DESCRIPTION:
For Top Rail: Width of the Railings TopRail cross section profile. For round or octagonal shape of profile, width equals height. For custom profile (symbol), the bounding box is used to calculate this value.


'component material=...': If provided, only components with the given material will be included.
For Post: Width of the Posts cross section profile.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
For Crossbar Top and Crossbar Bottom: Width of the profile of the crossbar.


'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
For Bar Vertical and Bar Horizontal: Width of the vertical bars profile.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('center net', [optional parameters])</big>
| colspan="3" | <big>Height()</big>
|-
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the center line.
|  || valign="top" | Height([optional parameter])


'component name=...': If provided, only components with the given name will be included.
This function is applicable to the Railing object and the following subparts: Top Rail, Wall Bracket, Post, Face Mount, Frame, Panel.


'component material=...': If provided, only components with the given material will be included.
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
QUANTITY DESCRIPTION:
For Railing object: The height of the railing, measured as the vertical distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the highest subpart of the Railing (Top Rail if available, Frame, Panel or Crossbar Top).
This value is written into the IFC-field Pset_RailingCommon.Height.
 
For Top Rail: Height of the TopRail, measured as the distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the Railings Top Rail.
 
For Wall Bracket: Vertical dimension of the Top Rails Wall Bracket.


'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
For Post: Height of the Post.


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
For Face Mount: Vertical dimension of the Face Mount Post.


'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
For Frame: Height of the rectangular frame.


'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
For Panel: Height of the panel in elevation.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('facing core gross', [optional parameters])</big>
| colspan="3" | <big>Height('profile')</big>
|-
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented towards the core component. All openings are ignored.
|  || valign="top" | Height('profile', [optional parameter])
 
This function is applicable to the following subparts: Top Rail, Post, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.


'component name=...': If provided, only components with the given name will be included.
QUANTITY DESCRIPTION:
For Top Rail: Height of the Railings TopRail cross section profile. For round or octagonal shape of profile, width equals height. For custom profile (symbol), the bounding box is used to calculate this value.


'component material=...': If provided, only components with the given material will be included.
For Post: Height of the Posts cross section profile.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
For Crossbar Top and Crossbar Bottom: Height of the profile of the crossbar.


'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
For Bar Vertical and Bar Horizontal: Height of the vertical bars profile.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('facing core net', [optional parameters])</big>
| colspan="3" | <big>Count('angle')</big>
|-
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented towards the core component.
|  || valign="top" | Count('angle', [optional parameter])


'component name=...': If provided, only components with the given name will be included.
This function is applicable to the Railing object and the Top Rail.


'component material=...': If provided, only components with the given material will be included.
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
QUANTITY DESCRIPTION:
For Railing: Number of vertices that change the path without the beginning and end. Or IOW: the number of angles in the path..


'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
For Top Rail: Number of angles  in the Top Rail subpart.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('left gross', [optional parameters])</big>
| colspan="3" | <big>Angle()</big>
|-
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the left face. All openings are ignored.
|  || valign="top" | Angle([optional parameter])


'component name=...': If provided, only components with the given name will be included.
This function is applicable to the following subparts: Bar Vertical and Bar Horizontal.


'component material=...': If provided, only components with the given material will be included.
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
QUANTITY DESCRIPTION:
For Bar Vertical: Angle of the vertical bars. Vertical is 0°.


'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
For Bar Horizontal: Angle of the horizontal bar. horizontal is .
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('left net', [optional parameters])</big>
| colspan="3" | <big>Area()</big>
|-
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the left face.
|  || valign="top" | Area([optional parameter])


'component name=...': If provided, only components with the given name will be included.
This function is applicable to the Railing object and the Panel subpart.


'component material=...': If provided, only components with the given material will be included.
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
QUANTITY DESCRIPTION:
For Railing: Area of the Railing object measured by Railing Length multiplied by Railing Height. Length is the distance between the outer edges of the first and last post or between the infills, whichever results in the higher value. Extended handrails are excluded. This Length differs from buildingSMART standard which is stored in the Railing objects record field RailingLengthIFC. The height of the railing is measured as the vertical distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the highest subpart of the Railing (Top Rail if available, Frame, Panel or Crossbar Top).


'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
For Panel: Area of the panel (Width x Height).
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('right gross', [optional parameters])</big>
| colspan="3" | <big>Perimeter()</big>
|-
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the right face. All openings are ignored.
|  || valign="top" |  
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('right net', [optional parameters])</big>
| colspan="3" | <big>Length('')</big>
|-
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the right face.
|  || valign="top" | Length([optional parameter])


'component name=...': If provided, only components with the given name will be included.
This function is applicable to the Railing object and the following subparts: Top Rail, Crossbar Top, Crossbar Bottom, Bar Vertical, Bar Horizontal, Frame.


'component material=...': If provided, only components with the given material will be included.
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
QUANTITY DESCRIPTION:
For Railing object: It is the distance between the outer edges of the first and last post or between the infills, whichever results in the higher value. Extended handrails are excluded. This Length differs from buildingSMART standard which is stored in the Railing objects record field RailingLengthIFC and written into Qto_RailingBaseQuantities.Length and BaseQuantities.Length.


'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
For Top Rail: Length of the 3D path object of the top rail including extensions of the Top Rail at beginning or end of the Railing object.


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
For Crossbar Top and Bottom: Length of the crossbar.


'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
For Bar Vertical and Horizontal: Length of the bar.


'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
For Frame: It is the same value as for Width when applied to a Frame.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('openings avert core', [optional parameters])</big>
| colspan="3" | <big>Length('max')</big>
|-
|-
|  || valign="top" | Returns the total length of wall or wall component openings along the side of the footprint that's oriented away from the core component.
|  || valign="top" | Maximum occuring distance between the axes of all instances of a subparts.
Eligible subparts are Wall Bracket, Post and Face Mount.


'component name=...': If provided, only components with the given name will be included.
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.


'component material=...': If provided, only openings in the components with the given material will be included.
QUANTITY DESCRIPTION:
For Wall Bracket: Returns the maximum distance between the axes of all Wall Brackets occuring anywhere in the Railing object.


'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
For Post: Maximum occuring distance between the axes of all posts.


'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
For Face Mount: Maximum Distance between the axes of all Face Mounts.  
 
|-
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('openings center', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea()</big>
|-
|-
|  || valign="top" | Returns the total length of openings along the center line of the footprint of a wall or wall component.
|  || valign="top" | SurfaceArea([optional parameter])


'component name=...': If provided, only components with the given name will be included.
This function is applicable to the following subparts: Top Rail, Wall Bracket, Post, Face Mount, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame, Panel.


'component material=...': If provided, only openings in the components with the given material will be included.
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.


'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
QUANTITY DESCRIPTION:
For Top Rail: Outer surface of the top rail on all sides including the two caps at beginning and end.


'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
For Wall Bracket: Complete outer surface of the Top Rails Wall Bracket.


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
For Post: Complete Outer Surface of the Post including the sides which face the stair or wall or handrail.


'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
For Face Mount: Complete Outer Surface of the Face Mount Post including the caps surfaces which are mounted against a wall, post, stair or other object.


'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
For Crossbar Top and Bottom: Complete Surface of all sides of the crossbar.
|-
|  ||
|-
| colspan="3" | <big>Length('openings facing core', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of wall or wall component openings along the side of the footprint that's oriented towards the core component.


'component name=...': If provided, only components with the given name will be included.
Bar Vertical and Horizontal: Complete Surface of all sides of the bar.


'component material=...': If provided, only openings in the components with the given material will be included.
For Frame: Complete Surface of the rectangular frame.


'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
For Panel: Complete surface area of all sides of the panel.
|-
|  ||
|}


'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
== Specialized for Roof ==


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
{| border=0
 
| colspan="3" | <big>ObjectData('Component Name')</big>
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
 
| style="width: 10pt;" |  || valign="top" | Returns the name of the wall, slab or roof component.
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
| style="width: 10pt;" |  ||  
|-
|-
| colspan="3" | <big>Length('openings left', [optional parameters])</big>
| colspan="3" | <big>ObjectData('Cost Index Code')</big>
|-
|-
|  || valign="top" | Returns the total length of openings along the left side of the footprint of a wall or wall component.
|  || valign="top" |  
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Length('openings right', [optional parameters])</big>
| colspan="3" | <big>ObjectData('Cost Index System')</big>
|-
|-
|  || valign="top" | Returns the total length of openings along the right side of the footprint of a wall or wall component.
|  || valign="top" |  
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>SurfaceArea('avert core gross', [optional parameters])</big>
| colspan="3" | <big>ObjectData('Description')</big>
|-
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented away from the core component. All openings are ignored.
|  || valign="top" |  
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>SurfaceArea('avert core net', [optional parameters])</big>
| colspan="3" | <big>ObjectData('Exterior')</big>
|-
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented away from the core component.
|  || valign="top" |  
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>SurfaceArea('center gross', [optional parameters])</big>
| colspan="3" | <big>ObjectData('Fire Rating')</big>
|-
|  || valign="top" |
|-
|-
|  || valign="top" | Returns the area along the center line of a wall or wall component. All openings are ignored.
|  ||  
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('center gross') returns the gross area along the center line of the wall or wall component.
| colspan="3" | <big>ObjectData('Function')</big>
 
=SurfaceArea('center gross', 'component=core') returns the gross area along the center line of the core component of the wall.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('center net', [optional parameters])</big>
| || valign="top" |  
|-
|-
|  || valign="top" | Returns the area along the center line of a wall or wall component.
|  ||  
 
|-
'component name=...': If provided, only components with the given name will be included.
| colspan="3" | <big>ObjectData('Lambda')</big>
 
|-
'component material=...': If provided, only components with the given material will be included.
|  || valign="top" | Returns the Lambda value of the object.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('center net') returns the area along the center line of the wall or wall component.
|  ||  
 
=SurfaceArea('center net', 'min opening area=0.5 sq m') returns the area along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('center net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('center net', 'opening type=Window') returns the area along the center line of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=SurfaceArea('center net', 'exclude opening type=Window') returns the area along the center line of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
 
=SurfaceArea('center net', 'opening type=Window;WinDoor 6.0') returns the area along the center line of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
 
=SurfaceArea('center net', 'component=core') returns the area along the center line of the core component of the wall.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('facing core gross', [optional parameters])</big>
| colspan="3" | <big>ObjectData('Manufacturer')</big>
|-
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented towards the core component. All openings are ignored.
|  || valign="top" |  
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>SurfaceArea('facing core net', [optional parameters])</big>
| colspan="3" | <big>ObjectData('Mark')</big>
|-
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented towards the core component.
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Model')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('RValue')</big>
|-
|  || valign="top" | Returns the R-Value of the object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('UValue')</big>
|-
|  || valign="top" | Returns the U-Value of the object.
|-
|  ||
|-
| colspan="3" | <big>RoofArea_Total()</big>
|-
|  || valign="top" | Returns the total area along the slope of a roof.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=RoofArea_Total returns the total area for each roof and roof face object in the database
 
Spreadsheet cell:
=RoofArea_Total(st=roofface) returns the combined total area of all roof face objects in the drawing</pre>
|-
| colspan="3" | <big>RoofArea_Heated()</big>
|-
|  || valign="top" | Returns the heated area along the slope of a roof.
The heated area is the area that does not include an overhang.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=RoofArea_Heated returns the heated area for each roof and roof face object in the database
 
Spreadsheet cell:
=RoofArea_Heated (st=roofface) returns the combined heated area of all roof face objects in the drawing
</pre>
|-
| colspan="3" | <big>RoofArea_TotalProj()</big>
|-
|  || valign="top" | Returns the total area of a roof projected on the active layer plane.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=RoofArea_TotalProj returns the total area for each roof and roof face object in the database, as projected to the layer plane
 
Spreadsheet cell:
=RoofArea_Totalproj(t=roof) returns the combined total area of all roof objects in the drawing, as projected to the layer plane
</pre>
|-
| colspan="3" | <big>RoofArea_HeatedProj()</big>
|-
|  || valign="top" | Returns the heated area of a roof projected on the active layer plane.
The heated area is the area that does not include an overhang.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=RoofArea_HeatedProj returns the heated area for each roof and roof face object in the database, as projected to the layer plane
 
Spreadsheet cell:
=RoofArea_HeatedProj (t=roof) returns the combined heated area of all roof objects in the drawing, as projected to the layer plane
</pre>
|-
| colspan="3" | <big>RoofStyleName()</big>
|-
|  || valign="top" | Returns the name the roof style used by the object.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=RoofStyleName returns the roof style name for each roof object in the database
 
Spreadsheet cell:
=RoofStyleName(n='roof-1') returns the roof style name for the object named “roof-1”
</pre>
|}
 
== Specialized for Site Model ==
 
{| border=0
| colspan="3" | <big>Depth()</big>
|-
| style="width: 10pt;" |  || valign="top" | Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>ProjectedArea()</big>
|-
|  || valign="top" | Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('component name')</big>
|-
|  || valign="top" | Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
|-
|  ||
|-
| colspan="3" | <big>Area()</big>
|-
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea()</big>
|-
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea( 'existing' )</big>
|-
|  || valign="top" | Calculate the existing surface area of the Site Model and their components.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=SURFACEAREA('Existing')    Returns the existing Surface Area for Site Model object or component in the DB row.
 
Spreadsheet cell:
=SURFACEAREA(SEL, 'Existing')    Returns the existing Surface Area for the selected Site Model object.
</pre>
|-
| colspan="3" | <big>SurfaceArea( 'proposed' )</big>
|-
|  || valign="top" | Calculate the proposed surface area of the Site Model and their components.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=SURFACEAREA('Proposed')    Returns the proposed Surface Area for Site Model object or component in the DB row.
 
Spreadsheet cell:
=SURFACEAREA(SEL, 'Proposed')    Returns the proposed Surface Area for the selected Site Model object.
</pre>
|-
| colspan="3" | <big>Volume()</big>
|-
|  || valign="top" | Calculate the volume of the Curb, Landscape Area, Hardscape, or Site Model and their components.
|-
|  ||
|-
| colspan="3" | <big>Volume('existing')</big>
|-
|  || valign="top" | Calculate the existing volume of the Site Model and their components.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('existing')    Returns the existing volume for Site Model object or component in the DB row.
 
Spreadsheet cell:
=VOLUME(SEL, 'existing')    Returns the existing volume for the selected Site Model object.
</pre>
|-
| colspan="3" | <big>Volume('proposed')</big>
|-
|  || valign="top" | Calculate the proposed volume of the Site Model and their components.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('proposed')    Returns the proposed volume for Site Model object or component in the DB row.
 
Spreadsheet cell:
=VOLUME(SEL, 'proposed')    Returns the proposed volume for the selected Site Model object.
</pre>
|}
 
== Specialized for Slab ==
 
{| border=0
| colspan="3" | <big>Weight('gross', [optional parameters])</big>
|-
| style="width: 10pt;" |  || valign="top" | Returns the weight of a wall, wall component, slab or slab component. All openings are ignored.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>Weight('net', [optional parameters])</big>
|-
|  || valign="top" | Returns the weight of a wall, wall component, slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Acoustic Rating')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Combustible Construction')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Compartmentation')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Component Name')</big>
|-
|  || valign="top" | Returns the name of the wall, slab or roof component.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Cost Index Code')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Cost Index System')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Description')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Exterior')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Fire Rating')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Function')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Lambda')</big>
|-
|  || valign="top" | Returns the Lambda value of the object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Load Bearing')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Manufacturer')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Mark')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Model')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('RValue')</big>
|-
|  || valign="top" | Returns the R-Value of the object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('UValue')</big>
|-
|  || valign="top" | Returns the U-Value of the object.
|-
|  ||
|-
| colspan="3" | <big>Width()</big>
|-
|  || valign="top" | Returns the thickness of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Count('modifiers', [optional parameters])</big>
|-
|  || valign="top" | Returns the number of modifiers in a slab or wall. For walls, recesses and projections are counted. For slabs, additions, subtractions and drains are counted.
 
'modifier type=...': If provided, only modifiers with any of the given types are counted. Multiple types can be delimited by a semicolon.
 
'exclude modifier type=...': If provided, modifiers with any of the given types will not be counted.
|-
|  ||
|-
| colspan="3" | <big>Count('openings', [optional parameters])</big>
|-
|  || valign="top" | Returns the number of openings in a wall, wall component, slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only openings in the components with the given material will be counted.
 
'component=...': If provided, only openings in the given components will be counted. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
opening criteria: If provided, only openings that satisfy all given criteria will be counted. If the values don't have any units specified, millimeters, square millimeters or cubic millimeters will be assumed. For slabs, the following criteria are available: min opening area top, max opening area top, min opening area bottom, max opening area bottom, min opening volume, max opening volume, min opening perimeter top, max opening perimeter top, min opening perimeter bottom, max opening perimeter bottom. For walls, the following criteria are available: min opening area left, max opening area left, min opening area right, max opening area right, min opening area facing core, max opening area facing core, min opening area avert core, max opening area avert core, min opening area center, max opening area center, min opening area footprint, max opening area footprint, min opening length footprint left, max opening length footprint left, min opening length footprint right, max opening length footprint right, min opening length footprint facing core, max opening length footprint facing core, min opening length footprint avert core, max opening length footprint avert core, min opening length footprint center, max opening length footprint center, min opening volume, max opening volume.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
 
'height=...': Specifies the height relative to the layer plane at which the footprint area and length along footprint criteria are measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Count('openings') returns the number of openings in the wall, wall component, slab or slab component.
 
=Count('openings', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters.
 
=Count('openings', 'min opening area top=0.5 sq m', 'max opening area top=1 sq m') returns the number of openings with an area between 0.5 and 1 square meter on the top of the slab or slab component.
 
=Count('openings', 'min opening area bottom=1 sq ft', 'max opening volume=10 cu in') returns the number of openings with an area of at least 1 square foot on the bottom of the slab or slab component and a volume of at most 10 cubic inches.
 
=Count('openings', 'opening type=Window') returns the number of openings created by "Window" plug-in objects.
 
=Count('openings', 'opening type=Window;WinDoor 6.0') returns the number of openings created by "Window" and "WinDoor 6.0" plug-in objects.
 
=Count('openings', 'component=core', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters in the wall core component.
 
The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.</pre>
|-
| colspan="3" | <big>Angle('energos')</big>
|-
|  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|-
|  ||
|-
| colspan="3" | <big>SlabThickness()</big>
|-
|  || valign="top" | Returns the thickness of slab objects.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=SlabThickness returns the thickness for each object in the database
 
Spreadsheet cell:
=SlabThickness(PON=slab) returns the combined thickness of all slab objects in the drawing
</pre>
|-
| colspan="3" | <big>SlabStyleName()</big>
|-
|  || valign="top" | Returns the name of the slab style used by the slab.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=SlabStyleName returns the name of the slab style for each slab object in the database
 
Spreadsheet cell:
=SlabStyleName(n='slab-1') returns the name of the slab style for the object named “slab-1”
</pre>
|-
| colspan="3" | <big>Area()</big>
|-
|  || valign="top" | Returns the area of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Perim('bottom', [optional parameters])</big>
|-
|  || valign="top" | Returns the perimeter of the bottom surface of a slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Perim('openings bottom', [optional parameters])</big>
|-
|  || valign="top" | Returns the sum of the opening perimeters on the bottom surface of a slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening perimeter=...' / 'max opening perimeter=...': If provided, only openings with a perimeter of at least min opening perimeter and at most max opening perimeter will be included. If the values don't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Perim('openings top', [optional parameters])</big>
|-
|  || valign="top" | Returns the sum of the opening perimeters on the top surface of a slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening perimeter=...' / 'max opening perimeter=...': If provided, only openings with a perimeter of at least min opening perimeter and at most max opening perimeter will be included. If the values don't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Perim('top', [optional parameters])</big>
|-
|  || valign="top" | Returns the perimeter of the top surface of a slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('bottom gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the bottom surface of a slab or slab component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('bottom gross') returns the gross area of the bottom face of the slab or slab component.
 
=SurfaceArea('bottom gross', 'component=top') returns the gross area of the bottom face of the top component of the slab.</pre>
|-
| colspan="3" | <big>SurfaceArea('bottom net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the bottom surface of a slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('bottom net') returns the area of the bottom face of the slab or slab component.
 
=SurfaceArea('bottom net', 'min opening area=0.5 sq m') returns the area of the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('bottom net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('bottom net', 'component=top') returns the area of the bottom face of the top component of the slab.</pre>
|-
| colspan="3" | <big>SurfaceArea('openings bottom', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings on the bottom surface of a slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings bottom') returns the total area of openings on the bottom face of the slab or slab component.
 
=SurfaceArea('openings bottom', 'min opening area=0.5 sq m') returns the total area of openings on the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('openings bottom', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('openings bottom', 'component=top') returns the total area of openings on the bottom face of the top component of the slab.</pre>
|-
| colspan="3" | <big>SurfaceArea('openings top', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings on the top surface of a slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings top') returns the total area of openings on the top face of the slab or slab component.
 
=SurfaceArea('openings top', 'min opening area=0.5 sq m') returns the total area of openings on the top face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('openings top', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the top face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('openings top', 'component=bottom') returns the total area of openings on the top face of the bottom component of the slab.</pre>
|-
| colspan="3" | <big>SurfaceArea('top gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the top surface of a slab or slab component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('top gross') returns the gross area of the top face of the slab or slab component.
 
=SurfaceArea('top gross', 'component=bottom') returns the gross area of the top face of the bottom component of the slab.</pre>
|-
| colspan="3" | <big>SurfaceArea('top net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the top surface of a slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('top net') returns the area of the top face of the slab or slab component.
 
=SurfaceArea('top net', 'min opening area=0.5 sq m') returns the area of the top face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('top net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the top face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('top net', 'component=bottom') returns the area of the top face of the bottom component of the slab.</pre>
|-
| colspan="3" | <big>Volume()</big>
|-
|  || valign="top" | Returns the volume of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Volume('gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('gross') returns the gross volume of the wall, wall component, slab or slab component.
 
=Volume('gross', 'component=core') returns the gross volume of the core wall component.</pre>
|-
| colspan="3" | <big>Volume('net', [optional parameters])</big>
|-
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('net') returns the volume of the wall, wall component, slab or slab component.
 
=Volume('net', 'min opening volume=10 cu cm') returns the volume of the wall, wall component, slab or slab component, but only taking openings with at least 10 cubic centimeters of volume into account.
 
=Volume('net', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the volume of the wall, wall component, slab or slab component, but only taking openings with between 10 cubic centimeters and 1 cubic meter of volume into account.
 
=Volume('net', 'opening type=Window') returns the volume of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=Volume('net', 'opening type=Window;WinDoor 6.0') returns the volume of the wall or wall component, but only taking openings created by "Window" and "WinDoor 6.0" plug-in objects into account.
 
=Volume('net', 'component=core', 'min opening volume=10 cu cm') returns the volume of the core wall component, but only taking openings with a volume of at least 10 cubic centimeters into account.</pre>
|-
| colspan="3" | <big>Volume('openings', [optional parameters])</big>
|-
|  || valign="top" | Returns the volume of the openings in a wall, wall component, slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('openings') returns the total volume of openings in the wall, wall component, slab or slab component.
 
=Volume('openings', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters.
 
=Volume('openings', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the total volume of openings with a volume of at least 10 cubic centimeters and at most 1 cubic meter.
 
=Volume('openings', 'opening type=Window') returns the total volume of openings created by "Window" plug-in objects.
 
=Volume('openings', 'opening type=Window;WinDoor 6.0') returns the total volume of openings created by "Window" and "WinDoor 6.0" plug-in objects.
 
=Volume('openings', 'component=core', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters in the wall core component.</pre>
|}
 
== Specialized for Socket ==
 
{| border=0
| colspan="3" | <big>ObjectData('eval socket circuits', '<RecordName>', '<FieldName>')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get parameter values or attached record fields from the socket's connected circuits.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>ObjectData('eval socket device', '<RecordName>', '<FieldName>')</big>
|-
|  || valign="top" | Get parameter value or attached record field from the socket's device.
|-
|  ||
|}
 
== Specialized for Space ==
 
{| border=0
| colspan="3" | <big>ObjectData('finish', field_name, [delimiter], [location], [wall_index])</big>
|-
| style="width: 10pt;" |  || valign="top" | Returns the value of the field named 'field_name' in a Space_Finish record.
 
The function is applicable to the Space object and any of its subobjects that have a Space_FinishSurface or Space_Finish record attached to them. In the latter case, the function will just return the value of the record field. In the former two cases, the function will list the Space_Finish record field values for all subobjects that fit the given 'location' and 'wall index' criteria, separated by the given 'delimiter'.
 
'delimiter': Could be any string. Will be added between each of the returned values. Use '\n' to have each value on a separate line. By default, the values will be comma-separated.
 
'location': Could be 'floor', 'base', 'walls', 'ceiling', 'north', 'east', 'south' or 'west'. If this parameter is provided, only finishes with the given location will be listed.
 
'wall_index': The index of a wall, whose value should be listed. Only applicable if 'walls' is used for the 'location' parameter. If not provided, all wall values will be listed.
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">In a database header, for each Space object.
=ObjectData('finish', 'FinishKey', ', ') - Lists the finish key of all finishes used in a space, separated by a comma.
=ObjectData('finish', 'FinishKey', '\n') - Lists the finish key of all finishes used in a space, each on a new line.
=ObjectData('finish', 'FinishKey', ', ', 'floor') - Lists the finish key of all finishes used for the floors in a space.
=ObjectData('finish', 'FinishKey', ', ', 'walls') - Lists the finish key of all finishes used for the walls in a space.
=ObjectData('finish', 'FinishKey', ', ', 'walls', 1) - Lists the finish key of all finishes used for the first wall in a space.
=ObjectData('finish', 'FinishKey', ', ', 'walls', 2) - Lists the finish key of all finishes used for the second wall in a space.
 
In a database header, for each Space subpart, where Space_Finish is present.
=ObjectData('finish', 'FinishKey') - Equivalent to ='Space_Finish'.'FinishKey'
=ObjectData('finish', 'FinishKey', '', 'ceiling') - Returns the key of the finish, only if the finish is applied to the ceiling.
=ObjectData('finish', 'FinishKey', '', 'walls', 1) - Returns the key of the finish, only if the finish is applied to the first wall.
</pre>
|-
| colspan="3" | <big>GetSpaceNameForObj()</big>
|-
|  || valign="top" | Returns the name of the space that surrounds the object.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=GetSpaceNameForObj returns the space name for each object in the database
 
Spreadsheet cell:
=GetSpaceNameForObj(n='chair-1') returns the space name for the object named “chair-1”
</pre>
|-
| colspan="3" | <big>GetSpaceNumForObj()</big>
|-
|  || valign="top" | Returns the number of the space that surrounds the object.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=GetSpaceNumForObj returns the space number for each object in the database
 
Spreadsheet cell:
=GetSpaceNumForObj(n='chair-1') returns the space number for the object named “chair-1”</pre>
|}
 
== Specialized for Structural Member ==
 
{| border=0
| colspan="3" | <big>ObjectData(criteria, 'cover bound bottom')</big>
|-
| style="width: 10pt;" |  || valign="top" | Returns the bottom bound of the structural member cover.
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('cover bound bottom')    Returns the bottom bound of the Structural Member cover.
 
Spreadsheet cell:
=OBJECTDATA(SEL, 'cover bound bottom')    Returns the bottom bound of the Structural Member cover.
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'cover bound top')</big>
|-
|  || valign="top" | Returns the top bound of the Structural Member cover.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('cover bound top')    Returns the top bound of the Structural Member cover.
 
Spreadsheet cell:
=OBJECTDATA(SEL, 'cover bound top')    Returns the top bound of the Structural Member cover.
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'cover physical length')</big>
|-
|  || valign="top" | Returns the physical length of the structural member cover including its start and end conditions.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('cover physical length')    Returns the physical length of the structural member cover including its start and end conditions.
 
Spreadsheet cell:
=OBJECTDATA(SEL, 'cover physical length')    Returns the physical length of the structural member cover including its start and end conditions.
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'member bound bottom')</big>
|-
|  || valign="top" | Returns the bottom bound of the Structural Member.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('member bound bottom')    Returns the bottom bound of the Structural Member.
 
Spreadsheet cell:
=OBJECTDATA(SEL, 'member bound bottom')    Returns the bottom bound of the Structural Member.
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'member bound top')</big>
|-
|  || valign="top" | Returns the top bound of the Structural Member.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('member bound top')    Returns the top bound of the Structural Member.
 
Spreadsheet cell:
=OBJECTDATA(SEL, 'member bound top')    Returns the top bound of the Structural Member.
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'member physical length')</big>
|-
|  || valign="top" | Returns the physical length of the structural member including its start and end conditions.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('member physical length')    Returns the physical length of the structural member including its start and end conditions.
 
Spreadsheet cell:
=OBJECTDATA(SEL, 'member physical length')    Returns the physical length of the structural member including its start and end conditions.
</pre>
|}
 
== Specialized for Wall ==
 
{| border=0
| colspan="3" | <big>Weight('gross', [optional parameters])</big>
|-
| style="width: 10pt;" |  || valign="top" | Returns the weight of a wall, wall component, slab or slab component. All openings are ignored.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>Weight('net', [optional parameters])</big>
|-
|  || valign="top" | Returns the weight of a wall, wall component, slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>FootPrintArea('gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the footprint area of a wall or wall component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>FootPrintArea('net', [optional parameters])</big>
|-
|  || valign="top" | Returns the footprint area of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>FootPrintArea('openings', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings in the footprint of a wall or wall component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Acoustic Rating')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Combustible Construction')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Compartmentation')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Component Name')</big>
|-
|  || valign="top" | Returns the name of the wall, slab or roof component.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Cost Index Code')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Cost Index System')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Description')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Exterior')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Fire Rating')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Function')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Lambda')</big>
|-
|  || valign="top" | Returns the Lambda value of the object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Load Bearing')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Manufacturer')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Mark')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Model')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Path Type')</big>
|-
|  || valign="top" | Returns the path type of a wall. 0 is line, and 1 is arc.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('RValue')</big>
|-
|  || valign="top" | Returns the R-Value of the object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('UValue')</big>
|-
|  || valign="top" | Returns the U-Value of the object.
|-
|  ||
|-
| colspan="3" | <big>Width()</big>
|-
|  || valign="top" | Returns the thickness of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Height('average')</big>
|-
|  || valign="top" | Returns the average height of a wall, including wall peaks and different starting and ending heights.
|-
|  ||
|-
| colspan="3" | <big>Height('overall')</big>
|-
|  || valign="top" | Returns the overall height of a wall.
|-
|  ||
|-
| colspan="3" | <big>Count('inserts', [optional parameters])</big>
|-
|  || valign="top" | Returns the number of inserts (symbols and parametric objects) in a wall.
 
'insert type=...': If provided, only inserts with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude insert type=...': If provided, inserts with any of the given types will not be counted.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Count('inserts') returns the number of inserts in the wall object.
 
=Count('inserts', 'insert type=Window') returns the number of "Window" plug-in object inserts.
 
=Count('inserts', 'insert type=Window;WinDoor 6.0') returns the number of by "Window" and "WinDoor 6.0" plug-in object inserts.
 
The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.</pre>
|-
| colspan="3" | <big>Count('modifiers', [optional parameters])</big>
|-
|  || valign="top" | Returns the number of modifiers in a slab or wall. For walls, recesses and projections are counted. For slabs, additions, subtractions and drains are counted.
 
'modifier type=...': If provided, only modifiers with any of the given types are counted. Multiple types can be delimited by a semicolon.
 
'exclude modifier type=...': If provided, modifiers with any of the given types will not be counted.
|-
|  ||
|-
| colspan="3" | <big>Count('openings', [optional parameters])</big>
|-
|  || valign="top" | Returns the number of openings in a wall, wall component, slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only openings in the components with the given material will be counted.
 
'component=...': If provided, only openings in the given components will be counted. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
opening criteria: If provided, only openings that satisfy all given criteria will be counted. If the values don't have any units specified, millimeters, square millimeters or cubic millimeters will be assumed. For slabs, the following criteria are available: min opening area top, max opening area top, min opening area bottom, max opening area bottom, min opening volume, max opening volume, min opening perimeter top, max opening perimeter top, min opening perimeter bottom, max opening perimeter bottom. For walls, the following criteria are available: min opening area left, max opening area left, min opening area right, max opening area right, min opening area facing core, max opening area facing core, min opening area avert core, max opening area avert core, min opening area center, max opening area center, min opening area footprint, max opening area footprint, min opening length footprint left, max opening length footprint left, min opening length footprint right, max opening length footprint right, min opening length footprint facing core, max opening length footprint facing core, min opening length footprint avert core, max opening length footprint avert core, min opening length footprint center, max opening length footprint center, min opening volume, max opening volume.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
 
'height=...': Specifies the height relative to the layer plane at which the footprint area and length along footprint criteria are measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Count('openings') returns the number of openings in the wall, wall component, slab or slab component.
 
=Count('openings', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters.
 
=Count('openings', 'min opening area top=0.5 sq m', 'max opening area top=1 sq m') returns the number of openings with an area between 0.5 and 1 square meter on the top of the slab or slab component.
 
=Count('openings', 'min opening area bottom=1 sq ft', 'max opening volume=10 cu in') returns the number of openings with an area of at least 1 square foot on the bottom of the slab or slab component and a volume of at most 10 cubic inches.
 
=Count('openings', 'opening type=Window') returns the number of openings created by "Window" plug-in objects.
 
=Count('openings', 'opening type=Window;WinDoor 6.0') returns the number of openings created by "Window" and "WinDoor 6.0" plug-in objects.
 
=Count('openings', 'component=core', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters in the wall core component.
 
The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.</pre>
|-
| colspan="3" | <big>Angle('energos')</big>
|-
|  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|-
|  ||
|-
| colspan="3" | <big>WallArea_Net()</big>
|-
|  || valign="top" | Returns the average of the net area of the interior and exterior face of the wall. The net area is adjusted for holes in the wall.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallArea_Net returns the average of the net area of the interior and exterior face of the wall, for each wall in the database; the net area is adjusted for holes in the wall
 
Spreadsheet cell:
=WallArea_Net(t=wall) returns the average of the net area of the interior and exterior face of the wall, combined for all walls in the drawing; the net area is adjusted for holes in the wall
</pre>
|-
| colspan="3" | <big>WallArea_Gross()</big>
|-
|  || valign="top" | Returns the average of the gross area of the interior and exterior face of the wall. The gross area ignores holes in the wall.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallArea_Gross returns the average of the gross area of the interior and exterior face of the wall, for each wall in the database; the gross area ignores holes in the wall
 
Spreadsheet cell:
=WallArea_Gross(t=wall) returns the average of the gross area of the interior and exterior face of the wall, combined for all walls in the drawing; the gross area ignores holes in the wall
</pre>
|-
| colspan="3" | <big>WallAverageHeight()</big>
|-
|  || valign="top" | Returns the average wall height of a wall, including wall peaks and different starting and ending heights.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallAverageHeight returns the average height for each wall object in the database
 
Spreadsheet cell:
=WallAverageHeight((t=wall)&(sel=true)) returns the average height of all walls that are selected in the drawing
</pre>
|-
| colspan="3" | <big>WallThickness()</big>
|-
|  || valign="top" | Returns the thickness of the wall.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallThickness returns the thickness for each wall object in the database
 
Spreadsheet cell:
=WallThickness(t=wall) returns the combined thickness of all walls in the drawing
</pre>
|-
| colspan="3" | <big>WallStyleName()</big>
|-
|  || valign="top" | Returns the name of the wall style used by the wall.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallStyleName returns the name of the wall style for each wall object in the database
 
Spreadsheet cell:
=WallStyleName(n='wall-1') returns the name of the wall style for the object named “wall-1”
</pre>
|-
| colspan="3" | <big>Area()</big>
|-
|  || valign="top" | Returns the area of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Length()</big>
|-
|  || valign="top" | Returns the length of a wall or its components.
|-
|  ||
|-
| colspan="3" | <big>Length('control line avert core', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of the control line of a wall component on the side that's oriented away from the core component. All openings, recesses, projections and peaks are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Length('control line center', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of the central control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Length('control line facing core', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of the control line of a wall component on the side that's oriented towards the core component. All openings, recesses, projections and peaks are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Length('control line left', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of the left control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Length('control line right', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of the right control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Length('avert core gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented away from the core component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('avert core net', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented away from the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('center gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the center line. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('center net', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the center line.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('facing core gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented towards the core component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('facing core net', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented towards the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('left gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the left face. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('left net', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the left face.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('right gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the right face. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('right net', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the right face.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('openings avert core', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of wall or wall component openings along the side of the footprint that's oriented away from the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('openings center', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of openings along the center line of the footprint of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('openings facing core', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of wall or wall component openings along the side of the footprint that's oriented towards the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('openings left', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of openings along the left side of the footprint of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('openings right', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of openings along the right side of the footprint of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('avert core gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented away from the core component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('avert core net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented away from the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('center gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area along the center line of a wall or wall component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('center gross') returns the gross area along the center line of the wall or wall component.
 
=SurfaceArea('center gross', 'component=core') returns the gross area along the center line of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('center net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area along the center line of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('center net') returns the area along the center line of the wall or wall component.
 
=SurfaceArea('center net', 'min opening area=0.5 sq m') returns the area along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('center net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('center net', 'opening type=Window') returns the area along the center line of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=SurfaceArea('center net', 'exclude opening type=Window') returns the area along the center line of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
 
=SurfaceArea('center net', 'opening type=Window;WinDoor 6.0') returns the area along the center line of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
 
=SurfaceArea('center net', 'component=core') returns the area along the center line of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('facing core gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented towards the core component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('facing core net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented towards the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('left gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the left surface of a wall or wall component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('left gross') returns the gross area of the left side of the wall or wall component.
 
=SurfaceArea('left gross', 'component=core') returns the gross area of the left side of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('left net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the left surface of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'include closures': If provided, the surfaces of splay/wrap faces will be included in the calculation.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('left net') returns the area of the left side of the wall or wall component.
 
=SurfaceArea('left net', 'min opening area=0.5 sq m') returns the area of the left side of the wall or wall component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('left net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the left side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('left net', 'opening type=Window') returns the area of the left side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=SurfaceArea('left net', 'exclude opening type=Window') returns the area of the left side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
 
=SurfaceArea('left net', 'opening type=Window;WinDoor 6.0') returns the area of the left side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
 
=SurfaceArea('left net', 'component=core') returns the area of the left side of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('openings avert core', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings on a wall component's surface that's oriented away from the core component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('openings center', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings along the center line of a wall or wall component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.


'component name=...': If provided, only components with the given name will be included.
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.


'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
Line 3,801: Line 5,515:
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|-
|  ||  
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings center') returns the total area of openings along the center line of the wall or wall component.
|-
 
| colspan="3" | <big>SurfaceArea('left gross', [optional parameters])</big>
=SurfaceArea('openings center', 'min opening area=0.5 sq m') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters.
|-
 
|  || valign="top" | Returns the area of the left surface of a wall or wall component. All openings are ignored.
=SurfaceArea('openings center', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.


'component name=...': If provided, only components with the given name will be included.
=SurfaceArea('openings center', 'opening type=Window') returns the total area of openings along the center line of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.


'component material=...': If provided, only components with the given material will be included.
=SurfaceArea('openings center', 'exclude opening type=Window') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
=SurfaceArea('openings center', 'opening type=Window;WinDoor 6.0') returns the total area of openings along the center line of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('left gross') returns the gross area of the left side of the wall or wall component.


=SurfaceArea('left gross', 'component=core') returns the gross area of the left side of the core component of the wall.</pre>
=SurfaceArea('openings center', 'component=core') returns the total area of openings along the center line of the core component of the wall.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('left net', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea('openings facing core', [optional parameters])</big>
|-
|-
|  || valign="top" | Returns the area of the left surface of a wall or wall component.
|  || valign="top" | Returns the area of the openings on a wall component's surface that's oriented towards the core component.


'component name=...': If provided, only components with the given name will be included.
'component name=...': If provided, only openings in the components with the given name will be included.


'component material=...': If provided, only components with the given material will be included.
'component material=...': If provided, only openings in the components with the given material will be included.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.


'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
Line 3,833: Line 5,545:
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('left net') returns the area of the left side of the wall or wall component.
|  ||  
|-
| colspan="3" | <big>SurfaceArea('openings left', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings on the left surface of a wall or wall component.


=SurfaceArea('left net', 'min opening area=0.5 sq m') returns the area of the left side of the wall or wall component, but ignoring any openings under 0.5 square meters.
'component name=...': If provided, only openings in the components with the given name will be included.


=SurfaceArea('left net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the left side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
'component material=...': If provided, only openings in the components with the given material will be included.


=SurfaceArea('left net', 'opening type=Window') returns the area of the left side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.


=SurfaceArea('left net', 'exclude opening type=Window') returns the area of the left side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.


=SurfaceArea('left net', 'opening type=Window;WinDoor 6.0') returns the area of the left side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.


=SurfaceArea('left net', 'component=core') returns the area of the left side of the core component of the wall.</pre>
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|-
| colspan="3" | <big>SurfaceArea('openings avert core', [optional parameters])</big>
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings left') returns the total area of openings on the left side of the wall or wall component.
|-
|  || valign="top" | Returns the area of the openings on a wall component's surface that's oriented away from the core component.


'component name=...': If provided, only openings in the components with the given name will be included.
=SurfaceArea('openings left', 'min opening area=0.5 sq m') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings under 0.5 square meters.


'component material=...': If provided, only openings in the components with the given material will be included.
=SurfaceArea('openings left', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.


'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
=SurfaceArea('openings left', 'opening type=Window') returns the total area of openings on the left side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.


'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
=SurfaceArea('openings left', 'exclude opening type=Window') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
=SurfaceArea('openings left', 'opening type=Window;WinDoor 6.0') returns the total area of openings on the left side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.


'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
=SurfaceArea('openings left', 'component=core') returns the total area of openings on the left side of the core component of the wall.</pre>
|-
|-
| ||  
| colspan="3" | <big>SurfaceArea('openings right', [optional parameters])</big>
|-
|-
| colspan="3" | <big>SurfaceArea('openings center', [optional parameters])</big>
|  || valign="top" | Returns the area of the openings on the right surface of a wall or wall component.
|-
|  || valign="top" | Returns the area of the openings along the center line of a wall or wall component.


'component name=...': If provided, only openings in the components with the given name will be included.
'component name=...': If provided, only openings in the components with the given name will be included.
Line 3,881: Line 5,593:
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings center') returns the total area of openings along the center line of the wall or wall component.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings right') returns the total area of openings on the right side of the wall or wall component.


=SurfaceArea('openings center', 'min opening area=0.5 sq m') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters.
=SurfaceArea('openings right', 'min opening area=0.5 sq m') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings under 0.5 square meters.


=SurfaceArea('openings center', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
=SurfaceArea('openings right', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.


=SurfaceArea('openings center', 'opening type=Window') returns the total area of openings along the center line of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
=SurfaceArea('openings right', 'opening type=Window') returns the total area of openings on the right side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.


=SurfaceArea('openings center', 'exclude opening type=Window') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
=SurfaceArea('openings right', 'exclude opening type=Window') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.


=SurfaceArea('openings center', 'opening type=Window;WinDoor 6.0') returns the total area of openings along the center line of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
=SurfaceArea('openings right', 'opening type=Window;WinDoor 6.0') returns the total area of openings on the right side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.


=SurfaceArea('openings center', 'component=core') returns the total area of openings along the center line of the core component of the wall.</pre>
=SurfaceArea('openings right', 'component=core') returns the total area of openings on the right side of the core component of the wall.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('openings facing core', [optional parameters])</big>
| colspan="3" | <big>SurfaceArea('right gross', [optional parameters])</big>
|-
|-
|  || valign="top" | Returns the area of the openings on a wall component's surface that's oriented towards the core component.
|  || valign="top" | Returns the area of the right surface of a wall or wall component. All openings are ignored.


'component name=...': If provided, only openings in the components with the given name will be included.
'component name=...': If provided, only components with the given name will be included.


'component material=...': If provided, only openings in the components with the given material will be included.
'component material=...': If provided, only components with the given material will be included.


'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.


'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('right gross') returns the gross area of the right side of the wall or wall component.


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
=SurfaceArea('right gross', 'component=core') returns the gross area of the right side of the core component of the wall.</pre>
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|-
| ||  
| colspan="3" | <big>SurfaceArea('right net', [optional parameters])</big>
|-
|-
| colspan="3" | <big>SurfaceArea('openings left', [optional parameters])</big>
|  || valign="top" | Returns the area of the right surface of a wall or wall component.
|-
 
|  || valign="top" | Returns the area of the openings on the left surface of a wall or wall component.
'component name=...': If provided, components with the given name will be included.


'component name=...': If provided, only openings in the components with the given name will be included.
'component material=...': If provided, only components with the given material will be included.


'component material=...': If provided, only openings in the components with the given material will be included.
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.


'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.


'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
Line 3,928: Line 5,640:


'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
'include closures': If provided, the surfaces of splay/wrap faces will be included in the calculation.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings left') returns the total area of openings on the left side of the wall or wall component.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('right net') returns the area of the right side of the wall or wall component.


=SurfaceArea('openings left', 'min opening area=0.5 sq m') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings under 0.5 square meters.
=SurfaceArea('right net', 'min opening area=0.5 sq m') returns the area of the right side of the wall or wall component, but ignoring any openings under 0.5 square meters.


=SurfaceArea('openings left', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
=SurfaceArea('right net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the right side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.


=SurfaceArea('openings left', 'opening type=Window') returns the total area of openings on the left side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
=SurfaceArea('right net', 'opening type=Window') returns the area of the right side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.


=SurfaceArea('openings left', 'exclude opening type=Window') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
=SurfaceArea('right net', 'exclude opening type=Window') returns the area of the right side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.


=SurfaceArea('openings left', 'opening type=Window;WinDoor 6.0') returns the total area of openings on the left side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
=SurfaceArea('right net', 'opening type=Window;WinDoor 6.0') returns the area of the right side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.


=SurfaceArea('openings left', 'component=core') returns the total area of openings on the left side of the core component of the wall.</pre>
=SurfaceArea('right net', 'component=core') returns the area of the right side of the core component of the wall.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('openings right', [optional parameters])</big>
| colspan="3" | <big>Volume()</big>
|-
|  || valign="top" | Returns the volume of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Volume('gross', [optional parameters])</big>
|-
|-
|  || valign="top" | Returns the area of the openings on the right surface of a wall or wall component.
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component. All openings are ignored.


'component name=...': If provided, only openings in the components with the given name will be included.
'component name=...': If provided, only components with the given name will be included.


'component material=...': If provided, only openings in the components with the given material will be included.
'component material=...': If provided, only components with the given material will be included.


'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings right') returns the total area of openings on the right side of the wall or wall component.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('gross') returns the gross volume of the wall, wall component, slab or slab component.


=SurfaceArea('openings right', 'min opening area=0.5 sq m') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings under 0.5 square meters.
=Volume('gross', 'component=core') returns the gross volume of the core wall component.</pre>
 
=SurfaceArea('openings right', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('openings right', 'opening type=Window') returns the total area of openings on the right side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=SurfaceArea('openings right', 'exclude opening type=Window') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
 
=SurfaceArea('openings right', 'opening type=Window;WinDoor 6.0') returns the total area of openings on the right side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
 
=SurfaceArea('openings right', 'component=core') returns the total area of openings on the right side of the core component of the wall.</pre>
|-
|-
| colspan="3" | <big>SurfaceArea('right gross', [optional parameters])</big>
| colspan="3" | <big>Volume('net', [optional parameters])</big>
|-
|-
|  || valign="top" | Returns the area of the right surface of a wall or wall component. All openings are ignored.
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component.


'component name=...': If provided, only components with the given name will be included.
'component name=...': If provided, only components with the given name will be included.
Line 3,981: Line 5,685:
'component material=...': If provided, only components with the given material will be included.
'component material=...': If provided, only components with the given material will be included.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('right gross') returns the gross area of the right side of the wall or wall component.


=SurfaceArea('right gross', 'component=core') returns the gross area of the right side of the core component of the wall.</pre>
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|-
| colspan="3" | <big>SurfaceArea('right net', [optional parameters])</big>
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('net') returns the volume of the wall, wall component, slab or slab component.
|-
|  || valign="top" | Returns the area of the right surface of a wall or wall component.


'component name=...': If provided, components with the given name will be included.
=Volume('net', 'min opening volume=10 cu cm') returns the volume of the wall, wall component, slab or slab component, but only taking openings with at least 10 cubic centimeters of volume into account.


'component material=...': If provided, only components with the given material will be included.
=Volume('net', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the volume of the wall, wall component, slab or slab component, but only taking openings with between 10 cubic centimeters and 1 cubic meter of volume into account.


'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
=Volume('net', 'opening type=Window') returns the volume of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.


'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
=Volume('net', 'opening type=Window;WinDoor 6.0') returns the volume of the wall or wall component, but only taking openings created by "Window" and "WinDoor 6.0" plug-in objects into account.


'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
=Volume('net', 'component=core', 'min opening volume=10 cu cm') returns the volume of the core wall component, but only taking openings with a volume of at least 10 cubic centimeters into account.</pre>
 
|-
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
| colspan="3" | <big>Volume('openings', [optional parameters])</big>
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('right net') returns the area of the right side of the wall or wall component.
|  || valign="top" | Returns the volume of the openings in a wall, wall component, slab or slab component.


=SurfaceArea('right net', 'min opening area=0.5 sq m') returns the area of the right side of the wall or wall component, but ignoring any openings under 0.5 square meters.
'component name=...': If provided, only openings in the components with the given name will be included.


=SurfaceArea('right net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the right side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
'component material=...': If provided, only openings in the components with the given material will be included.


=SurfaceArea('right net', 'opening type=Window') returns the area of the right side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.


=SurfaceArea('right net', 'exclude opening type=Window') returns the area of the right side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.


=SurfaceArea('right net', 'opening type=Window;WinDoor 6.0') returns the area of the right side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.  


=SurfaceArea('right net', 'component=core') returns the area of the right side of the core component of the wall.</pre>
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|-
| colspan="3" | <big>Volume()</big>
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('openings') returns the total volume of openings in the wall, wall component, slab or slab component.
|-
 
|  || valign="top" | Returns the volume of a wall, slab, roof or a roof face object or their components.
=Volume('openings', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters.
 
=Volume('openings', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the total volume of openings with a volume of at least 10 cubic centimeters and at most 1 cubic meter.
 
=Volume('openings', 'opening type=Window') returns the total volume of openings created by "Window" plug-in objects.
 
=Volume('openings', 'opening type=Window;WinDoor 6.0') returns the total volume of openings created by "Window" and "WinDoor 6.0" plug-in objects.
 
=Volume('openings', 'component=core', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters in the wall core component.</pre>
|-
|-
| ||  
| colspan="3" | <big>WallOverallHeight()</big>
|-
|-
| colspan="3" | <big>Volume('gross', [optional parameters])</big>
| || valign="top" | Returns the overall height of walls.
|-
|-
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component. All openings are ignored.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallOverallHeight returns the average overall height for each wall object in the database


'component name=...': If provided, only components with the given name will be included.
Spreadsheet cell:
=WallOverallHeight((t=wall)&(sel=true)) returns the average overall height of all walls that are selected in the drawing
</pre>
|}


'component material=...': If provided, only components with the given material will be included.
== Specialized for WinDoor 6.0 ==


'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
{| border=0
| colspan="3" | <big>Angle('energos')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('gross') returns the gross volume of the wall, wall component, slab or slab component.
| style="width: 10pt;" |  ||
|}
 
== Specialized for Window ==


=Volume('gross', 'component=core') returns the gross volume of the core wall component.</pre>
{| border=0
| colspan="3" | <big>Angle('energos')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>Volume(criteria, 'glazing all')</big>
|-
|-
| colspan="3" | <big>Volume('net', [optional parameters])</big>
| || valign="top" | Returns the total volume of all glazing.
|-
|-
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('glazing all')    Returns the total volume of all glazing.


'component name=...': If provided, only components with the given name will be included.
Spreadsheet cell:
 
=VOLUME(SEL, 'glazing all')   Returns the total volume of all glazing.
'component material=...': If provided, only components with the given material will be included.
</pre>
 
|-
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
| colspan="3" | <big>Volume(criteria, 'glazing for sashes')</big>
 
|-
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
|  || valign="top" | Returns the volume of glazing for all sashes except the transom.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('net') returns the volume of the wall, wall component, slab or slab component.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('glazing for sashes')     Returns the volume of glazing for all sashes except the transom.


=Volume('net', 'min opening volume=10 cu cm') returns the volume of the wall, wall component, slab or slab component, but only taking openings with at least 10 cubic centimeters of volume into account.
Spreadsheet cell:
 
=VOLUME(SEL, 'glazing for sashes')   Returns the volume of glazing for all sashes except the transom.
=Volume('net', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the volume of the wall, wall component, slab or slab component, but only taking openings with between 10 cubic centimeters and 1 cubic meter of volume into account.
</pre>
 
=Volume('net', 'opening type=Window') returns the volume of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=Volume('net', 'opening type=Window;WinDoor 6.0') returns the volume of the wall or wall component, but only taking openings created by "Window" and "WinDoor 6.0" plug-in objects into account.
 
=Volume('net', 'component=core', 'min opening volume=10 cu cm') returns the volume of the core wall component, but only taking openings with a volume of at least 10 cubic centimeters into account.</pre>
|-
|-
| colspan="3" | <big>Volume('openings', [optional parameters])</big>
| colspan="3" | <big>Volume(criteria, 'glazing for transom')</big>
|-
|-
|  || valign="top" | Returns the volume of the openings in a wall, wall component, slab or slab component.
|  || valign="top" | Returns the volume of glazing for the transom.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('openings') returns the total volume of openings in the wall, wall component, slab or slab component.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('glazing for transom')     Returns the volume of glazing for the transom.


=Volume('openings', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters.
Spreadsheet cell:
 
=VOLUME(SEL, 'glazing for transom')   Returns the volume of glazing for the transom.
=Volume('openings', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the total volume of openings with a volume of at least 10 cubic centimeters and at most 1 cubic meter.
</pre>
 
=Volume('openings', 'opening type=Window') returns the total volume of openings created by "Window" plug-in objects.
 
=Volume('openings', 'opening type=Window;WinDoor 6.0') returns the total volume of openings created by "Window" and "WinDoor 6.0" plug-in objects.
 
=Volume('openings', 'component=core', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters in the wall core component.</pre>
|-
|-
| colspan="3" | <big>WallOverallHeight()</big>
| colspan="3" | <big>Volume(criteria, 'window jamb')</big>
|-
|-
|  || valign="top" | Returns the overall height of walls.
|  || valign="top" | Returns the volume of all geometry that makes up the Jamb and Mullions.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallOverallHeight returns the average overall height for each wall object in the database
=VOLUME('window jamb')    Returns the volume of all geometry that makes up the Jamb and Mullions.


Spreadsheet cell:
Spreadsheet cell:
=WallOverallHeight((t=wall)&(sel=true)) returns the average overall height of all walls that are selected in the drawing
=VOLUME(SEL, 'window jamb')   Returns the volume of all geometry that makes up the Jamb and Mullions.
</pre>
</pre>
|}
== Specialized for WinDoor 6.0 ==
{| border=0
| colspan="3" | <big>Angle('energos')</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
| colspan="3" | <big>Volume(criteria, 'window sashes')</big>
|-
|  || valign="top" | Returns the total volume the all sashes (including the transom sash).
|-
|-
| style="width: 10pt;" |  ||
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|}
=VOLUME('window sashes')    Returns the total volume the all sashes (including the transom sash).


== Specialized for Window ==
Spreadsheet cell:
 
,VOLUME(SEL, 'window sashes')   Returns the total volume the all sashes (including the transom sash).
{| border=0
</pre>
| colspan="3" | <big>Angle('energos')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|-
| style="width: 10pt;" |  ||
|}
|}


Line 4,436: Line 6,131:
</pre>
</pre>
|}
|}





Latest revision as of 23:54, 11 September 2024

.Worksheets|Worksheets ..Search Criteria Format|Search Criteria Format ..Worksheet Functions|Worksheet Functions ..Worksheets#Version_Information|Version Information

Disclaimer

All function descriptions below use US notation.

In European notation, the decimal "." should be "," and the separator "," should become ";".

Note: This page is automatically generated. If you see changes that need to be done, please contact devsupport@vectorworks.net.

General

RunScript(scriptPath [, functionName])
Executes a script and returns the result value.
Database header cell:
=RunScript('My Script') executes the VectorScript script named “My Script” and returns a value for each object in the database

Spreadsheet cell:
=RunScript(2, 'ScriptFile.py', 2, 1) executes the Python script “ScriptFile.py” in the Vectorworks Plug-Ins folder, passing the parameters “2” and “1,” and returns a value
FormatField(record_format_name, field_name)
Returns the default value of a given field name of the specified record format.
=FormatField(‘Door’, ‘Width’), where “Door” is the name of a record format, returns the default value for the “Width” field.

RunScriptEdit(scriptPath [, functionName])
Executes a script and returns the result value. The cells are editable and the same script is executed to handle the edit.
Database(criteria)
Creates a database of objects that meet the criteria.
=DATABASE((L='Floor-1')) creates a worksheet database of all objects on layer “Floor-1.”
DatabaseByScript([scriptPath], scriptName, ...params...)
Runs a script to create a database of objects.
=DataBaseByScript('MyScript.py', 2, 1) creates a worksheet database by executing the script named “My Script.py,” passing the parameters “2” and “1” to the script.

Logic

Switch(number, value1, value2, ... value_no_match)
Use value1, or value2, or value3, etc depending on the (number). When no value is available, then use value_no_match.
=switch(3, 10, 20, 30, 40, 50, 60, 'no match') returns 30
IFS((logic1), value1, (logic2), value2, ..., (logicN), valueN))
One of several possible results based on a series of tests. The first value which passes the test is chosen.
=IFS(A4>30, 'yes', A4<=30, 'no') returns 'yes' if the number in the cell A4 is >30. Else, if it is <=30 'no' is returned
=IFS(A4>30, 'yes', A4<30, 'no', TRUE, 'exact') returns 'exact' if the number in the cell A4 is exactly 30, 'yes' when >30, and 'no' when <30

=IFS(COND1; VALUE1; COND2; VALUE2; ELSE; 'ELSE') this example uses ELSE as a string condition, which evaluates to TRUE as it is non-empty string
Exact(value1, value2)
True when the two values are exactly the same. It will perform a case-sensitive comparison if the values are strings.
=exact('text', 'text') returns True, while exact('Text', 'text') will return False.
IsNA(value)
True when the value is N/A.
=IF(IsNA(Angle('energos')), '-', 'has value') On a database row, calculates the Energos angle of the objects, and decides which value to output based on if energos is applicable or not.

Note, you can use IfNA in order to use alternative value only when it's not applicable, the 'Angle' would have to be repeated for the IF function.

IfNA(value, value_when_na)
Use value_when_na when value resolves to N/A, otherwise use the value itself.
=IfNA(Angle('energos'), '-') On a database row, calculates the Energos angle of the objects, and if they are not applicable, would use '-'

FirstNonEmpty(value1, value2, value3, ...)
Use value1 if not empty, otherwise use value2 if not empty, otherwise use value3 if not empty, etc. Empty means: empty string, zero value, or N/A value. N/A will be returned if no match.
=FirstNonEmpty('Format-1'.'data', B1, 'Empty')

Return the value of the data field of the Format-1, if empty return B1, or the string 'Empty' if that is empty too.

IsError(value)
True when the value resolves to an error.
IfError(value, value_when_error)
Use value_when_error when value resolved to an error, otherwise use the value itself.
if((logical_test), value_if_true, value_if_false)
Use value_if_true if logical_test is true, value_is_false if logical_test is false.
=if(('Existing Tree'.'Condition'='Not Set'), '-', 'Existing Tree'.'Condition') If no condition value was set for the existing tree object, the value in this cell is a dash; otherwise, the value in this cell is the condition value that was set for the tree object.

=if(('Existing Tree'.'Condition'='Not Set'), '-', 'Existing Tree'.'Condition')

Lookup

VLookup(value, [use_pattern], result_col_index, not_found_value, table)
Finds a value in the table range, looking at the leftmost column, and returns the value at the result_col_index in that same row. Uses ECMAScript syntax for the pattern: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
=VLookup(value, [use_pattern], result_col_index, not_found_value, table)

Find a value in the table range, looking at the first column, and return the value at the resut_col_index of that row.

Parameters:
  value - the value that will be searched in the first column of 'table'.
  use_pattern - use regular expression pattern for the search.
  result_col_index - the number of the column in 'table' which will return the result_col_index.
  not_found_value - the result if 'value' is not found
  table - a range referencing the data. the first column will be searched, and 'result_col_index' will specify the result.

=VLookup(A3, 2, 'no email', B1..C4)
=VLookup(A3, 2, 'no email', 'Worksheet-1':B1..C4)

This example will search for the value of A3 in column B, and if found it will return the value in the C column, otherwise it will return 'no email'.

If the table is like this, 'tech' will be searched in B column, and it will return 'tech@vectorworks.net'
Note the second example, the table is a range for another worksheet named 'Worksheet-1'

  |    A   |     B     |     C
-------------------------------------------------
1 |        |  support  | support@vectorworks.net
2 |        |  tech     | tech@vectorworks.net
3 |  tech  |  PR       | PR@vectorworks.net

When [use_pattern] is missing or "false", the "value" will be matched exactly when looking up.
When [use_pattern] is "true" then the "value" is expected to be a regular expression that will be used when looking up.
Here is more information of the syntax of the regular rexpressions: https://cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
And here is a web-tool that can help developing and testing regular expressions: https://regexr.com/
XLookup(value, [use_pattern], not_found_value, array_lookup, array_result)
Finds a value in the array_lookup, and returns the value from the array_result at the found row. The arrays should be ranges on the same column. Uses ECMAScript syntax for the pattern: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
=XLookup(value, [use_pattern], not_found_value, array_lookup, array_result)

Find a value in the array_lookup, and return the value from the array_result at the found row. the arrays should be ranges on the same column.

Parameters:
  value - the value that will be searched in 'array_lookup' (a range defined in a single column).
  use_pattern - use regular expression pattern for the search.
  not_found_value - the result if 'value' is not found
  array_lookup - a range defined in a single column to search the 'value' in
  array_result - a range defined in a single column to to provide the result from the row that the 'value' was found in 'array_lookup'

=XLookup('tech', 'not found', 'Worksheet-Values':A1..A3, 'Worksheet-Result':B1..B3)

Named worksheet: 'Worksheet-Values':

  |     A     
--------------
1 |  support
2 |  tech
3 |  PR       

Named worksheet: 'Worksheet-Result':

  |   A    |     B
-----------|-------------------------
1 |  1234  | support@vectorworks.net
2 |  1235  | tech@vectorworks.net
3 |  1236  | PR@vectorworks.net

When [use_pattern] is missing or "false", the "value" will be matched exactly when looking up.
When [use_pattern] is "true" then the "value" is expected to be a regular expression that will be used when looking up.
Here is more information of the syntax of the regular rexpressions: https://cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
And here is a web-tool that can help developing and testing regular expressions: https://regexr.com/

Math

round(number)
Rounds the specified number to the nearest whole number.
=round(2.345) returns 2
sin(number)
Returns the sine of a given angle.
=sin(deg2rad(32)) converts a 32-degree angle to its radian equivalent, and returns the sine of the angle
cos(number)
Returns the cosine of a given angle.
=cos(deg2rad(23)) converts a 23-degree angle to its radian equivalent, and returns the cosine of the angle
exp(number)
Returns e raised to the power of number.
=exp(2) returns the numeric value of e raised to the power of 2
ln(number)
Returns the natural logarithm (base e) of a number.
=ln(12) returns the natural logarithm of 12
sqrt(number)
Returns the square root of a number.
=sqrt(D27) returns the square root of the number in cell D27
atan(number)
Returns the arctangent of a number.
=atan(A3) returns the angle for which the tangent value is given in cell A3
rad2deg(number)
Converts number from radians to degrees.
=rad2deg(0.5235987) converts the radian angle measurement to its degree equivalent
deg2rad(number)
Converts number from degrees to radians.
=deg2rad(47) converts the 47-degree angle measurement to its radian equivalent
asin(number)
Returns the arcsine of a number.
=asin(A3) returns the angle for which the sine value is given in cell A3
acos(number)
Returns the arccosine of a number.
=acos(3/5) returns the angle for which the cosine value is 3/5
rounddown(number, digits)
Rounds the specified number down to a specified number of decimal digits.
=rounddown(2.345, 2) returns 2.34
roundup(number, digits)
Rounds the specified number up to a specified number of decimal digits.
=roundup(2.345, 2) returns 2.35
abs(number)
The absolute value of a number.
=abs(-12) returns the absolute value of the number -12
quotient(numerator, denominator)
Computes the quotient of an integer division.
=quotient(5, 2) returns 2

You can clculate the remainder by using the MOD operator
=5 MOD 2
gcd(number1, number2, …)
The greatest common divisor of a group of numbers.
=gcd(5, 10, 20) returns 5
lcm(number1, number2, …)
The least common multiple of a group of numbers.
=lcm(2, 5, 11) returns 110
median(number1, number2, …)
The median (middle number) of a group of numbers
=median(1, 2, 3, 4, 5, 6) returns 3.5
logX(number, base)
The natural logarithm of a number with specified base. Number is the positive real number for which the logarithm is calculated. Related function: Power
=logx(16, 2) returns 4
power(number, power)
Raises a number to the given power. The function works like an exponent in a standard math equation.
=power(10, 3) returns 1000
sqrtpi(number)
The square root of (number * pi).
=sqrtpi(3.1415) returns 3.142 (square root of pi*3.1415)
sumsq(number1, number2, …)
The sum of the squares of the arguments.
=sumsq(0, 1, 2, 3, 4, 5) returns 55
randBetween(number1, number2)
A number between bottom and top, including bottom but not including top.
=randBetween(10, 100) returns a random number in the range [10, 100]
rand()
A number between 0 and 1, including 0 but not including 1.
=rand() returns a random number in the range [0, 1)
ceiling(number, [significance])
Rounds a number rounded up, away from zero, to the nearest multiple of significance.
=ceiling(123.123, 0.01) returns 123.13 (123.123 rounded up to the nearest multiple of 0.01)
floorNum(number, [significance])
Rounds a number down, toward zero, to the nearest multiple of significance.
=floorNum(123.123, 0.01) returns 123.12 (123.123 rounded down to the nearest multiple of 0.01)
truncate(number, [num digits])
A number truncated to the specified number of decimal places.
=truncate(123.123, 2) returns 123.12
average(number1, number2,...)
Returns the average (mean) of the arguments.
=average(A2,A10..A12) returns the average of the numbers contained in cells A2, A10, A11, and A12
int(number)
Rounds a number down to the nearest integer.
=int(3.8) returns the value 3
log(number)
Returns the base 10 logarithm of a number.
=log(100) returns the base 10 logarithm of 100
max(number1, number2,...)
Returns the largest number in the list of arguments.
=max(C5,C7,C9) returns the largest of the numbers that are in cells C5, C7, and C9
min(number1, number2,...)
Returns the smallest number in the list of arguments.
=min(C5,C7,C9) returns the smallest of the numbers that are in cells C5, C7, and C9
tan(number)
Returns the tangent of a given angle.
=tan(deg2rad(32)) converts a 32-degree angle to its radian equivalent, and returns the tangent of the angle
sum(number1, number2,...)
Returns the sum of all numbers in the list of arguments.
=sum(A2,A10..A12) returns the sum of the numbers contained in cells A2, A10, A11, and A12

Objects

General

Depth([optional parameters])
Returns the object's depth. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Weight([optional parameters])
Returns the object's wight. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
ProjectedArea([optional parameters])
Returns the object's projected area. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
FootPrintArea([optional parameters])
Returns the object's footprint area. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
CrossSectionArea([optional parameters])
Returns the object's cross section area. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
SpecialArea([optional parameters])
Returns the object's special area typically defined by parameters. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
ObjectData('Class Description')
Returns the class description of the object's class.
ObjectData('Classification', classification_index, param_index)
Returns the specified classification data from the object

Available options for classification_index: 1 - Primary Classification; 2 - Secondary Classification; 3 - Tertiary Classification;

Available options for param_index: 1 - Is classified; 2 - Standard Name; 3 - Classification Code; 4 - Classification Description; 5 - Classification System; 6 - Standard Source; 7 - Standard Edition; 8 - Standard Edition Date; 9 - Standard Location; 10 - Standard Description;

ObjectData('component', <value> [, <component index>])
When called on an object, the function returns the specified <value> of the object's component with the specified <component index>, or the core component if <component index> is missing. When called on a component, the function will return the specified <value> for that component. If the optional <component index> is added, the function will return the component value only for components that match the given index.

The following values are supported: "name", "function", "class", "class desc", "class description", "thickness", "lambda", "u-value", "net area", "net volume".

See the example for more details.

Available options for <value>:
	- Name
	- Function
	- Class
	- Class Desc
	- Thickness
	- Lambda
	- U-Value
	- Net Area
	- Net Volume

Examples:
	# return component name
	ObjectData('component', 'Name')			# core component
	ObjectData('component', 'Name', 2)		# component with index = 2
	
	
	# return component Function value
	ObjectData('component', 'Function')		# core component
	ObjectData('component', 'Function', 2)	# component with index = 2
	
	
	# return component class
	ObjectData('component', 'Class')		# core component
	ObjectData('component', 'Class', 2)		# component with index = 2
	
	
	# return component class description
	ObjectData('component', 'Class Desc')			# core component
	ObjectData('component', 'Class Desc', 2)		# component with index = 2
	ObjectData('component', 'Class Description')	# core component
	ObjectData('component', 'Class Description', 2)	# component with index = 2
	
	
	# return component thickness
	ObjectData('component', 'Thickness')		# core component
	ObjectData('component', 'Thickness', 2)		# component with index = 2
	
	
	# return component lambda value
	ObjectData('component', 'Lambda')			# core component
	ObjectData('component', 'Lambda', 2)		# component with index = 2
	
	
	# return component U-value
	ObjectData('component', 'U-Value')			# core component
	ObjectData('component', 'U-Value', 2)		# component with index = 2
	
	
	# return component net area
	ObjectData('component', 'Net Area')			# core component
	ObjectData('component', 'Net Area', 2)		# component with index = 2
	
	
	# return component net volume
	ObjectData('component', 'Net Volume')		# core component
	ObjectData('component', 'Net Volume', 2)	# component with index = 2
	
	
ObjectData('General Name')
Returns the object's or symbol's name and if it's a symbol with no name, returns the symbol definition resource name.
Database header cell:
=ObjectData('General Name')        Returns the name for each object in the DB row.
                                If the object is a symbol, it will return the name of the symbol

Spreadsheet cell:
=ObjectData(SEL=TRUE, 'General Name')    Returns the name for the selected object
                                      If the object is a symbol, it will return the name of the symbol
ObjectData(criteria, 'inventory part', part_univ_name, part_index)
Get inventory part name from inventory supported object.
ObjectData(criteria, 'inventory part param', part_univ_name, part_index, param_index)
Get inventory part parameter value from inventory supported object.
ObjectData(criteria, 'inventory part quantity', part_univ_name, part_index)
Get inventory part quantity from inventory supported object.
ObjectData('Layer Description')
Returns the layer description of the object's layer.
ObjectData('load info', paramSelector, [loadIndex])
Get load info from a load object. ParamSelector can be - 'Position', 'Load ID', 'Load Name', 'Distributed Weight' and 'Total Weight'. If no loadIndex is specified the first load is used.
ObjectData('Object Variable', variable_index)
Returns the specified object variable from the object.
ObjectData('Universal Value', format_name, field_name, [is format])
Returns the universal value of the specified field of record or format if the optional parameter is True. It will work with the parametric format when the format_name is empty. Returns N/A if the object doesn't have the record attached or the format doesn't exist.
Database header cell:
=ObjectData('Universal Value', 'My Format-1', 'data')        Returns the 'data' field for the attached 'My Format-1' for each object in the DB row. Returns N/A if the format or the field is not available.
=ObjectData('Universal Value', 'My Format-1', 'data', True)  Returns the 'data' field for the attached 'My Format-1' for each object in the DB row. Returns N/A if the format or the field is not available.
=ObjectData('Universal Value', '', 'DoorHeight')            Returns the 'DoorHeight' field for each parametric in the DB row. Returns N/A if the field is not avaialble or the object is not a parametric.
=ObjectData('Universal Value', '', 'DoorHeight', True)      Returns the 'DoorHeight' field default value for each parametric in the DB row. Returns N/A if the field is not avaialble or the object is not a parametric.

Spreadsheet cell:
=ObjectData(t=wall, 'Universal Value', 'My Format-1', 'data')        Returns the 'data' field for the attached 'My Format-1' for the wall. Returns N/A if the format or the field is not available.
=ObjectData(t=wall, 'Universal Value', 'My Format-1', 'data', True)  Returns the 'data' field for the attached 'My Format-1' for the wall. Returns N/A if the format or the field is not available.
=ObjectData(PON='Door', 'Universal Value', '', 'DoorHeight')        Returns the 'DoorHeight' field for the parametric object Door. Returns N/A if the field is not avaialble or the object is not a parametric.
=ObjectData(PON='Door', 'Universal Value', '', 'DoorHeight', True)  Returns the 'DoorHeight' field default value the parametric object Door. Returns N/A if the field is not avaialble or the object is not a parametric.
ObjectType()
Returns the object type ID.
Database header cell:
=ObjectType returns the object type value for each object in the database

Spreadsheet cell:
=ObjectType(sel=true) returns the object type value of the selected object; for example, the object type value for a light is 81
Width([optional parameters])
Returns the delta X (width) of objects. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Width returns the width (delta x) for each object in the database

Spreadsheet cell:
=Width(sel=true) returns the combined width (delta x value) of the selected object
Height([optional parameters])
Returns the delta Y (height) of objects. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Height returns the height (delta y) for each object in the database

Spreadsheet cell:
=Height(sel=true) returns the combined height (delta y) value of the selected objects in the drawing
Count([optional parameters])
Returns the number of objects. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Count returns the total number of objects for each row in the database

Spreadsheet cell:
=Count(s='simple sofa') returns the total number of symbol objects named “simple sofa” in the drawing

When used with the COUNT function, the SEL (selection status) criterion counts objects that are actually non-selectable, such as the individual items within a group. The VSEL (visible selection status) criterion counts only the visibly selected items, which is the same counting method used for the Object Info palette. For example, if you select and count a group that has 11 items in it, the SEL criterion returns a value of 12 (the group, plus the 11 items). The VSEL criterion returns a value of 1 (the group only).
Count('subparts', [subpart_name])
Returns the number of subparts in a plug-in object. If subpart_name is provided, then only subparts with the given subpart name will be counted. If the given subpart name doesn't match the localized name of a subpart, then it will be treated as a universal name.
Angle()
Returns the angle of lines and walls, the span angle of arcs (in degrees), and the slope angle of slabs (in degrees).
Database header cell:
=Angle returns the angle of each object in the database

Spreadsheet cell:
=Angle((t=arc)&(n='arc-1')) returns the sweep angle of the arc object named “arc-1” in the drawing
IsFlipped()
Returns 1 if the object is flipped, otherwise it returns 0.
Database header cell:
=IsFlipped returns the flip state for each object in the database

Spreadsheet cell:
=IsFlipped(PON='window') returns the flip state of the window object if it resolves to only one, otherwise returns the total number of window objects in the drawing that are flipped
XCoordinate()
Returns the X coordinate of the insertion point for symbols, point plug-in objects, and loci. The returned value is relative to the user origin.
Database header cell:
=XCoordinate returns the x coordinate value for each symbol, point plug-in object, and locus in the database
YCoordinate()
Returns the Y coordinate of the insertion point for symbols, point plug-in objects, and loci. The returned value is relative to the user origin.
Database header cell:
=YCoordinate returns the y coordinate value for each symbol, point plug-in object, and locus in the database
ZCoordinate()
Returns the Z coordinate of the insertion point for symbols, point plug-in objects, and loci. The returned value is relative to the object's layer plane.
Database header cell:
=ZCoordinate returns the z coordinate value for each symbol, point plug-in object, and locus in the database
Area()
Returns the area of 2D objects. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Area returns the area of each object in the database

Spreadsheet cell:
=Area(t=rect) returns the combined area of all rectangle objects in the drawing
BotBound()
Returns the minimum Y coordinate of objects.
Database header cell:
=BotBound returns the bottom 2D boundary of each object in the database

Spreadsheet cell:
=BotBound(t=locus) returns the bottom 2D boundary of the locus that has the lowest bottom 2D boundary value in the drawing
TopBound()
Returns the maximum Y (top boundary) of the objects.
Database header cell:
=TopBound returns the top 2D boundary for each object in the database

Spreadsheet cell:
=TopBound(sel=true) returns the top 2D boundary of the topmost selected object
LeftBound()
Returns the left side minimum X (left boundary) of the objects.
Database header cell:
=LeftBound returns the left 2D boundary for each object in the database

Spreadsheet cell:
=LeftBound(t=locus) returns the left 2D boundary of the leftmost locus in the drawing
RightBound()
Returns the right side minimum X (right boundary) of the objects.
Database header cell:
=RightBound returns the right 2D boundary for each object in the database

Spreadsheet cell:
=RightBound(t=rect) returns the right 2D boundary of the rightmost rectangle in the drawing
Perim([optional parameters])
Returns the object's perimeter. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Perim returns the perimeter for each object in the database

Spreadsheet cell:
=Perim(sel=true) returns the total perimeter of all selected objects
Length([optional parameters])
Returns the length of lines or walls. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Length returns the length for each object in the database

Spreadsheet cell:
=Length(t=line) returns the total length of all line objects in the drawing
XCenter()
Returns the center of objects in the X direction.
Database header cell:
=XCenter returns the x coordinate value of the center of the 2D boundary for each object in the database

Spreadsheet cell:
=XCenter(sel=true) returns the x coordinate value of the center of the 2D boundary of the selected object
YCenter()
Returns the center of objects in the Y direction.
Database header cell:
=YCenter returns the y coordinate value of the center of the 2D boundary for each object in the database

Spreadsheet cell:
=YCenter(sel=true) returns the y coordinate value of the center of the 2D boundary of the selected object
ZCenter()
Returns the center of objects in the Z direction.
Database header cell:
=ZCenter returns the z coordinate value of the center of the 2D boundary for each object in the database

Spreadsheet cell:
=ZCenter(sel=true) returns the z coordinate value of the center of the 2D boundary of the selected object
SurfaceArea([optional parameters])
Returns the object's surface area. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=SurfaceArea returns the surface area for each object in the database

Spreadsheet cell:
=SurfaceArea(st=sphere) returns the total surface area of all sphere objects in the drawing
Volume([optional parameters])
Returns the object's volume of objects. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Volume returns the volume for each object in the database

Spreadsheet cell:
=Volume(t=xtrd) returns the total volume of all extrude objects in the drawing
Image()
Returns an image of the object.
Database header cell:
=Image returns the image for each object in the database

Spreadsheet cell:
=Image(s='cabinet') returns the image of the symbol named “Cabinet”
ObjUValue()
Returns the U-Value of objects.
Database header cell:
=ObjectUValue returns the U-value for each wall, round wall, roof, roof face, slab, door, and window object in the database

Spreadsheet cell:
=ObjectUValue(n='wall-1') returns the U-value for the wall named “wall-1”
ObjRValue()
Returns the R-Value of objects.
Database header cell:
=ObjectRValue returns the R-value for each wall, round wall, roof, roof face, slab, door, and window object in the database

Spreadsheet cell:
=ObjectRValue(n='wall-1') returns the R-value for the wall named “wall-1”
ObjIncludeInEnergos()
Returns 1 if object will be included in Energos calculations, otherwise it returns 0.
Database header cell:
=ObjIncludeInEnergos returns the Energos status for each wall, round wall, roof, roof face, slab, door, and window object in the database

Spreadsheet cell:
=ObjIncludeInEnergos(t=wall) returns the Energos status for all walls in the drawing
PluginStyleName()
Returns the name of the plug-in style used by the object.
Database header cell:
=PluginStyleName returns the plug-in style name for each object in the database

Spreadsheet cell:
=PluginStyleName(sel=true) returns the plug-in style name for all selected objects in the drawing
Layer()
Returns the object's layer name.
Database header cell:
=Layer returns the layer name of each object in the database

Spreadsheet cell:
=Layer(sel=true) returns the layer name of the selected objects in the drawing
Class()
Returns the object's class name.
Database header cell:
=Class returns the class name of each object in the database

Spreadsheet cell:
=Class(sel=true) returns the class name of the selected objects in the drawing
ObjectTypeName()
Returns the object's type name.
Database header cell:
=ObjectTypeName returns the type name for each object in the database

Spreadsheet cell:
=ObjectTypeName(sel=true) returns the type name of the selected objects in the drawing
Name()
Returns the object's name.
Database header cell:
=Name returns the name for each object in the database

Spreadsheet cell:
=Name(sel=true) returns the name of the selected objects in the drawing
Story()
Returns the object's story name.
Database header cell:
=Story returns the story name for each object in the database

Spreadsheet cell:
=Story(sel=true) returns the story name of the selected objects in the drawing
ObjectTileFill()
Returns the object's tile fill name.
Database header cell:
=TileFill returns the tile fill name for each object in the database

Spreadsheet cell:
=TileFill(sel=true) returns the tile fill name of the selected objects in the drawing
ObjectHatchFill()
Returns the object's hatch fill name.
Database header cell:
=HatchFill returns the hatch fill name for each object in the database

Spreadsheet cell:
=HatchFill(sel=true) returns the hatch fill name of the selected objects in the drawing
ObjectGradientFill()
Returns the object's gradient fill name.
Database header cell:
=GradientFill returns the gradient fill name for each object in the database

Spreadsheet cell:
=GradientFill(sel=true) returns the gradient fill name of the selected objects in the drawing
ObjectTexture()
Returns the object's texture name.
Database header cell:
=ObjectTexture returns the texture name of each object in the database

Spreadsheet cell:
=ObjectTexture(sel=true) returns the texture name of the selected objects in the drawing
ObjectSketchStyle()
Returns the object's sketch style name.
Database header cell:
=SketchStyle returns the sketch style name for each object in the database

Spreadsheet cell:
=SketchStyle(sel=true) returns the sketch style name of the selected objects in the drawing
ObjectLineType()
Returns the object's line type name.
Database header cell:
=LineType returns the line type name for each object in the database

Spreadsheet cell:
=LineType(sel=true) returns the line type name of the selected objects in the drawing
ObjectImageFill()
Returns the object's image fill name.
Database header cell:
=ImageFill returns the image fill name for each object in the database

Spreadsheet cell:
=ImageFill(sel=true) returns the image fill name of the selected objects in the drawing
GetCOBieSource(worksheetName.columnName.country.version)
Returns data source of a COBie property for an object.
=GETCOBIESOURCE ('space.floorname') returns the FloorName data source for objects whose COBie property is Space
GetCOBieProperty(worksheetName.columnName.country.version)
Returns the value of a COBie property for an object.
=GETCOBIEPROPERTY ('space.floorname') returns the FloorName value for objects whose COBie property is Space
SymbolName()
Returns the symbol name.
Database header cell:
=SymbolName returns the name for each symbol instance in the database

Spreadsheet cell:
=SymbolName(sel=true) returns the symbol name of the selected symbol instances in the drawing
DataTagField(fieldname)
Returns the value of the specified field in the data tag object. Fieldname is the name of the field in the data tag layout.
Database header cell:
=DataTagField('Color'), where “Color” is the label of a user-entered text field in a data tag, returns the value for the “Color” field (for example, “Red”) for each data tag in the database.

Spreadsheet cell:
=DataTagField(sel=true, 'Color'), where “Color” is the label of a user-entered text field in a data tag, returns the value for the “Color” field (for example, “Red”) for the selected data tag in the drawing.
ImageByViewport(viewportName)
Returns an image of the object with the specified viewport's color scheme(s) applied.
Database header cell:
=Imagebyviewport('Plan A') applies the data visualizations from the viewport named “Plan A” to each image in the database 

Spreadsheet cell:
=Imagebyviewport('Space Allocation') applies the data visualization from the viewport named “Space Allocation” to the image in the cell
ImageByDataVis(dataVisName)
Returns an image of the object with the specified data visualizations's color scheme applied.
Database header cell:
=Imagebydatavis('truss by type') applies the “truss by type” data visualization to each image in the database rows

Spreadsheet cell:
=Imagebydatavis('offices') applies the data visualization named “offices” to the image in the cell
XRotation()
Returns the object's rotation angle (in degrees) around the X-axis.
YRotation()
Returns the object's rotation angle (in degrees) around the Y-axis.
ZRotation()
Returns the object's rotation angle (in degrees) around the Z-axis.
PartTypeName()
Returns the part type name of the subpart object. Returns the object type name if the object is not a subpart.
Database header cell:
=PartTypeName returns the part type name for each subpart object in the database. if the database object is not a subpart, the object type name is returned

FillForeColor()
Returns the object's fill foreground color name.
Database header cell:
=FillForeColor returns the name of the fill foreground color for each object in the database

Spreadsheet cell:
=FillForeColor(t=rect) returns the name of the fill foreground color of the rectangle object
FillBackColor()
Returns the object's fill background color name.
Database header cell:
=FillBackColor returns the name of the fill background color for each object in the database

Spreadsheet cell:
=FillBackColor(t=rect) returns the name of the fill background color of the rectangle object
PenForeColor()
Returns the object's pen foreground color name.
Database header cell:
=PenForeColor returns the name of the pen foreground color for each object in the database

Spreadsheet cell:
=PenForeColor(t=rect) returns the name of the pen foreground color of the rectangle object
PenBackColor()
Returns the object's pen background color name.
Database header cell:
=PenBackColor returns the name of the pen background color for each object in the database

Spreadsheet cell:
=PenBackColor(t=rect) returns the name of the pen background color of the rectangle object
IsFilled()
Returns 1 if the object has any fill attribute, otherwise returns 0.
Database header cell:
=IsFilled returns the attribute fill state (1 if filled, otherwise 0) for each object in the database



Spreadsheet cell:
=IsFilled(T=WALL) returns the attribute fill state of the wall object if the criteria resolves to one object, otherwise returns the total number of walls in the drawing that are filled

ViewportStyleName()
Returns the name of the viewport style used by the object.
Database header cell:
=ViewportStyleName returns the viewport style name for each viewport object in the database

Spreadsheet cell:
=ViewportStyleName(n='viewport-1') returns the viewport style name for the object named “viewport-1”

Legacy

ComponentArea( index)
Returns the area of one side of the specified component,

minus any holes in the 3D object.

Database header cell:
=ComponentArea(2) returns the combined area of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentArea(t=wall,1) returns the combined area of the first components for all walls in the drawing
ComponentVolume(index)
Returns the total 3D volume of the specified component,

minus any holes in the 3D object.

Database header cell:
=ComponentVolume(2) returns the combined volume of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentVolume(t=wall,1) returns the combined volume of the first components for all walls in the drawing
ComponentName(index)
Returns the name of the specified component.
Database header cell:
=ComponentName(2) returns the name of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentName(t=wall,1) returns the name of the first component for all walls in the drawing
GetIFCProperty(instanceName.propertyName)
Returns the value of the property field of the given instance or preset.
=GETIFCPROPERTY ('ifcfurnishingelement.name') returns the Name value for IFC objects whose IFC entity is IfcFurnishingElement 
ComponentLambda(index)
Returns the lambda of the specified component.
Database header cell:
=ComponentLambda(2) returns the Lambda value of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentLambda(t=wall,1) returns the Lambda value of the first component for all walls in the drawing
ComponentUValue(index)
Returns the U-Value of the specified component.
Database header cell:
=ComponentUValue(2) returns the combined U-values of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentUValue(t=wall,1) returns the combined U-values of the first components for all walls in the drawing
ComponentRValue(index)
Returns the R-Value of the specified component.
Database header cell:
=ComponentRValue(2) returns the combined R-values of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentRValue(t=wall,1) returns the combined R-values of the first components for all walls in the drawing
ComponentThickness(index)
Returns the thickness of the specified component.
Database header cell:
=ComponentThickness(2) returns the combined thickness of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentThickness(t=wall,1) returns the combined thickness of the first components for all walls in the drawing
CompAreaByClass(class)
The area of one side of the specified wall, slab, or roof component, minus any holes. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompAreaByClass('Class-1') returns the combined area of the components assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompAreaByClass(t=wall,'Class-1') returns the combined area of the components assigned to the class “Class-1” for all walls in the drawing
CompLambdaByClass(class)
The Lambda value of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the lambda value of the first matching component will be returned.
Database header cell:
=CompLambdaByClass('Class-1') returns the Lambda value of the first component assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompLambdaByClass(t=wall,'Class-1') returns the Lambda value of the first component assigned to the class “Class-1” for all walls in the drawing
CompNameByClass(class)
The name of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the first component name will be returned.
Database header cell:
=CompNameByClass('Class-1') returns the name of the first component assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompNameByClass(t=wall,'Class-1') returns the name of the first component assigned to the class “Class-1” for all walls in the drawing
CompRValueByClass(class)
The R-Value of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompRValueByClass('Class-1') returns the combined R-values of the components assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompRValueByClass(t=wall,'Class-1') returns the combined R-values of the components assigned to the class “Class-1” for all walls in the drawing
CompThicknessByClass(class)
The thickness of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompThicknessByClass('Class-1') returns the combined thickness of the components assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompThicknessByClass(t=wall,'Class-1') returns the combined thickness of the components assigned to the class “Class-1” for all walls in the drawing
CompUValueByClass(class)
The U-Value of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompUValueByClass('Class-1') returns the combined U-values of the components assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompUValueByClass(t=wall,'Class-1') returns the combined U-values of the components assigned to the class “Class-1” for all walls in the drawing
CompVolumeByClass(class)
The volume of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompVolumeByClass('Class-1') returns the combined volume of the components assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompVolumeByClass(t=wall,'Class-1') returns the combined volume of the components assigned to the class “Class-1” for all walls in the drawing
CompAreaByName(name)
The area of one side of the specified wall, slab, or roof component, minus any holes. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompAreaByName('Brick Veneer') returns the combined area of the components with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompAreaByName(t=wall,'Brick Veneer') returns the combined area of the components with the name “Brick Veneer” for all walls in the drawing
CompLambdaByName(name)
The Lambda value of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the lambda value of the first matching component will be returned.
Database header cell:
=CompLambdaByName('Brick Veneer') returns the Lambda value of the first component with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompLambdaByName(t=wall,'Brick Veneer') returns the Lambda value of the first component with the name “Brick Veneer” for all walls in the drawing
CompClassByName(name)
The class of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the specified name the first component class will be returned.
Database header cell:
=CompClassByName('Brick Veneer') returns the class of the first component with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompClassByName(t=wall,'Brick Veneer') returns the class of the first component with the name “Brick Veneer” for all walls in the drawing
CompRValuesByName(name)
The R-Value of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompRValueByName('Brick Veneer') returns the combined R-values of the components with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompRValueByName(t=wall,'Brick Veneer') returns the combined R-values of the components with the name “Brick Veneer” for all walls in the drawing
CompThicknessByName(name)
The thickness of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompThicknessByName('Brick Veneer') returns the combined thickness of the components with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompThicknessByName(t=wall,'Brick Veneer') returns the combined thickness of the components with the name “Brick Veneer” for all walls in the drawing
CompUValueByName(name)
The U-Value of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompUValueByName('Brick Veneer') returns the combined U-values of the components with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompUValueByName(t=wall,'Brick Veneer') returns the combined U-values of the components with the name “Brick Veneer” for all walls in the drawing
CompVolumeByName( name)
The volume of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompVolumeByName('Brick Veneer') returns the combined volume of the components with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompVolumeByName(t=wall,'Brick Veneer') returns the combined volume of the components with the name “Brick Veneer” for all walls in the drawing
CompMatByClass(class)
The material of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompMatByClass('Class-1') returns the materials used by the first component assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompMatByClass(t=wall,'Class-1') returns the material used by the first component assigned to the class “Class-1” for all walls in the drawing
CompMatByName(name)
The material of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompMatByName('Siding') returns the materials used by the first component with the name “Siding” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompMatByName(t=wall,'Siding') returns the material used by the first component with the name “Siding” for all walls in the drawing
CompAreaByMat(material)
The area of one side of the specified wall, slab, or roof component, minus any holes. Material is a string that specifies the component's material. If multiple components use the specified material the values will be summed.
Database header cell:
=CompAreaByMat('Mortar MT') returns the combined area of the components that use the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompAreaByMat(t=wall, 'Mortar MT') returns the combined area of the components that use the material “Mortar MT” for all walls in the drawing
CompClassByMat(material)
The class of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the first component class will be returned.
Database header cell:
=CompClassByMat('Mortar MT') returns the class of the first component that uses the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompClassByMat(t=wall, 'Mortar MT') returns the class of the first component that uses the material “Mortar MT” for all walls in the drawing
CompLambdaByMat(material)
The Lambda value of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the lambda value of the first matching component will be returned.
Database header cell:
=CompLambdaByMat('Mortar MT') returns the Lambda value of the first component that uses the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompLambdaByMat(t=wall,'Mortar MT') returns the Lambda value of the first component that uses the material “Mortar MT” for all walls in the drawing
CompNameByMat(material)
The name of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the first component name will be returned.
Database header cell:
=CompNameByMat('Mortar MT') returns the name of the first component that uses the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompNameByMat(t=wall,'Mortar MT') returns the name of the first component that uses the material “Mortar MT” for all walls in the drawing
CompRValueByMat(material)
The R-Value of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the values will be summed.
Database header cell:
=CompRValueByMat('Mortar MT') returns the combined R-values of the components that use the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompRValueByMat(t=wall,'Mortar MT') returns the combined R-values of the components that use the material “Mortar MT” for all walls in the drawing
CompThicknessByMat(material)
The thickness of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the values will be summed.
Database header cell:
=CompThicknessByMat('Mortar MT') returns the combined thickness of the components that use the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompThicknessByMat(t=wall,'Mortar MT') returns the combined thickness of the components that use the material “Mortar MT” for all walls in the drawing
CompUValueByMat(material)
The U-Value of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the values will be summed.
Database header cell:
=CompUValueByMat('Mortar MT') returns the combined U-values of the components that use the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompUValueByMat(t=wall,'Mortar MT') returns the combined U-values of the components that use the material “Mortar MT” for all walls in the drawing
CompVolumeByMat(material)
The volume of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the values will be summed.
Database header cell:
=CompVolumeByMat('Mortar MT') returns the combined volume of the components that use the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompVolumeByMat(t=wall,'Mortar MT') returns the combined volume of the components that use the material “Mortar MT” for all walls in the drawing

Material

MaterialName()
Returns the object's material.
Database header cell:
=MaterialName returns the names of materials in objects for each row in the database

Spreadsheet cell:
=MaterialName(t=SOLIDCSG) returns the names of materials in generic solids in the drawing
MaterialCount()
Returns the object's number of materials.
Database header cell:
=MaterialCount returns the total number of materials in objects for each row in the database

Spreadsheet cell:
=MaterialCount(t=SOLIDCSG) returns the total number of materials in generic solids in the drawing
MaterialTexture()
Returns the name of the object's material's texture assignment.
Database header cell:
=MaterialTexture returns the texture of the material assigned to objects for each row in the database

Spreadsheet cell:
=MaterialTexture(t=SOLIDCSG) returns the texture of the material assigned to the generic solid in the drawing
MatPropertyByName(materialName, propertyName)
Returns the value of the specified property for the specified material.
Spreadsheet cell:
=MatPropertyByName('Mortar MT','MaterialFinish') returns the material finish property for the material “Mortar MT”
MaterialIsSimple()
Returns true if the object's material is a simple material.
Database header cell:
=MaterialIsSimple returns TRUE if the material of the object referenced by the database row is a simple material.

Spreadsheet cell:
=MaterialIsSimple(t=SOLIDCSG) returns TRUE if the material of the generic solid in the drawing is a simple material.
MaterialPartName(materialName)
Returns the name of the material-bearing geometry that uses the specified material in the object.
Database header cell:
=MaterialPartName('Metal Steel MT') returns the name of the first part that uses the material “Metal Steel MT” for each row in the database

Spreadsheet cell:
=MaterialPartName(t=wall, 'Metal Steel MT') returns the name of the first part that uses the material “Metal Steel MT” for walls in the drawing
MaterialSurfaceArea()
Returns the surface area of the object's specified material assignment.
Database header cell:
=MaterialSurfaceArea('Mortar MT') returns the surface area for objects that use the material named “Mortar MT” for all objects for each row in the database

Spreadsheet cell:
=MaterialSurfaceArea(t=wall,'Mortar MT') returns the surface area for objects that use the material named “Mortar MT” for all walls in the drawing
MaterialVolume()
Returns the volume of the object's specified material assignment.
Database header cell:
=MaterialVolume('Mortar MT') returns the volume for objects that use the material named “Mortar MT” for all objects for each row in the database

Spreadsheet cell:
=MaterialVolume(t=wall,'Mortar MT') returns the volume for objects that use the material named “Mortar MT” for all walls in the drawing
MaterialPercent(materialName)
Returns percentage of the object's specified material.
Database header cell:
=MaterialPercent('Mortar MT') returns the percentage of the material “Mortar MT” in all objects for each row in the database

Spreadsheet cell:
=MaterialPercent(t=wall,'Mortar MT') returns the percentage of the material “Mortar MT” for all walls in the drawing
ComponentMaterial(index)
Returns the material of the specified component.
Database header cell:
=ComponentMaterial(2) returns the material used by the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentMaterial(t=wall,1) returns the material used by the first component for all walls in the drawing
MaterialProperty(propertyName)
Returns the value of the specified property for the material resource.
Database header cell:
=MaterialProperty('MaterialFinish') returns the value of the material property "MaterialCategory" for each material resource in the database

Spreadsheet cell:
=MaterialProperty((t=material) & (n='material-1'), 'MaterialCategory') returns the value of the material property "MaterialCategory" for the material resource named "material-1"

Available property names:

- General info fields
	'MaterialDescription'
	'MaterialKeynote'
	'MaterialMark'

- Physical values
	'MaterialUsesAcousticImpedance' and 'MaterialAcousticImpedance'
	'MaterialUsesAlbedo' and 'MaterialAlbedo'
	'MaterialUsesDensity' and 'MaterialDensity'
	'MaterialUsesEmbodiedCarbon' and 'MaterialEmbodiedCarbon'
	'MaterialUsesEmissivity' and 'MaterialEmissivity'
	'MaterialUsesLambda' and 'MaterialLambda'
	'MaterialUsesModulusOfElasticity' and 'MaterialModulusOfElasticity'
	'MaterialUsesSlipResistance' and 'MaterialSlipResistance'
	'MaterialUsesSoundVelocity' and 'MaterialSoundVelocity'
	'MaterialUsesSpecificGravity' and 'MaterialSpecificGravity'
	'MaterialUsesSpecificHeat' and 'MaterialSpecificHeat'
	'MaterialUsesTensileStrength' and 'MaterialTensileStrength'
	'MaterialUsesThermalExpansionCoefficient' and 'MaterialThermalExpansionCoefficient'
	'MaterialUsesYieldStrength' and 'MaterialYieldStrength'

Construction info
	'MaterialCategory'
	'MaterialClassificationDescription'
	'MaterialCost'
	'MaterialFinish'
	'MaterialIsSurfaceAreaMeasure'
	'MaterialIsVolumetric'
	'MaterialManufacturer'
	'MaterialProductDescription'
	'MaterialProductModel'
	'MaterialProductName'
	'MaterialProductURL'
	'MaterialReferenceID'
	'MaterialSource'
	'MaterialStandard'

Specialized for Adapter

ObjectData('eval adapter plug device', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the adapter's plug device.
ObjectData('eval adapter plug socket', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the adapter's plug socket.

Specialized for Cable

ObjectData('cable break', '<DataSelector>', [<Break Index>)]
Get cable break data. Data selectors - 'Name'. If the function is called on a cable break subpart there is no need to specify the break index. If the function is called on a cable object you have to specify the break index.
ObjectData('cable section', '<DataSelector>', [<Section Index>)]
Get cable section data. Data selectors - 'Name', 'Parts Ordered'. 'Parts Ordered' is read only. If the function is called on a cable section subpart there is no need to specify the section index. If the function is called on a cable object you have to specify the section index.
Length('cable section', '<DataSelector>', [<Section Index>)]
Get cable section length. Data selectors - 'Length', 'Start Slack', 'End Slack', 'Swag', 'Total Vertical Drop'. 'Length' and 'Total Vertical Drop' are read only. If the function is called on a cable section subpart there is no need to specify the section index. If the function is called on a cable object you have to specify the section index.

Specialized for Circuit

ObjectData('eval circuit destination adapter', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's destination adapter.
ObjectData('eval circuit destination device', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's destination device.
ObjectData('eval circuit destination socket', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's destination socket.
ObjectData('eval circuit drop points', ['<RecordName>'], ['<FieldName>'], ['ignoreEnds'])
List any intermediate drop point ID’s, parameter values or attached record fields through which a circuit passes. Add ignoreEnds to not list the drop points, located at the begging or at the end of the route. The drawing needs to be analyzed.
ObjectData('eval circuit route', ['<RecordName>'], ['<FieldName>'])
Get path IDs, parameter values or attached record fields from the circuit's used cable paths. The drawing needs to be analyzed.
ObjectData('eval circuit source adapter', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's source adapter.
ObjectData('eval circuit source device', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's source device.
ObjectData('eval circuit source socket', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's source socket.

Specialized for Countertop

Weight()
Returns the net weight of the Countertop or any Countertop subpart. To have a weight, a subpart must have a material with a set density.
Weight('gross')
Returns the gross weight of the Countertop or any Countertop subpart. To have a weight, a subpart must have a material with a set density.
Weight('net')
Returns the gross weight of the Countertop or any Countertop subpart. To have a weight, a subpart must have a material with a set density.
ObjectData('backsplash profile')
Returns the name of the backsplash profile. Applicable to the countertop object and backsplash subpart.
ObjectData('edge profile')
Returns the name of the edge/trim profile. Applicable to the countertop object and profile and trim subparts.
ObjectData('joint type')
Returns the joint type of waterfall edge subparts.
ObjectData('style name')
Returns the name of the plug-in style used by the countertop object.
Thickness()
Returns the thickness of the countertop surface, trim, backsplashes or waterfall edges. For the countertop object, this function will return the thickness of the countertop surface.
Width('bounding box')
Returns the width of the bounding box of the countertop object or countertop surface.
Height()
Returns the Z-height of trim and backsplashes.
Height('bounding box')
Returns the height of the bounding box of the countertop object or countertop surface.
Count('cutouts')
Returns the number of cutouts in the countertop object or countertop surface. Both 2D and 3D cutouts are included.
Area()
Returns the area of the outer faces of waterfall edges.
Area('bounding box')
Returns the area of the bounding box of the countertop object or countertop surface.
Area('cutouts')
Returns the total area of cutouts in the countertop. All 2D and 3D cutouts are taken into account. The function is only applicable to the countertop object and the countertop surface subpart.
Area('gross')
Returns the gross area of the countertop. No cutouts are taken into account. The function is only applicable to the countertop object and the countertop surface subpart.
Area('net')
Returns the net area of the countertop. All 2D and 3D cutouts are taken into account. The function is only applicable to the countertop object and the countertop surface subpart.
Perim()
Returns the perimeter of the countertop object or countertop surface. The countertop overhangs will be included in the perimeter.
Length()
Returns the length of edge profiles, trim, backsplashes or waterfall edges. The length is measured along the outer edge of the subart.
Volume()
Returns the net volume of the Countertop or any Countertop subpart.
Volume('gross')
Returns the gross volume of the Countertop or any Countertop subpart. Cutouts and edge profiles are ignored.
Volume('net')
Returns the net volume of the Countertop or any Countertop subpart.

Specialized for Curb

FootPrintArea()
Calculate the footprint area of the Curb object and its subparts.
SpecialArea()
Calculate the Extrude profile area for Curb Extrude subparts.
ObjectData('name')
Return the name of the subpart symbol for Curbs.
Width()
Returns the width of the bounding box for Curb and its subparts.
Height()
Returns the height of the bounding box for Curb and its subparts.
Length()
Returns the length of the Curb insertion line
Volume()
Calculate the volume of the Curb, Landscape Area, Hardscape, or Site Model and their components.

Specialized for Curtain Wall

CurtWallFrameLength(classname)
Returns the length of curtain wall frames in class 'classname'.
Database header cell:
=CurtWallFrameLength('') returns the combined length of the curtain wall frames for each curtain wall in the database

Spreadsheet cell:
=CurtWallFrameLength(t=wall, '') returns the combined length of the curtain wall frames for all curtain walls in the drawing
CurtWallPnlAreaGross(classname)
Returns the gross area of the curtain wall panels in class 'classname'.
Database header cell:
=CurtWallPnlAreaGross('') returns the combined gross area of the curtain wall panels for each curtain wall in the database

Spreadsheet cell:
=CurtWallPnlAreaGross(t=wall, '') returns the combined gross area of the curtain wall panels for all curtain walls in the drawing
CurtWallPnlAreaNet(classname)
Returns the net area of the curtain walls panels in class 'classname'.
Database header cell:
=CurtWallPnlAreaNet ('Class-1') returns the combined net area of the curtain wall panels assigned to the class “Class-1” for each curtain wall in the database

Spreadsheet cell:
=CurtWallPnlAreaNet(t=wall, 'Class-1') returns the combined net area of the curtain wall panels assigned to the class “Class-1” for all curtain walls in the drawing

Specialized for Device

ObjectData('eval equipment item', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the device's corresponding equipment item.

Specialized for Distributor Object

ObjectData('eval schematic device', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the objects's schematic device.

Specialized for Door

Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.
Volume(criteria, 'door jamb')
Returns the volume the jamb.
Database header cell:
=VOLUME('door jamb')     Returns the volume the jamb.

Spreadsheet cell:
=VOLUME(SEL, 'door jamb')    Returns the volume the jamb.
Volume(criteria, 'door sashes')
Returns the total volume all sashes (including sidelight and transom sashes).
Database header cell:
=VOLUME('door sashes')     Returns the total volume all sashes (including sidelight and transom sashes).

Spreadsheet cell:
=VOLUME(SEL, 'door sashes')    Returns the total volume all sashes (including sidelight and transom sashes).
Volume(criteria, 'glazing all')
Returns the total volume of all glazing.
Database header cell:
=VOLUME('glazing all')     Returns the total volume of all glazing.

Spreadsheet cell:
=VOLUME(SEL, 'glazing all')    Returns the total volume of all glazing.
Volume(criteria, 'glazing for leaves')
Returns the volume of glazing for all leaves (including vision panels).
Database header cell:
=VOLUME('glazing for leaves')     Returns the volume of glazing for all leaves (including vision panels).

Spreadsheet cell:
=VOLUME(SEL, 'glazing for leaves')    Returns the volume of glazing for all leaves (including vision panels).
Volume(criteria, 'glazing for sidelights')
Returns the volume of glazing for all sidelights.
Database header cell:
=VOLUME('glazing for sidelights')     Returns the volume of glazing for all sidelights.

Spreadsheet cell:
=VOLUME(SEL, 'glazing for sidelights')    Returns the volume of glazing for all sidelights.
Volume(criteria, 'glazing for transom')
Returns the volume of glazing for the transom.
Database header cell:
=VOLUME('glazing for transom')     Returns the volume of glazing for the transom.

Spreadsheet cell:
=VOLUME(SEL, 'glazing for transom')    Returns the volume of glazing for the transom.
Volume(criteria, 'leaf panels')
Returns the total volume of the leaf panels.
Database header cell:
=VOLUME('leaf panels')     Returns the total volume of the leaf panels.

Spreadsheet cell:
=VOLUME(SEL, 'leaf panels')    Returns the total volume of the leaf panels.
Volume(criteria, 'leaf stiles and rails')
Returns the total volume of the leaf rails, and stiles.
Database header cell:
=VOLUME('leaf stiles and rails')     Returns the total volume of the leaf rails and stiles.

Spreadsheet cell:
=VOLUME(SEL, 'leaf stiles and rails')    Returns the total volume of the leaf rails and stiles.

Specialized for Door CW

Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.

Specialized for Fence

Depth('Gravel Board')
The function is applicable to Fence object and Gravel Board subpart.

Returns the depth of the gravel board, if active.

Depth('Horizontal Boards')
The function is applicable to Fence object and Infill subpart.

Returns the profile thickness. If the fence has different Infill Type, returns N/A.

Depth('Panels')
The function is applicable to Fence object and Infill subpart.

Returns the profile depth. If the fence has different Infill Type, returns N/A.

Depth('Rail', <Index>)
The function is applicable to:

Fence object: returns the depth of the selected rail.

Rail subpart: returns the depth of the rail. If the rail doesn't correspond to the selected index, returns N/A.

Depth('Rails')
The function is applicable to rail subparts: returns the depth of the rail.
Depth('Vertical Boards')
The function is applicable to Fence object and Infill subpart.

Returns the profile width. If the fence has different Infill Type, returns N/A.

FootPrintArea('Corner Footers')
The function is applicable to:

Fence object: returns the total footprint area of all footers.

Footer subpart: returns the footprint area of the footer. If the footer is not corner, returns N/A.

FootPrintArea('Footers')
The function is applicable to:

Fence object: returns the total footprint area of all footers.

Footer subpart: returns the footprint area of the footer.

FootPrintArea('Gate Footers')
The function is applicable to:

Fence object: returns the total footprint area of all footers.

Footer subpart: returns the footprint area of the footer. If the footer is not gate, returns N/A.

FootPrintArea('Running Footers')
The function is applicable to:

Fence object: returns the total footprint area of all footers.

Footer subpart: returns the footprint area of the footer. If the footer is not running, returns N/A.

ObjectData('Footer Type')
The function is applicable to Footer subpart only.

Returns the type of the footer. It can be 'Corner Footer', 'Running Footer' or 'Gate Footer'.

ObjectData('Infill Type')
The function is applicable to Infill subpart only.

Returns the type of the infill. It can be 'Preconstructed Panel', 'Vertical Board' or 'Horizontal Board'.

ObjectData('Name')
The function is applicable to all Fence subparts: Post, Gate, Infill, and Rail.

Returns the name of the used symbol definition.

ObjectData('Post Type')
The function is applicable to Post subpart only.

Returns the type of the post. It can be 'Corner Post', 'Running Post' or 'Gate Post'.

ObjectData('Rail Index')
The function is applicable to Rail subpart only.

Returns the index of the rail type, starting from index 1.

Width('Horizontal Boards')
The function is applicable to Fence object and Infill subpart.

Returns the profile width. If the fence has different Infill Type, returns N/A.

Width('Vertical Boards')
The function is applicable to Fence object and Infill subpart.

Returns the profile thickness. If the fence has different Infill Type, returns N/A.

Height('Corner Footers')
The function is applicable to:

Fence object: returns the sum of all corner footers.

Footer subpart: returns the height of the footer, which is equal to the (depth below grade + drainage layer) of the related footer type. If the footer type is not corner, returns N/A.

Height('Corner Posts')
The function is identical to Length('Corner Posts').
Height('Fabric')
The function is applicable to:

Fence object: returns the height of the fabric subpart ( if there are more than 1, returns the height of the first ).

Rail subpart: returns height only if the rail is of type fabric.

Height('Footers')
The function is applicable to:

Fence object: returns the sum of all footers.

Footer subpart: returns the height of the footer, which is equal to the (depth below grade + drainage layer) of the related footer type.

Height('Gate Footers')
The function is applicable to:

Fence object: returns the sum of all gate footers.

Footer subpart: returns the height of the footer, which is equal to the (depth below grade + drainage layer) of the related footer. If the footer type is not gate, returns N/A.

Height('Gate Posts')
The function is identical to Length('Gate Posts').
Height('Gates')
The function is applicable to Gate subpart only. Returns the height of the gate.
Height('Gravel Board')
The function is applicable to Fence object and Gravel Board subpart.

Returns the height of the gravel board, if active.

Height('Panels')
The function is applicable to Fence object and Infill subpart.

Returns the panel height. If the fence has different Infill type, returns N/A.

Height('Posts')
The function is identical to Length('Posts').
Height('Rail', <Index>)
The function is applicable to:

Fence object: returns the height of the <Index> rail.

Rail subpart: returns the height of the rail. If the rail doesn't correspond to the selected index, returns N/A.

Height('Rails')
The function is applicable to:

Rail subpart: returns the height of the rail.

Height('Running Footers')
The function is applicable to:

Fence object: returns the sum of all running footers.

Footer subpart: returns the height of the footer, which is equal to the (depth below grade + drainage layer) of the related footer type. If the footer type is not running, returns N/A.

Height('Running Posts')
The function is identical to Length('Running Posts').
Height('Top Line Above Grade')
The function is applicable to the Fence object.

If the 'Infill Type' is 'Rails Only': returns the highest top elevation of all rails.

Otherwise: returns the 'Top Line Above Grade' field.

Count('Corner Footers')
The function is applicable to:

Fence object: returns the count of all corner footers.

Footer subpart: returns 1 for any corner footer. If the footer is not corner, returns N/A.

Count('Corner Posts')
The function is applicable to:

Fence object: returns the total count of corner posts.

Post subpart: returns 1 for any corner post.

Count('Fabric')
The function is applicable to:

Fence object: returns the count of all rails that are treated as fabric.

Rail subpart: returns 1 if the rail is fabric.

Count('Footers')
The function is applicable to:

Fence object: returns the count of all footers.

Footer subpart: returns 1 for any type of footer.

Count('Gate Footers')
The function is applicable to:

Fence object: returns the count of all gate footers.

Footer subpart: returns 1 for any gate footer. If footer is not gate, returns N/A.

Count('Gate Posts')
The function is applicable to:

Fence object: returns the total count of gate posts.

Post subpart: returns 1 for any gate post.

Count('Gates')
The function is applicable to:

Fence object: returns the number of gates in the fence object.

Gate subpart: returns 1 for any gate.

Count('Gravel Board')
The function is applicable to:

Fence object: returns number of gravel boards if the option is active.

Gravel Board subpart: returns 1.

Count('Horizontal Boards')
The function is applicable to:

Fence object: returns the number of horizontal boards in the object.

Infill subpart: returns 1 for any horizontal board infill. If the fence has different Infill Type, returns N/A.

Count('Panels')
The function is applicable to:

Fence object: returns the number of panels in the object.

Infill subpart: returns 1 for any panel infill. If the fence has different Infill Type, returns N/A.

Count('Posts')
The function is applicable to:

Fence object: returns the total count of posts.

Post subpart: returns 1 for any type of post.

Count('Rail', <Index>)
The function is applicable to:

Fence object: returns 1 if <Index> is valid one or 0 if it is out of bounds.

Rail subpart: returns 1 if the rail corresponds to the selected index. Otherwise, returns N/A.

Count('Rails')
The function is applicable to:

Fence object: returns the count of all rail settings.

Rail subpart: returns 1 for any rail.

Count('Running Footers')
The function is applicable to:

Fence object: returns the count of all running footers.

Footer subpart: returns 1 for any running footer. If the footer is not running, returns N/A.

Count('Running Posts')
The function is applicable to:

Fence object: returns the total count of running posts.

Post subpart: returns 1 for any running post.

Count('Vertical Boards')
The function is applicable to:

Fence object: returns the number of vertical boards in the object.

Infill subpart: returns 1 for any vertical board infill. If the fence has different Infill Type, returns N/A.

Length('2D')
The function is applicable to the Fence object.

Returns the 2D length of the offset object path.

Length('3D')
The function is applicable to the Fence object.

Returns the 3D length of the offset object path.

Length('Corner Posts')
The function is applicable to:

Fence object: returns the sum of all post length.

Post subpart: returns the length of the post, counted from top to bottom of depth below grade. If the post is not corner, returns N/A.

Length('Fabric')
The function is applicable to:

Fence object: return the total length of all fabric rails with equal index. If there are multiple fabric rails, selects the first one.

Rail subpart: returns the length of the rail. If the rail isn't fabric, returns N/A.

Length('Gate Posts')
The function is applicable to:

Fence object: returns the sum of all post length.

Post subpart: returns the length of the post, counted from top to bottom of depth below grade. If the post is not gate, returns N/A.

Length('Gates')
The function is applicable to:

Fence object: returns the sum of all gate lengths.

Gate subpart: return the length along the fence line of this Gate.

Length('Gravel Board')
The function is applicable to:
returns the sum length of all gravel boards.

Gravel Board subpart: returns the length of the gravel board.

Length('Horizontal Boards')
The function is applicable to:

Fence object: returns the sum of all horizontal board lengths.

Infill subpart: returns the length of the horizontal board. It is defined as the distance/arc length from the start post to the end (depending on the object path). If the fence has different Infill Type, returns N/A.

Length('Panels')
The function is applicable to:

Fence object: returns the sum of all panel lengths.

Infill subpart: returns the length of the panel. If the fence has different Infill Type, returns N/A.

Length('Posts')
The function is applicable to:

Fence object: returns the sum of all post length.

Post subpart: returns the length of the post, counted from top to bottom of depth below grade.

Length('Rail', <Index>)
The function is applicable to:

Fence object: returns the total length of all rails with index <Index>.

Rail subpart: return the length of the rail. If the rail doesn't correspond to the selected index, returns N/A.

Length('Rails')
The function is applicable to:

Fence object: returns the total length of all rails.

Rail subpart: returns the length of the rail.

Length('Running Posts')
The function is applicable to:

Fence object: returns the sum of all post length.

Post subpart: returns the length of the post, counted from top to bottom of depth below grade. If the post is not running, returns N/A.

Length('Vertical Boards')
The function is applicable to:

Fence object: returns the sum of all vertical boards lengths.

Infill subpart: returns the length of the vertical board. It is defined from the bottom position of the board to top. If the fence has different Infill Type, returns N/A.

SurfaceArea('Fabric')
The function is applicable to:

Fence object: returns the total surface area of all fabric rails.

Rail subpart: returns the surface area of the rail if it is fabric. Otherwise, returns N/A.

SurfaceArea('Panels')
The function is applicable to:

Fence object: returns the sum of all panel surface areas.

Infill subpart: returns the panel surface area. If the fence has different Infill Type, returns N/A.

Volume()
The function is applicable to the Fence object.

Returns the total volume of the fence object.

Volume('Corner Footers')
The function is applicable to:

Fence object: returns the total volume of all corner footers.

Footer subpart: returns the volume of the footer. If the footer is not corner, returns N/A.

Volume('Corner Posts')
The function is applicable to:

Fence object: returns the volume of all corner posts.

Post subpart: returns the volume of the corner post. If the post is not corner, returns N/A.

Volume('Footers')
The function is applicable to:

Fence object: returns the total volume of all footers.

Footer subpart: returns the volume of the footer.

Volume('Gate Footers')
The function is applicable to:

Fence object: returns the total volume of all gate footers.

Footer subpart: returns the volume of the footer. If the gate is not gate, returns N/A.

Volume('Gate Posts')
The function is applicable to:

Fence object: returns the volume of all gate posts.

Post subpart: returns the volume of the gate post. If the post is not gate, returns N/A.

Volume('Gates')
The function is applicable to:

Fence object: returns the total volume of all gates.

Gate subpart: returns the volume of the gate.

Volume('Gravel Board')
The function is applicable to:
returns the total volume of all gravel boards.

Gravel Board subpart: returns the volume of the gravel board.

Volume('Horizontal Boards')
The function is applicable to:

Fence object: returns the total volume of the horizontal boards.

Infill subpart: returns the horizontal board volume. If the fence has different Infill Type, returns N/A.

Volume('Panels')
The function is applicable to:

Fence object: returns the total volume of the panels.

Infill subpart: returns the panel volume. If the fence has different Infill Type, returns N/A.

Volume('Posts')
The function is applicable to:

Fence object: returns the volume of all posts.

Post subpart: returns the volume of the post.

Volume('Rail', <Index>)
The function is applicable to:

Fence object: returns the total volume of all rails from the selected index.

Rail subpart: returns the volume of the rail. If the rail doesn't correspond to the selected index, returns N/A.

Volume('Rails')
The function is applicable to:

Fence object: returns the total volume of all rails.

Rail subpart: returns the volume of the rail. Function is defined only if Depth and Height return nonzero result.

Volume('Running Footers')
The function is applicable to:

Fence object: returns the total volume of all running footers.

Footer subpart: returns the volume of the footer. If the footer is not running, returns N/A.

Volume('Running Posts')
The function is applicable to:

Fence object: returns the volume of all running posts.

Post subpart: returns the volume of the running post. If the post is not running, returns N/A.

Volume('Vertical Boards')
The function is applicable to:

Fence object: returns the total volume of the vertical boards.

Infill subpart: returns the vertical board volume. If the fence has different Infill Type, returns N/A.

Specialized for Hardscape

Depth()
Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
ProjectedArea()
Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
ObjectData('component name')
Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
Area()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
SurfaceArea()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
Volume()
Calculate the volume of the Curb, Landscape Area, Hardscape, or Site Model and their components.

Specialized for Hedgerow

ObjectData('percentage')
Return the percentage value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('Plant Record', <field>)
Provides access to the Plant Record data of the Landscape Area Plant subparts for edit if the style allows.
ObjectData('rate')
Return the rate value value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('rate unit')
Return the rate unit string of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('rate with unit')
Return the rate value and unit of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.

Specialized for Landscape Area

Depth()
Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
ProjectedArea()
Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
ObjectData('component name')
Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
ObjectData('divider')
Return the divider string or empty of this divider from a Landscape Area. This must be used on a database row listing the dividers/plants of Landscape Areas.
ObjectData('Landscape Area', <field>)
Provides access to the Landscape Area data field for edit if the style allows.
ObjectData('percentage')
Return the percentage value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('Plant Record', <field>)
Provides access to the Plant Record data of the Landscape Area Plant subparts for edit if the style allows.
ObjectData('rate')
Return the rate value value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('rate unit')
Return the rate unit string of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('rate with unit')
Return the rate value and unit of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
Area()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
SurfaceArea()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
Volume()
Calculate the volume of the Curb, Landscape Area, Hardscape, or Site Model and their components.

Specialized for Lighting Device

Weight(criteria)
Returns the total weight of the Lighting Device and all it's accessories.
ObjectData('accessory inst types', <field>)
Provides access to the Instrument Type of Lighting Device accessories. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
ObjectData('accessory parameter', <field>)
Provides access to a data of the Lighting Device accessory. Use the first parameter to specify the universal parameter name. Use no parameters additional for all cells and accessories or use additional parameters to specify cells or accessories.
ObjectData('accessory symbols', <field>)
Provides access to the symbol names of Lighting Device accessories. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
ObjectData('cellsonly', <field>)
Provides access to a parameter of the Lighting Devices and ignores accessories. Use parameters to specify the universal parameter name.
ObjectData('channel', <field>)
Provides access to the channel of Lighting Devices. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
ObjectData('colors', <field>)
Provides access to the color of Lighting Devices. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
ObjectData('eval schematic device', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the objects's schematic device.
ObjectData('parameter', <field>)
Provides access to a parameter of Lighting Devices. Use parameters to specify the universal parameter name, cell number and accessory number.

Specialized for Marionette Object

ObjectData('parameter', '<OIP FieldName>')
Get parameter values or attached record fields from Marionette objects.

Specialized for Panel Connector

ObjectData('eval panel connector circuit', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit connected to the panel connector.

Specialized for Plant

Count('excav component')
Returns the number of planting excavation components.
Volume('excav component', <index>)
Returns the volume of the <index> planting excavation component.
PlantImage(index)
Returns an image of the object at the specified index.
Database header cell:
=PlantImage(2) displays the image specified for Image Detail in the More Data pane of the plant symbol definition

Spreadsheet cell:
=PlantImage((‘Plant’.’plant ID’=’TaxfR’), 4) displays the image specified for Custom Image in the More Data pane of the plant symbol definition with a plant ID of TaxfR

Specialized for Railing

Width()
This function is applicable to the following subparts: Frame, Panel, Bracket and Face Post.

QUANTITY DESCRIPTION: For Frame: Width of the rectangular frame.

For Panel: Width of the rectangular panel.

For Bracket: width of bracket (actually represents the value of Handrail offset).

For Face Post: width of face post (actually represents the value of Inset).

Width('brackets')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Width of bracket subpart.

Width('face posts')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Width of face post subpart.

Width('frame')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the width of all frame subparts.

Width('panels')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the width of all panel subparts.

Width('profile')
This function is applicable to the following subparts: Handrail, Guardrail, Post, Frame, Bar Vertical, Bar Horizontal, Bracket and Face Post.

QUANTITY DESCRIPTION: Width of subparts listed above.

Height()
This function is applicable to the Railing object and the following subparts: Handrail, Guardrail, Frame, Panel, Bracket, Post and Face Post.

QUANTITY DESCRIPTION: For Railing object: Height of the Railing object (actually represents the maximum value of Guardrail Height or Handrail Height).

For Frame: Height of the rectangular frame.

For Panel: Height of the rectangular panel.

For Handrail: Height of Handrail (actually represents the value of Handrail Height).

For Guardrail: Height of Guardrail (actually represents the value of Guardrail Height).

For Face Post: Height of Post.

For Post: Height of Post.

Height('brackets')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Height of the bracket subpart.

Height('face posts')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the height of all face post subparts.

Height('frame')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the height of all frame subparts.

Height('guardrail')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Height of the Guardrail (actually represents the value of Guardrail Height).

Height('handrail')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Height of the Handrail (actually represents the value of Handrail Height).

Height('panels')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the height of all panel subparts.

Height('posts')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the height of all post subparts.

Height('profile')
This function is applicable to the following subparts: Handrail, Guardrail, Frame, Bar Vertical, Bar Horizontal, Bracket, Post and Face Post.

QUANTITY DESCRIPTION: Height of profile of the individual subpart.

Count('corners')
This function is applicable to the Railing object and the following subparts: Guardrail and Handrail.

QUANTITY DESCRIPTION: For Railing object: Number of vertices that change the direction or height of the path without the beginning and end.

For Guardrail: Number of vertices that change the direction or height of the path without the beginning and end in the Guardrail subpart.

For Handrail: If there is no Guardrail, then number of vertices that change the direction or height of the path without the beginning and end in the Guardrail subpart.

Angle()
This function is applicable to the following subparts: Bar Vertical and Bar Horizontal.

QUANTITY DESCRIPTION: For Bar Vertical: Angle of the vertical bars(if option Rotate bars to diagonals on then 45° if not 0°.).

For Bar Horizontal: Angle of the horizontal bars(if option Rotate bars to diagonals on then 45° if not 0°.).

Angle('bar horizontal')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: For Railing object: Angle of the horizontal bars(if option Rotate bars to diagonals on then 45° if not 0°.).

Angle('bar vertical')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: For Railing object: Angle of the vertical bars(if option Rotate bars to diagonals on then 45° if not 0°.).

Area()
This function is applicable to the Railing object and the following subparts: Frame, Panel, Bracket and Face Post.

QUANTITY DESCRIPTION: For Railing object: Area of the entire Railing object.

For subpart: Area of the individual subpart.

Area('brackets')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Area of bracket subpart.

Area('face posts')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Area of face post subpart.

Area('frame')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the area of all frame subparts.

Area('panels')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the area of all panel subparts.

Perimeter()
This function is applicable to the Frame subpart.

QUANTITY DESCRIPTION: Frame: Perimeter of the Frame.

Perimeter('frame')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: For Railing object: Perimeter of all Frames.

Length()
This function is applicable to the Railing object and the following subparts: Handrail, Guardrail, Frame, Bar Vertical, Bar Horizontal, Bracket and Face Post.

QUANTITY DESCRIPTION: For Railing object: Length of the 3D object path.

For Handrail: Length of the 3D handrail.

For Guardrail: Length of the 3D guardrail.

For Frame: With of frame.

For Bar Vertical: Length of the bar vertical.

For Bar Horizontal: Length of the bar horizontal.

For Bracket: Handrail Offset + Bracket Height.

For Face Post: Width + height of face post.

Length('bar horizontal')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the length of all bar horizontal subparts.

Length('bar vertical')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the length of all bar vertical subparts.

Length('brackets')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Length of the bracket subpart.

Length('face posts')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Length of the face post subpart.

Length('frame')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Length of the frame subpart.

Length('guardrail')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the length of all guardrail subparts.

Length('handrail')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the length of all handrail subparts.

Length('max support spacing')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Maximum distance between posts if there no posts then returns the maximum distance between brackets.

SurfaceArea()
This function is applicable to the following subparts: Handrail, Guardrail, Post, Frame, Panel, Bar Vertical, Bar Horizontal, Bracket and Face Post.

QUANTITY DESCRIPTION: Complete outer surface area of subpart.

SurfaceArea('bar horizontal')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the surface area of all bar horizontal subparts.

SurfaceArea('bar vertical')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the surface area of all bar vertical subparts.

SurfaceArea('brackets')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Surface area of bracket.

SurfaceArea('face posts')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the surface area of all face post subparts.

SurfaceArea('frame')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the surface area of all frame subparts.

SurfaceArea('guardrail')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the surface area of all guardrail subparts.

SurfaceArea('handrail')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the surface area of all handrail subparts.

SurfaceArea('panels')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the surface area of all panel subparts.

SurfaceArea('posts')
This function is applicable to the Railing object.

QUANTITY DESCRIPTION: Sum of the surface area of all post subparts.

Specialized for Railing/Fence

Width()
Width([optional parameter])

This function is applicable to the following subparts: Wall Bracket, Face Mount, Frame and Panel.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Wall Bracket: Horizontal dimension of the Top Rails Wall Bracket.

For Face Mount: Horizontal dimension of the Face Mount Post.

For Frame: Width of the rectangular frame.

For Panel: Width of the panel in elevation.

Width('profile')
Width('profile', [optional parameter])

This function is applicable to the following subparts: Top Rail, Post, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Top Rail: Width of the Railings TopRail cross section profile. For round or octagonal shape of profile, width equals height. For custom profile (symbol), the bounding box is used to calculate this value.

For Post: Width of the Posts cross section profile.

For Crossbar Top and Crossbar Bottom: Width of the profile of the crossbar.

For Bar Vertical and Bar Horizontal: Width of the vertical bars profile.

Height()
Height([optional parameter])

This function is applicable to the Railing object and the following subparts: Top Rail, Wall Bracket, Post, Face Mount, Frame, Panel.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Railing object: The height of the railing, measured as the vertical distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the highest subpart of the Railing (Top Rail if available, Frame, Panel or Crossbar Top). This value is written into the IFC-field Pset_RailingCommon.Height.

For Top Rail: Height of the TopRail, measured as the distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the Railings Top Rail.

For Wall Bracket: Vertical dimension of the Top Rails Wall Bracket.

For Post: Height of the Post.

For Face Mount: Vertical dimension of the Face Mount Post.

For Frame: Height of the rectangular frame.

For Panel: Height of the panel in elevation.

Height('profile')
Height('profile', [optional parameter])

This function is applicable to the following subparts: Top Rail, Post, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Top Rail: Height of the Railings TopRail cross section profile. For round or octagonal shape of profile, width equals height. For custom profile (symbol), the bounding box is used to calculate this value.

For Post: Height of the Posts cross section profile.

For Crossbar Top and Crossbar Bottom: Height of the profile of the crossbar.

For Bar Vertical and Bar Horizontal: Height of the vertical bars profile.

Count('angle')
Count('angle', [optional parameter])

This function is applicable to the Railing object and the Top Rail.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Railing: Number of vertices that change the path without the beginning and end. Or IOW: the number of angles in the path..

For Top Rail: Number of angles in the Top Rail subpart.

Angle()
Angle([optional parameter])

This function is applicable to the following subparts: Bar Vertical and Bar Horizontal.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Bar Vertical: Angle of the vertical bars. Vertical is 0°.

For Bar Horizontal: Angle of the horizontal bar. horizontal is 0°.

Area()
Area([optional parameter])

This function is applicable to the Railing object and the Panel subpart.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Railing: Area of the Railing object measured by Railing Length multiplied by Railing Height. Length is the distance between the outer edges of the first and last post or between the infills, whichever results in the higher value. Extended handrails are excluded. This Length differs from buildingSMART standard which is stored in the Railing objects record field RailingLengthIFC. The height of the railing is measured as the vertical distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the highest subpart of the Railing (Top Rail if available, Frame, Panel or Crossbar Top).

For Panel: Area of the panel (Width x Height).

Perimeter()
Length()
Length([optional parameter])

This function is applicable to the Railing object and the following subparts: Top Rail, Crossbar Top, Crossbar Bottom, Bar Vertical, Bar Horizontal, Frame.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Railing object: It is the distance between the outer edges of the first and last post or between the infills, whichever results in the higher value. Extended handrails are excluded. This Length differs from buildingSMART standard which is stored in the Railing objects record field RailingLengthIFC and written into Qto_RailingBaseQuantities.Length and BaseQuantities.Length.

For Top Rail: Length of the 3D path object of the top rail including extensions of the Top Rail at beginning or end of the Railing object.

For Crossbar Top and Bottom: Length of the crossbar.

For Bar Vertical and Horizontal: Length of the bar.

For Frame: It is the same value as for Width when applied to a Frame.

Length('max')
Maximum occuring distance between the axes of all instances of a subparts.

Eligible subparts are Wall Bracket, Post and Face Mount.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Wall Bracket: Returns the maximum distance between the axes of all Wall Brackets occuring anywhere in the Railing object.

For Post: Maximum occuring distance between the axes of all posts.

For Face Mount: Maximum Distance between the axes of all Face Mounts.

SurfaceArea()
SurfaceArea([optional parameter])

This function is applicable to the following subparts: Top Rail, Wall Bracket, Post, Face Mount, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame, Panel.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Top Rail: Outer surface of the top rail on all sides including the two caps at beginning and end.

For Wall Bracket: Complete outer surface of the Top Rails Wall Bracket.

For Post: Complete Outer Surface of the Post including the sides which face the stair or wall or handrail.

For Face Mount: Complete Outer Surface of the Face Mount Post including the caps surfaces which are mounted against a wall, post, stair or other object.

For Crossbar Top and Bottom: Complete Surface of all sides of the crossbar.

Bar Vertical and Horizontal: Complete Surface of all sides of the bar.

For Frame: Complete Surface of the rectangular frame.

For Panel: Complete surface area of all sides of the panel.

Specialized for Roof

ObjectData('Component Name')
Returns the name of the wall, slab or roof component.
ObjectData('Cost Index Code')
ObjectData('Cost Index System')
ObjectData('Description')
ObjectData('Exterior')
ObjectData('Fire Rating')
ObjectData('Function')
ObjectData('Lambda')
Returns the Lambda value of the object.
ObjectData('Manufacturer')
ObjectData('Mark')
ObjectData('Model')
ObjectData('RValue')
Returns the R-Value of the object.
ObjectData('UValue')
Returns the U-Value of the object.
RoofArea_Total()
Returns the total area along the slope of a roof.
Database header cell:
=RoofArea_Total returns the total area for each roof and roof face object in the database

Spreadsheet cell:
=RoofArea_Total(st=roofface) returns the combined total area of all roof face objects in the drawing
RoofArea_Heated()
Returns the heated area along the slope of a roof.

The heated area is the area that does not include an overhang.

Database header cell:
=RoofArea_Heated returns the heated area for each roof and roof face object in the database

Spreadsheet cell:
=RoofArea_Heated (st=roofface) returns the combined heated area of all roof face objects in the drawing
RoofArea_TotalProj()
Returns the total area of a roof projected on the active layer plane.
Database header cell:
=RoofArea_TotalProj returns the total area for each roof and roof face object in the database, as projected to the layer plane

Spreadsheet cell:
=RoofArea_Totalproj(t=roof) returns the combined total area of all roof objects in the drawing, as projected to the layer plane
RoofArea_HeatedProj()
Returns the heated area of a roof projected on the active layer plane.

The heated area is the area that does not include an overhang.

Database header cell:
=RoofArea_HeatedProj returns the heated area for each roof and roof face object in the database, as projected to the layer plane

Spreadsheet cell:
=RoofArea_HeatedProj (t=roof) returns the combined heated area of all roof objects in the drawing, as projected to the layer plane
RoofStyleName()
Returns the name the roof style used by the object.
Database header cell:
=RoofStyleName returns the roof style name for each roof object in the database

Spreadsheet cell:
=RoofStyleName(n='roof-1') returns the roof style name for the object named “roof-1”

Specialized for Site Model

Depth()
Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
ProjectedArea()
Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
ObjectData('component name')
Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
Area()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
SurfaceArea()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
SurfaceArea( 'existing' )
Calculate the existing surface area of the Site Model and their components.
Database header cell:
=SURFACEAREA('Existing')     Returns the existing Surface Area for Site Model object or component in the DB row.

Spreadsheet cell:
=SURFACEAREA(SEL, 'Existing')    Returns the existing Surface Area for the selected Site Model object.
SurfaceArea( 'proposed' )
Calculate the proposed surface area of the Site Model and their components.
Database header cell:
=SURFACEAREA('Proposed')     Returns the proposed Surface Area for Site Model object or component in the DB row.

Spreadsheet cell:
=SURFACEAREA(SEL, 'Proposed')    Returns the proposed Surface Area for the selected Site Model object.
Volume()
Calculate the volume of the Curb, Landscape Area, Hardscape, or Site Model and their components.
Volume('existing')
Calculate the existing volume of the Site Model and their components.
Database header cell:
=VOLUME('existing')     	Returns the existing volume for Site Model object or component in the DB row.

Spreadsheet cell:
=VOLUME(SEL, 'existing')    Returns the existing volume for the selected Site Model object.
Volume('proposed')
Calculate the proposed volume of the Site Model and their components.
Database header cell:
=VOLUME('proposed')     	Returns the proposed volume for Site Model object or component in the DB row.

Spreadsheet cell:
=VOLUME(SEL, 'proposed')    Returns the proposed volume for the selected Site Model object.

Specialized for Slab

Weight('gross', [optional parameters])
Returns the weight of a wall, wall component, slab or slab component. All openings are ignored.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

Weight('net', [optional parameters])
Returns the weight of a wall, wall component, slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

ObjectData('Acoustic Rating')
ObjectData('Combustible Construction')
ObjectData('Compartmentation')
ObjectData('Component Name')
Returns the name of the wall, slab or roof component.
ObjectData('Cost Index Code')
ObjectData('Cost Index System')
ObjectData('Description')
ObjectData('Exterior')
ObjectData('Fire Rating')
ObjectData('Function')
ObjectData('Lambda')
Returns the Lambda value of the object.
ObjectData('Load Bearing')
ObjectData('Manufacturer')
ObjectData('Mark')
ObjectData('Model')
ObjectData('RValue')
Returns the R-Value of the object.
ObjectData('UValue')
Returns the U-Value of the object.
Width()
Returns the thickness of a wall, slab, roof or a roof face object or their components.
Count('modifiers', [optional parameters])
Returns the number of modifiers in a slab or wall. For walls, recesses and projections are counted. For slabs, additions, subtractions and drains are counted.

'modifier type=...': If provided, only modifiers with any of the given types are counted. Multiple types can be delimited by a semicolon.

'exclude modifier type=...': If provided, modifiers with any of the given types will not be counted.

Count('openings', [optional parameters])
Returns the number of openings in a wall, wall component, slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only openings in the components with the given material will be counted.

'component=...': If provided, only openings in the given components will be counted. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

opening criteria: If provided, only openings that satisfy all given criteria will be counted. If the values don't have any units specified, millimeters, square millimeters or cubic millimeters will be assumed. For slabs, the following criteria are available: min opening area top, max opening area top, min opening area bottom, max opening area bottom, min opening volume, max opening volume, min opening perimeter top, max opening perimeter top, min opening perimeter bottom, max opening perimeter bottom. For walls, the following criteria are available: min opening area left, max opening area left, min opening area right, max opening area right, min opening area facing core, max opening area facing core, min opening area avert core, max opening area avert core, min opening area center, max opening area center, min opening area footprint, max opening area footprint, min opening length footprint left, max opening length footprint left, min opening length footprint right, max opening length footprint right, min opening length footprint facing core, max opening length footprint facing core, min opening length footprint avert core, max opening length footprint avert core, min opening length footprint center, max opening length footprint center, min opening volume, max opening volume.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

'height=...': Specifies the height relative to the layer plane at which the footprint area and length along footprint criteria are measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

=Count('openings') returns the number of openings in the wall, wall component, slab or slab component.

=Count('openings', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters.

=Count('openings', 'min opening area top=0.5 sq m', 'max opening area top=1 sq m') returns the number of openings with an area between 0.5 and 1 square meter on the top of the slab or slab component.

=Count('openings', 'min opening area bottom=1 sq ft', 'max opening volume=10 cu in') returns the number of openings with an area of at least 1 square foot on the bottom of the slab or slab component and a volume of at most 10 cubic inches.

=Count('openings', 'opening type=Window') returns the number of openings created by "Window" plug-in objects.

=Count('openings', 'opening type=Window;WinDoor 6.0') returns the number of openings created by "Window" and "WinDoor 6.0" plug-in objects.

=Count('openings', 'component=core', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters in the wall core component.

The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.
Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.
SlabThickness()
Returns the thickness of slab objects.
Database header cell:
=SlabThickness returns the thickness for each object in the database

Spreadsheet cell:
=SlabThickness(PON=slab) returns the combined thickness of all slab objects in the drawing
SlabStyleName()
Returns the name of the slab style used by the slab.
Database header cell:
=SlabStyleName returns the name of the slab style for each slab object in the database

Spreadsheet cell:
=SlabStyleName(n='slab-1') returns the name of the slab style for the object named “slab-1”
Area()
Returns the area of a wall, slab, roof or a roof face object or their components.
Perim('bottom', [optional parameters])
Returns the perimeter of the bottom surface of a slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

Perim('openings bottom', [optional parameters])
Returns the sum of the opening perimeters on the bottom surface of a slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening perimeter=...' / 'max opening perimeter=...': If provided, only openings with a perimeter of at least min opening perimeter and at most max opening perimeter will be included. If the values don't have any units specified, millimeters will be assumed.

Perim('openings top', [optional parameters])
Returns the sum of the opening perimeters on the top surface of a slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening perimeter=...' / 'max opening perimeter=...': If provided, only openings with a perimeter of at least min opening perimeter and at most max opening perimeter will be included. If the values don't have any units specified, millimeters will be assumed.

Perim('top', [optional parameters])
Returns the perimeter of the top surface of a slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

SurfaceArea('bottom gross', [optional parameters])
Returns the area of the bottom surface of a slab or slab component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

=SurfaceArea('bottom gross') returns the gross area of the bottom face of the slab or slab component.

=SurfaceArea('bottom gross', 'component=top') returns the gross area of the bottom face of the top component of the slab.
SurfaceArea('bottom net', [optional parameters])
Returns the area of the bottom surface of a slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

=SurfaceArea('bottom net') returns the area of the bottom face of the slab or slab component.

=SurfaceArea('bottom net', 'min opening area=0.5 sq m') returns the area of the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('bottom net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('bottom net', 'component=top') returns the area of the bottom face of the top component of the slab.
SurfaceArea('openings bottom', [optional parameters])
Returns the area of the openings on the bottom surface of a slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

=SurfaceArea('openings bottom') returns the total area of openings on the bottom face of the slab or slab component.

=SurfaceArea('openings bottom', 'min opening area=0.5 sq m') returns the total area of openings on the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('openings bottom', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('openings bottom', 'component=top') returns the total area of openings on the bottom face of the top component of the slab.
SurfaceArea('openings top', [optional parameters])
Returns the area of the openings on the top surface of a slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

=SurfaceArea('openings top') returns the total area of openings on the top face of the slab or slab component.

=SurfaceArea('openings top', 'min opening area=0.5 sq m') returns the total area of openings on the top face of the slab or slab component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('openings top', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the top face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('openings top', 'component=bottom') returns the total area of openings on the top face of the bottom component of the slab.
SurfaceArea('top gross', [optional parameters])
Returns the area of the top surface of a slab or slab component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

=SurfaceArea('top gross') returns the gross area of the top face of the slab or slab component.

=SurfaceArea('top gross', 'component=bottom') returns the gross area of the top face of the bottom component of the slab.
SurfaceArea('top net', [optional parameters])
Returns the area of the top surface of a slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

=SurfaceArea('top net') returns the area of the top face of the slab or slab component.

=SurfaceArea('top net', 'min opening area=0.5 sq m') returns the area of the top face of the slab or slab component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('top net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the top face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('top net', 'component=bottom') returns the area of the top face of the bottom component of the slab.
Volume()
Returns the volume of a wall, slab, roof or a roof face object or their components.
Volume('gross', [optional parameters])
Returns the volume of a wall, wall component, slab or slab component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

=Volume('gross') returns the gross volume of the wall, wall component, slab or slab component.

=Volume('gross', 'component=core') returns the gross volume of the core wall component.
Volume('net', [optional parameters])
Returns the volume of a wall, wall component, slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

=Volume('net') returns the volume of the wall, wall component, slab or slab component.

=Volume('net', 'min opening volume=10 cu cm') returns the volume of the wall, wall component, slab or slab component, but only taking openings with at least 10 cubic centimeters of volume into account.

=Volume('net', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the volume of the wall, wall component, slab or slab component, but only taking openings with between 10 cubic centimeters and 1 cubic meter of volume into account.

=Volume('net', 'opening type=Window') returns the volume of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=Volume('net', 'opening type=Window;WinDoor 6.0') returns the volume of the wall or wall component, but only taking openings created by "Window" and "WinDoor 6.0" plug-in objects into account.

=Volume('net', 'component=core', 'min opening volume=10 cu cm') returns the volume of the core wall component, but only taking openings with a volume of at least 10 cubic centimeters into account.
Volume('openings', [optional parameters])
Returns the volume of the openings in a wall, wall component, slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

=Volume('openings') returns the total volume of openings in the wall, wall component, slab or slab component.

=Volume('openings', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters.

=Volume('openings', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the total volume of openings with a volume of at least 10 cubic centimeters and at most 1 cubic meter.

=Volume('openings', 'opening type=Window') returns the total volume of openings created by "Window" plug-in objects.

=Volume('openings', 'opening type=Window;WinDoor 6.0') returns the total volume of openings created by "Window" and "WinDoor 6.0" plug-in objects.

=Volume('openings', 'component=core', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters in the wall core component.

Specialized for Socket

ObjectData('eval socket circuits', '<RecordName>', '<FieldName>')
Get parameter values or attached record fields from the socket's connected circuits.
ObjectData('eval socket device', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the socket's device.

Specialized for Space

ObjectData('finish', field_name, [delimiter], [location], [wall_index])
Returns the value of the field named 'field_name' in a Space_Finish record.

The function is applicable to the Space object and any of its subobjects that have a Space_FinishSurface or Space_Finish record attached to them. In the latter case, the function will just return the value of the record field. In the former two cases, the function will list the Space_Finish record field values for all subobjects that fit the given 'location' and 'wall index' criteria, separated by the given 'delimiter'.

'delimiter': Could be any string. Will be added between each of the returned values. Use '\n' to have each value on a separate line. By default, the values will be comma-separated.

'location': Could be 'floor', 'base', 'walls', 'ceiling', 'north', 'east', 'south' or 'west'. If this parameter is provided, only finishes with the given location will be listed.

'wall_index': The index of a wall, whose value should be listed. Only applicable if 'walls' is used for the 'location' parameter. If not provided, all wall values will be listed.

In a database header, for each Space object.
=ObjectData('finish', 'FinishKey', ', ') - Lists the finish key of all finishes used in a space, separated by a comma.
=ObjectData('finish', 'FinishKey', '\n') - Lists the finish key of all finishes used in a space, each on a new line.
=ObjectData('finish', 'FinishKey', ', ', 'floor') - Lists the finish key of all finishes used for the floors in a space.
=ObjectData('finish', 'FinishKey', ', ', 'walls') - Lists the finish key of all finishes used for the walls in a space.
=ObjectData('finish', 'FinishKey', ', ', 'walls', 1) - Lists the finish key of all finishes used for the first wall in a space.
=ObjectData('finish', 'FinishKey', ', ', 'walls', 2) - Lists the finish key of all finishes used for the second wall in a space.

In a database header, for each Space subpart, where Space_Finish is present.
=ObjectData('finish', 'FinishKey') - Equivalent to ='Space_Finish'.'FinishKey'
=ObjectData('finish', 'FinishKey', '', 'ceiling') - Returns the key of the finish, only if the finish is applied to the ceiling.
=ObjectData('finish', 'FinishKey', '', 'walls', 1) - Returns the key of the finish, only if the finish is applied to the first wall.
GetSpaceNameForObj()
Returns the name of the space that surrounds the object.
Database header cell:
=GetSpaceNameForObj returns the space name for each object in the database

Spreadsheet cell:
=GetSpaceNameForObj(n='chair-1') returns the space name for the object named “chair-1”
GetSpaceNumForObj()
Returns the number of the space that surrounds the object.
Database header cell:
=GetSpaceNumForObj returns the space number for each object in the database

Spreadsheet cell:
=GetSpaceNumForObj(n='chair-1') returns the space number for the object named “chair-1”

Specialized for Structural Member

ObjectData(criteria, 'cover bound bottom')
Returns the bottom bound of the structural member cover.
Database header cell:
=OBJECTDATA('cover bound bottom')     Returns the bottom bound of the Structural Member cover.

Spreadsheet cell:
=OBJECTDATA(SEL, 'cover bound bottom')    Returns the bottom bound of the Structural Member cover.
ObjectData(criteria, 'cover bound top')
Returns the top bound of the Structural Member cover.
Database header cell:
=OBJECTDATA('cover bound top')     Returns the top bound of the Structural Member cover.

Spreadsheet cell:
=OBJECTDATA(SEL, 'cover bound top')    Returns the top bound of the Structural Member cover.
ObjectData(criteria, 'cover physical length')
Returns the physical length of the structural member cover including its start and end conditions.
Database header cell:
=OBJECTDATA('cover physical length')     Returns the physical length of the structural member cover including its start and end conditions.

Spreadsheet cell:
=OBJECTDATA(SEL, 'cover physical length')    Returns the physical length of the structural member cover including its start and end conditions.
ObjectData(criteria, 'member bound bottom')
Returns the bottom bound of the Structural Member.
Database header cell:
=OBJECTDATA('member bound bottom')     Returns the bottom bound of the Structural Member.

Spreadsheet cell:
=OBJECTDATA(SEL, 'member bound bottom')    Returns the bottom bound of the Structural Member.
ObjectData(criteria, 'member bound top')
Returns the top bound of the Structural Member.
Database header cell:
=OBJECTDATA('member bound top')     Returns the top bound of the Structural Member.

Spreadsheet cell:
=OBJECTDATA(SEL, 'member bound top')    Returns the top bound of the Structural Member.
ObjectData(criteria, 'member physical length')
Returns the physical length of the structural member including its start and end conditions.
Database header cell:
=OBJECTDATA('member physical length')     Returns the physical length of the structural member including its start and end conditions.

Spreadsheet cell:
=OBJECTDATA(SEL, 'member physical length')    Returns the physical length of the structural member including its start and end conditions.

Specialized for Wall

Weight('gross', [optional parameters])
Returns the weight of a wall, wall component, slab or slab component. All openings are ignored.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

Weight('net', [optional parameters])
Returns the weight of a wall, wall component, slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

FootPrintArea('gross', [optional parameters])
Returns the footprint area of a wall or wall component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

FootPrintArea('net', [optional parameters])
Returns the footprint area of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

FootPrintArea('openings', [optional parameters])
Returns the area of the openings in the footprint of a wall or wall component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

ObjectData('Acoustic Rating')
ObjectData('Combustible Construction')
ObjectData('Compartmentation')
ObjectData('Component Name')
Returns the name of the wall, slab or roof component.
ObjectData('Cost Index Code')
ObjectData('Cost Index System')
ObjectData('Description')
ObjectData('Exterior')
ObjectData('Fire Rating')
ObjectData('Function')
ObjectData('Lambda')
Returns the Lambda value of the object.
ObjectData('Load Bearing')
ObjectData('Manufacturer')
ObjectData('Mark')
ObjectData('Model')
ObjectData('Path Type')
Returns the path type of a wall. 0 is line, and 1 is arc.
ObjectData('RValue')
Returns the R-Value of the object.
ObjectData('UValue')
Returns the U-Value of the object.
Width()
Returns the thickness of a wall, slab, roof or a roof face object or their components.
Height('average')
Returns the average height of a wall, including wall peaks and different starting and ending heights.
Height('overall')
Returns the overall height of a wall.
Count('inserts', [optional parameters])
Returns the number of inserts (symbols and parametric objects) in a wall.

'insert type=...': If provided, only inserts with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude insert type=...': If provided, inserts with any of the given types will not be counted.

=Count('inserts') returns the number of inserts in the wall object.

=Count('inserts', 'insert type=Window') returns the number of "Window" plug-in object inserts.

=Count('inserts', 'insert type=Window;WinDoor 6.0') returns the number of by "Window" and "WinDoor 6.0" plug-in object inserts.

The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.
Count('modifiers', [optional parameters])
Returns the number of modifiers in a slab or wall. For walls, recesses and projections are counted. For slabs, additions, subtractions and drains are counted.

'modifier type=...': If provided, only modifiers with any of the given types are counted. Multiple types can be delimited by a semicolon.

'exclude modifier type=...': If provided, modifiers with any of the given types will not be counted.

Count('openings', [optional parameters])
Returns the number of openings in a wall, wall component, slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only openings in the components with the given material will be counted.

'component=...': If provided, only openings in the given components will be counted. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

opening criteria: If provided, only openings that satisfy all given criteria will be counted. If the values don't have any units specified, millimeters, square millimeters or cubic millimeters will be assumed. For slabs, the following criteria are available: min opening area top, max opening area top, min opening area bottom, max opening area bottom, min opening volume, max opening volume, min opening perimeter top, max opening perimeter top, min opening perimeter bottom, max opening perimeter bottom. For walls, the following criteria are available: min opening area left, max opening area left, min opening area right, max opening area right, min opening area facing core, max opening area facing core, min opening area avert core, max opening area avert core, min opening area center, max opening area center, min opening area footprint, max opening area footprint, min opening length footprint left, max opening length footprint left, min opening length footprint right, max opening length footprint right, min opening length footprint facing core, max opening length footprint facing core, min opening length footprint avert core, max opening length footprint avert core, min opening length footprint center, max opening length footprint center, min opening volume, max opening volume.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

'height=...': Specifies the height relative to the layer plane at which the footprint area and length along footprint criteria are measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

=Count('openings') returns the number of openings in the wall, wall component, slab or slab component.

=Count('openings', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters.

=Count('openings', 'min opening area top=0.5 sq m', 'max opening area top=1 sq m') returns the number of openings with an area between 0.5 and 1 square meter on the top of the slab or slab component.

=Count('openings', 'min opening area bottom=1 sq ft', 'max opening volume=10 cu in') returns the number of openings with an area of at least 1 square foot on the bottom of the slab or slab component and a volume of at most 10 cubic inches.

=Count('openings', 'opening type=Window') returns the number of openings created by "Window" plug-in objects.

=Count('openings', 'opening type=Window;WinDoor 6.0') returns the number of openings created by "Window" and "WinDoor 6.0" plug-in objects.

=Count('openings', 'component=core', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters in the wall core component.

The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.
Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.
WallArea_Net()
Returns the average of the net area of the interior and exterior face of the wall. The net area is adjusted for holes in the wall.
Database header cell:
=WallArea_Net returns the average of the net area of the interior and exterior face of the wall, for each wall in the database; the net area is adjusted for holes in the wall

Spreadsheet cell:
=WallArea_Net(t=wall) returns the average of the net area of the interior and exterior face of the wall, combined for all walls in the drawing; the net area is adjusted for holes in the wall
WallArea_Gross()
Returns the average of the gross area of the interior and exterior face of the wall. The gross area ignores holes in the wall.
Database header cell:
=WallArea_Gross returns the average of the gross area of the interior and exterior face of the wall, for each wall in the database; the gross area ignores holes in the wall

Spreadsheet cell:
=WallArea_Gross(t=wall) returns the average of the gross area of the interior and exterior face of the wall, combined for all walls in the drawing; the gross area ignores holes in the wall
WallAverageHeight()
Returns the average wall height of a wall, including wall peaks and different starting and ending heights.
Database header cell:
=WallAverageHeight returns the average height for each wall object in the database

Spreadsheet cell:
=WallAverageHeight((t=wall)&(sel=true)) returns the average height of all walls that are selected in the drawing
WallThickness()
Returns the thickness of the wall.
Database header cell:
=WallThickness returns the thickness for each wall object in the database

Spreadsheet cell:
=WallThickness(t=wall) returns the combined thickness of all walls in the drawing
WallStyleName()
Returns the name of the wall style used by the wall.
Database header cell:
=WallStyleName returns the name of the wall style for each wall object in the database

Spreadsheet cell:
=WallStyleName(n='wall-1') returns the name of the wall style for the object named “wall-1”
Area()
Returns the area of a wall, slab, roof or a roof face object or their components.
Length()
Returns the length of a wall or its components.
Length('control line avert core', [optional parameters])
Returns the length of the control line of a wall component on the side that's oriented away from the core component. All openings, recesses, projections and peaks are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

Length('control line center', [optional parameters])
Returns the length of the central control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

Length('control line facing core', [optional parameters])
Returns the length of the control line of a wall component on the side that's oriented towards the core component. All openings, recesses, projections and peaks are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

Length('control line left', [optional parameters])
Returns the length of the left control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

Length('control line right', [optional parameters])
Returns the length of the right control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

Length('avert core gross', [optional parameters])
Returns the length of a wall component along the bottom of the side that's oriented away from the core component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('avert core net', [optional parameters])
Returns the length of a wall component along the bottom of the side that's oriented away from the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('center gross', [optional parameters])
Returns the length of a wall or wall component along the bottom of the center line. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('center net', [optional parameters])
Returns the length of a wall or wall component along the bottom of the center line.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('facing core gross', [optional parameters])
Returns the length of a wall component along the bottom of the side that's oriented towards the core component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('facing core net', [optional parameters])
Returns the length of a wall component along the bottom of the side that's oriented towards the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('left gross', [optional parameters])
Returns the length of a wall or wall component along the bottom of the left face. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('left net', [optional parameters])
Returns the length of a wall or wall component along the bottom of the left face.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('right gross', [optional parameters])
Returns the length of a wall or wall component along the bottom of the right face. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('right net', [optional parameters])
Returns the length of a wall or wall component along the bottom of the right face.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('openings avert core', [optional parameters])
Returns the total length of wall or wall component openings along the side of the footprint that's oriented away from the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('openings center', [optional parameters])
Returns the total length of openings along the center line of the footprint of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('openings facing core', [optional parameters])
Returns the total length of wall or wall component openings along the side of the footprint that's oriented towards the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('openings left', [optional parameters])
Returns the total length of openings along the left side of the footprint of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('openings right', [optional parameters])
Returns the total length of openings along the right side of the footprint of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

SurfaceArea('avert core gross', [optional parameters])
Returns the area of a wall component's surface that's oriented away from the core component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.

SurfaceArea('avert core net', [optional parameters])
Returns the area of a wall component's surface that's oriented away from the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

SurfaceArea('center gross', [optional parameters])
Returns the area along the center line of a wall or wall component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.

=SurfaceArea('center gross') returns the gross area along the center line of the wall or wall component.

=SurfaceArea('center gross', 'component=core') returns the gross area along the center line of the core component of the wall.
SurfaceArea('center net', [optional parameters])
Returns the area along the center line of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

=SurfaceArea('center net') returns the area along the center line of the wall or wall component.

=SurfaceArea('center net', 'min opening area=0.5 sq m') returns the area along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('center net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('center net', 'opening type=Window') returns the area along the center line of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('center net', 'exclude opening type=Window') returns the area along the center line of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('center net', 'opening type=Window;WinDoor 6.0') returns the area along the center line of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('center net', 'component=core') returns the area along the center line of the core component of the wall.
SurfaceArea('facing core gross', [optional parameters])
Returns the area of a wall component's surface that's oriented towards the core component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.

SurfaceArea('facing core net', [optional parameters])
Returns the area of a wall component's surface that's oriented towards the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

SurfaceArea('left gross', [optional parameters])
Returns the area of the left surface of a wall or wall component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.

=SurfaceArea('left gross') returns the gross area of the left side of the wall or wall component.

=SurfaceArea('left gross', 'component=core') returns the gross area of the left side of the core component of the wall.
SurfaceArea('left net', [optional parameters])
Returns the area of the left surface of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'include closures': If provided, the surfaces of splay/wrap faces will be included in the calculation.

=SurfaceArea('left net') returns the area of the left side of the wall or wall component.

=SurfaceArea('left net', 'min opening area=0.5 sq m') returns the area of the left side of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('left net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the left side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('left net', 'opening type=Window') returns the area of the left side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('left net', 'exclude opening type=Window') returns the area of the left side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('left net', 'opening type=Window;WinDoor 6.0') returns the area of the left side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('left net', 'component=core') returns the area of the left side of the core component of the wall.
SurfaceArea('openings avert core', [optional parameters])
Returns the area of the openings on a wall component's surface that's oriented away from the core component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

SurfaceArea('openings center', [optional parameters])
Returns the area of the openings along the center line of a wall or wall component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

=SurfaceArea('openings center') returns the total area of openings along the center line of the wall or wall component.

=SurfaceArea('openings center', 'min opening area=0.5 sq m') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('openings center', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('openings center', 'opening type=Window') returns the total area of openings along the center line of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('openings center', 'exclude opening type=Window') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('openings center', 'opening type=Window;WinDoor 6.0') returns the total area of openings along the center line of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('openings center', 'component=core') returns the total area of openings along the center line of the core component of the wall.
SurfaceArea('openings facing core', [optional parameters])
Returns the area of the openings on a wall component's surface that's oriented towards the core component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

SurfaceArea('openings left', [optional parameters])
Returns the area of the openings on the left surface of a wall or wall component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

=SurfaceArea('openings left') returns the total area of openings on the left side of the wall or wall component.

=SurfaceArea('openings left', 'min opening area=0.5 sq m') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('openings left', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('openings left', 'opening type=Window') returns the total area of openings on the left side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('openings left', 'exclude opening type=Window') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('openings left', 'opening type=Window;WinDoor 6.0') returns the total area of openings on the left side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('openings left', 'component=core') returns the total area of openings on the left side of the core component of the wall.
SurfaceArea('openings right', [optional parameters])
Returns the area of the openings on the right surface of a wall or wall component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

=SurfaceArea('openings right') returns the total area of openings on the right side of the wall or wall component.

=SurfaceArea('openings right', 'min opening area=0.5 sq m') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('openings right', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('openings right', 'opening type=Window') returns the total area of openings on the right side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('openings right', 'exclude opening type=Window') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('openings right', 'opening type=Window;WinDoor 6.0') returns the total area of openings on the right side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('openings right', 'component=core') returns the total area of openings on the right side of the core component of the wall.
SurfaceArea('right gross', [optional parameters])
Returns the area of the right surface of a wall or wall component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.

=SurfaceArea('right gross') returns the gross area of the right side of the wall or wall component.

=SurfaceArea('right gross', 'component=core') returns the gross area of the right side of the core component of the wall.
SurfaceArea('right net', [optional parameters])
Returns the area of the right surface of a wall or wall component.

'component name=...': If provided, components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'offset from start=...' / 'offset from end=...': If provided, the area will only be measured starting from the given offset from the start of the wall path up to the given offset from the end of the wall path.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'include closures': If provided, the surfaces of splay/wrap faces will be included in the calculation.

=SurfaceArea('right net') returns the area of the right side of the wall or wall component.

=SurfaceArea('right net', 'min opening area=0.5 sq m') returns the area of the right side of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('right net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the right side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('right net', 'opening type=Window') returns the area of the right side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('right net', 'exclude opening type=Window') returns the area of the right side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('right net', 'opening type=Window;WinDoor 6.0') returns the area of the right side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('right net', 'component=core') returns the area of the right side of the core component of the wall.
Volume()
Returns the volume of a wall, slab, roof or a roof face object or their components.
Volume('gross', [optional parameters])
Returns the volume of a wall, wall component, slab or slab component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

=Volume('gross') returns the gross volume of the wall, wall component, slab or slab component.

=Volume('gross', 'component=core') returns the gross volume of the core wall component.
Volume('net', [optional parameters])
Returns the volume of a wall, wall component, slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

=Volume('net') returns the volume of the wall, wall component, slab or slab component.

=Volume('net', 'min opening volume=10 cu cm') returns the volume of the wall, wall component, slab or slab component, but only taking openings with at least 10 cubic centimeters of volume into account.

=Volume('net', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the volume of the wall, wall component, slab or slab component, but only taking openings with between 10 cubic centimeters and 1 cubic meter of volume into account.

=Volume('net', 'opening type=Window') returns the volume of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=Volume('net', 'opening type=Window;WinDoor 6.0') returns the volume of the wall or wall component, but only taking openings created by "Window" and "WinDoor 6.0" plug-in objects into account.

=Volume('net', 'component=core', 'min opening volume=10 cu cm') returns the volume of the core wall component, but only taking openings with a volume of at least 10 cubic centimeters into account.
Volume('openings', [optional parameters])
Returns the volume of the openings in a wall, wall component, slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

=Volume('openings') returns the total volume of openings in the wall, wall component, slab or slab component.

=Volume('openings', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters.

=Volume('openings', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the total volume of openings with a volume of at least 10 cubic centimeters and at most 1 cubic meter.

=Volume('openings', 'opening type=Window') returns the total volume of openings created by "Window" plug-in objects.

=Volume('openings', 'opening type=Window;WinDoor 6.0') returns the total volume of openings created by "Window" and "WinDoor 6.0" plug-in objects.

=Volume('openings', 'component=core', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters in the wall core component.
WallOverallHeight()
Returns the overall height of walls.
Database header cell:
=WallOverallHeight returns the average overall height for each wall object in the database

Spreadsheet cell:
=WallOverallHeight((t=wall)&(sel=true)) returns the average overall height of all walls that are selected in the drawing

Specialized for WinDoor 6.0

Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.

Specialized for Window

Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.
Volume(criteria, 'glazing all')
Returns the total volume of all glazing.
Database header cell:
=VOLUME('glazing all')     Returns the total volume of all glazing.

Spreadsheet cell:
=VOLUME(SEL, 'glazing all')    Returns the total volume of all glazing.
Volume(criteria, 'glazing for sashes')
Returns the volume of glazing for all sashes except the transom.
Database header cell:
=VOLUME('glazing for sashes')     Returns the volume of glazing for all sashes except the transom.

Spreadsheet cell:
=VOLUME(SEL, 'glazing for sashes')    Returns the volume of glazing for all sashes except the transom.
Volume(criteria, 'glazing for transom')
Returns the volume of glazing for the transom.
Database header cell:
=VOLUME('glazing for transom')     Returns the volume of glazing for the transom.

Spreadsheet cell:
=VOLUME(SEL, 'glazing for transom')    Returns the volume of glazing for the transom.
Volume(criteria, 'window jamb')
Returns the volume of all geometry that makes up the Jamb and Mullions.
Database header cell:
=VOLUME('window jamb')     Returns the volume of all geometry that makes up the Jamb and Mullions.

Spreadsheet cell:
=VOLUME(SEL, 'window jamb')   Returns the volume of all geometry that makes up the Jamb and Mullions.
Volume(criteria, 'window sashes')
Returns the total volume the all sashes (including the transom sash).
Database header cell:
=VOLUME('window sashes')     Returns the total volume the all sashes (including the transom sash).

Spreadsheet cell:
,VOLUME(SEL, 'window sashes')    Returns the total volume the all sashes (including the transom sash).

Specialized for Window CW

Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.

Text

concat(text1, text2,...)
Joins several text strings into one text string.
=concat(B3,', ',B4) returns the contents of cells B3 and B4 as a single string, separated by a comma and a space
SubString(text, delimiter, index)
Splits a single string into an array of strings using a delimiter, and returns the string at the specified index.
=SUBSTRING('kitchen;bedroom;bathroom;basement', ';', 2) returns “bedroom,” which is the second substring in the specified string
txt(value, ToUnit, [Param1], [Param2], ...)
Converts a numeric value from document units to the specified units and returns a string representation using the options to control formatting. More information is available in the example.
The first parameter must be <ToUnit> and then a list of optional parameters to fine tune the conversion.

Parameter Details:
 - <ToUnit> - the units in which the value will be converted from the current document units
	Possible options are for using the current document units:
		Dim		- linear dimension 
		Area	- area dimension
		Volume	- volume dimension
		Angle	- angular dimension
		
	General purpose options:
		General	- as a general number
		Sci		- as a scienific number
		Percent	- as a percent number
	
	Linear specific units options (one of the list):
		FeetNInches, Inches, Feet, Miles, Yards, Microns, Millimeters, Centimeters, Meters, Kilometers, Degrees, Ares
	
	Area specific units options (one of the list):
		SquareInches, SquareFeet, SquareYards, SquareMiles, Acres, SquareMicrons, SquareMillimeters, SquareCentimeters, SquareMeters, SquareKilometers, Hectares
	
	Volume specific units options (one of the list):
		CubicInches, CubicFeet, CubicYards, Gallons, CubicMillimeters, CubicCentimeters, CubicMeters, Litres

 - <optional param> - rounding style
		Dec		- decimal representation of the number
		Frac	- fractional representation of the number
		Auto	- will use fractional representation if rounds up to one, or decimal representation if not

 - <optional param> - rounding format
	Decimal rounding represented by the number of digits after the decimal dot.
	Examples:
		0.000	- would round up three digits. e.g. 0.356 if the number is 0.3556678
		0.0		- would round up one digit. e.g. 0.4 if the number is 0.3556678
		0.		- would round up to no digits. e.g. 0 if the number is 0.3556678
	
	Fractional rounding represented by the number after the / symbol, from 1/1 to 1/64 max.
	Examples:
		1/8		- would round to 1/8th
		1/64	- would round to 1/64th
		1/1		- would round to integer number

- <optional param> - rounding base using multiples of tenths, quarters, or halves
		RoundTenth
		RoundQuarter
		RoundHalf

- <optional param> - Units display
		NoUnits
		Units

- <optional param> - thousands separator display
		ThousandsSeparator
		NoThousandsSeparator

- <optional param> - trailing zero display
		NoTrailingZero
		TrailingZero

- <optional param> - leading zero
		NoLeadingZeroes
		LeadingZeroes

Examples:
=TXT(2.45, 'Dim') - returns the number in the documents linear dimensions
=TXT(2.45, 'Feet', 'Frac', '1/16') - returns the number in feet as fraction with 1/16 rounding
isalnum(text)
True if all characters in the string are letters and/or digits and there is at least one character or digit, false otherwise. Real numbers will return False.
=isalnum('word123') returns True
isalpha(text)
True if all characters in the string are alphabetic and there is at least one character, false otherwise.
=isalpha('word') returns True
isdigit(text)
True if all characters in the string are digits and there is at least one digit, false otherwise. Real numbers will return False.
=isdigit('1234') returns True
islower(text)
True if all cased characters in the string are lowercase and there is at least one cased character, false otherwise. Non-alphabetic characters don't have a case and will return true.
=islower('does not have upper char') returns True
isspace(text)
True if there are only whitespace characters in the string and there is at least one character, false otherwise.
=isspace('      ') returns True
istitle(text)
True if the string is a titlecased string and there is at least one character, for example uppercase characters may only follow uncased characters and lowercase characters only cased ones. False otherwise.
=isTitle('This Is Title Text') returns True
isupper(text)
True if all cased characters in the string are uppercase and there is at least one cased character, false otherwise. Non-alphabetic characters don't have a case and will return true.
=isUpper('DOES NOT HAVE LOWER CHARS') returns True
TextJoin(delimiter, text1, text2, …)
The string which is the concatenation of the strings in the sequence seq. The separator between elements is the string providing this method.
=textJoin(', ', 1, 2, 3) returns '1, 2, 3'
Lower(text)
Converts all characters in a text string to lowercase.
=lower('MAKE THIS LOWER') returns 'make this lower'
TrimLeft(text, [chars])
Removes leading characters from a text string. The chars argument is a string specifying the set of characters to be removed. If omitted or None, whitespaces will be removed.
=trimLeft('abbcwordabbc', 'abc') returns 'wordabbc'
Replace(string, oldString, newString, [count])
Replaces occurrences of a substring in a text with a different substring. If the optional argument count is given, only the first count occurrences are replaced.
=replace('my car is your car', 'car', 'ball', 2) returns 'my car is your ball'
TrimRight(text, [chars])
Removes trailing characters from a text string. The chars argument is a string specifying the set of characters to be removed. If omitted or None, whitespaces will be removed.
=trimRight('abbcwordabbc', 'abc') returns 'abbcword'
Trim(text, [chars])
Removes leading and trailing characters from a text string. The chars argument is a string specifying the set of characters to be removed. If omitted or None, whitespaces will be removed.
=trim('abbcwordabbc', 'abc') returns 'word'
Proper(text)
Converts a text string to titlecase. The first letter in each word starts with uppercase characters, all remaining characters are lowercase.
=proper('make this title text') returns 'Make This Title Text'
Upper(text)
Converts all characters in a text string to uppercase.
=upper('make this upper') returns 'MAKE THIS UPPER'
Len(text)
The number of characters in the (text) string.
=len('hello there') returns 11
 
Insert(text, index, textToInsert)
Inserts a text (textToInsert) into an existing text string (text) at specified index position.
=insert('hey, this is ok', 12, ' not') returns 'hey, this is not ok'
Left(text, count)
Returns a string with the specified number of characters from the start of the text value.
=left('this is sample', 4) returns 'this'
Right(text, count)
Returns a string with the specified number of characters from the end of the text value.
=right('this is sample', 6) returns 'sample'
Mid(text, index, count)
Returns a string with the specified number of characters starting at a given position in the text value
=mid('apple', 2, 3) returns 'ppl'
=mid('apple', -4, 3) looking the index backwards, returns 'ppl'
=mid('apple', 4, -3) getting characters backward from the index, returns 'ppl
Delete(text, index, count)
Removes the specified number (count) of characters from the text string starting at a given position (index).
=delete('this is sample', 4, 3) returns 'this sample'. Here 3 characters after the 4th are deleted.
Quote(text)
Returns a the text enclosed in quotation marks.
=quote('quote this') returns "quote this" (The text, in double quotes)
Rept(text, num)
Repeats text a given number of times.
=rept('Line ', 3) returns 'Line Line Line '
Fixed(num, [decimals])
Formats a number as text with a fixed number of decimals.
=fixed(10.12345, 3) returns 10.123 (up to the 3rd digit after the decimal point)
JustNum(num, width)
Returns a numeric string of the specified size (width) with leading zeros appended to the number. The original string is returned if width is less than the original string length.
=justNum(10.123, 8) returns '0010.123'
Char(number)
Returns the Unicode character or text representation (U+1234) referenced by the given number .
=char(8734) returns the symbol ∞
=char('U+221E') also returns ∞
Code(text)
Returns the number (Unicode code point) for the first character of the text.
=code('∞') returns 8734. The unicode codepoint for ∞
Find(subtext, text, [caseSensitive])
The lowest index in the (text) where substring (subtext) is found. If the optional argument (case) is set to true, case-sensitive search is performed. Index of -1 if (subtext) is not found.
=find('text', 'this is text') returns 8
FindPattern(pattern, text, [caseSensitive])
The lowest index in the (text) where the regular expression provided in (pattern) is found. If the optional argument (case) is set to true, case-sensitive search is performed. Index of -1 if (subtext) is not found. Regular expression is a sequence of characters that specifies a search pattern. Uses ECMAScript syntax for the pattern: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
=findPattern('(Soft)(.*)', 'soft Software', True) returns 5
value(text)
Converts a text string that represents a number to a number.
=value('2e3') returns the numeric value of 2 times 10 raised to the power of 3