VS:IFC DefPsetImport2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created blank page)
 
No edit summary
 
Line 1: Line 1:


{{LocationMain|category=LocationVS|specific=}}
__TOC__
<vwDoc>
-----------------------------------------------------------------------------------------------------------
<desc>
Imports Custom Object Presets from XML, XLSX, CSV or text files.
If parameter is empty, Import File dialog is shown to select the desired file.</desc>
-----------------------------------------------------------------------------------------------------------
<def>
<funcDef lang="vs">
FUNCTION IFC_DefPsetImport2(strFilePath:STRING) : BOOLEAN;
</funcDef>
<funcDef lang="py">
def vs.IFC_DefPsetImport2(strFilePath):
    return BOOLEAN
</funcDef>
</def>
-----------------------------------------------------------------------------------------------------------
<params>
<lineList ident=1>
<line>
strFilePath
STRING
The path to the file. If param is empty, Import File dialog is shown to select the desired file.
</line>
</lineList>
</params>
-----------------------------------------------------------------------------------------------------------
<return></return>
-----------------------------------------------------------------------------------------------------------
<remark></remark>
-----------------------------------------------------------------------------------------------------------
<sample>
<code lang="pas">
PROCEDURE PsetImport;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml}
bOK := IFC_DefPsetImport2( 'D:\Vectorworks\Presets.xml');
END;
RUN(PsetImport);
</code>
==== Python ====
<code lang="py">
# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml
ok = vs.IFC_DefPsetImport2( 'D:\Vectorworks\Presets.xml');
</code>
</sample>
-----------------------------------------------------------------------------------------------------------
<version>
Availability: from Vectorworks 2023 SP6
</version>
</vwDoc>
[[Category:VS Function Reference|IFC_DefPsetImport]]
[[Category:VS Function Reference:IFC|IFC_DefPsetImport]]

Latest revision as of 07:57, 30 July 2024

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports Custom Object Presets from XML, XLSX, CSV or text files.

If parameter is empty, Import File dialog is shown to select the desired file.

FUNCTION IFC_DefPsetImport2(
strFilePath :STRING) : BOOLEAN;
def vs.IFC_DefPsetImport2(strFilePath):
    return BOOLEAN

Parameters

strFilePath STRING The path to the file. If param is empty, Import File dialog is shown to select the desired file.

Example

PROCEDURE PsetImport;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml}
	bOK := IFC_DefPsetImport2( 'D:\Vectorworks\Presets.xml');
END;

RUN(PsetImport);

Python

# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml
ok = vs.IFC_DefPsetImport2( 'D:\Vectorworks\Presets.xml');

Version

Availability: from Vectorworks 2023 SP6