VS:vsoGetQTOFunction

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the requested function during event 84 (kParametricGetQTOValue). The function and the option will determine what value needs to be returned during this event by calling vsoSetQTOValue.

PROCEDURE vsoGetQTOFunction(
hObject :HANDLE;
VAR functionIndex :INTEGER;
VAR option :DYNARRAY[] of CHAR);
def vs.vsoGetQTOFunction(hObject):
    return (functionIndex, option)

Parameters

hObject HANDLE
functionIndex INTEGER
option DYNARRAY[] of CHAR

Version

Availability: from Vectorworks 2022