VS:UpdateImageControl3

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Updates the image control.


Returns false if the image cannot be found or set to the control, otherwise returns true.


This function directly looks for the image file with the input file path, while UpdateImageControl2() only looks into the Vectorworks resrouces folder.

FUNCTION UpdateImageControl3(
dialogID :LONGINT;
controlID :LONGINT;
imageFullPath :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.UpdateImageControl3(dialogID, controlID, imageFullPath):
    return BOOLEAN

Parameters

dialogID LONGINT The dialog identifier given by the command to create the dialog.
controlID LONGINT The identifier of the control to be updated.
imageFullPath DYNARRAY[] of CHAR The full path to the image.

Return Value

Returns false if the image cannot be found or set to the control, otherwise returns true.

Version

Availability: from Vectorworks 2018

See Also

VS Functions:

VS:UpdateImageControl2

VS Functions: [[VS:UpdateImageControl2]]