VS:SetView

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetView sets the view of a VectorWorks document. The projection must be non-plan to modify the view.

PROCEDURE SetView(
xAngle :REAL;
yAngle :REAL;
zAngle :REAL;
xDistance :REAL;
yDistance :REAL;
zDistance :REAL);
def vs.SetView(xAngle, yAngle, zAngle, xDistance, yDistance, zDistance):
    return None

Parameters

xAngle REAL X axis rotation angle.
yAngle REAL Y axis rotation angle.
zAngle REAL Z axis rotation angle.
xDistance REAL X coordinate of view center.
yDistance REAL Y coordinate of view center.
zDistance REAL Z coordinate of view center.

Remarks

Listed example generates VectorScript error due to the units designation after the view angle.


Works for me. Is this a Mac-only problem?


You can also set the view to one of the standard views, like this:

PROCEDURE Example;
CONST
kViewTopPlan        = 1;
kViewTop            = 2;
kViewFront          = 3;
kViewRight          = 4;
kViewBottom         = 5;
kViewBack           = 6;
kViewLeft           = 7;
kViewRightIso       = 8;
kViewLeftIso        = 9;
kViewRightRearIso   = 10;
kViewLeftRearIso    = 11;
kViewLowerRightIso  = 12;
kViewLowerLeftIso   = 13;
kViewLowerRightRear = 14;
kViewLowerLeftRear  = 15;
BEGIN
DoMenuTextByName('Standard Views', IntDialog('Enter a number (1~15): ', '1'));
END;
RUN(Example);

Example

VectorScript

SetView(45d,30d,30d,0,2,2);

Python


Version

Availability: from All Versions